Switched from Ubuntu, WiFi won't cooperate with me

First of all I would like to say hello to all members of openSUSE community.
I’m new in openSUSE but have some experience with Ubuntu (there was also Fedora some time ago). Until now I have never had to ask about help, because I was able to find solution by browsing web. I have never experienced by myself problems like that I have now.

Yesterday I made fresh install of openSUSE 42.3 LEAP with KDE on my Toshiba notebook with AMD APU and “Realtek RTL8188EE Wireless Network Adapter”.

First of all, I haven’t done connection settings while installing system.

  1. WiFi won’t work. Keep asking for password to wifi and kdewallet. (my first experience with KDE, cable connection works)
    I tried with kwallet but cannot make GPG wallet, also tried with blank one. With blank password in KDEwallet manager there was “(1)” displayed next to network when I added password into security settings of that exact connection. But it still keep asking for password (I need to refill password every time). I tried a lot of combinations of settings.

  2. Very bad fronts rendering in Firefox. Changing system fronts settings and Firefox fronts didn’t change anything. But that’s nothing in compare to wifi…

So after about 4 hours without wifi I decided to reinstall and try with GNOME (Fedora with GNOME was ok with my wifi). I was hoping that without KDEwallet it will be easier. And now I’m here with ethernet connection.

  1. WiFi again…
    At first, basis connect, just choose network name and write password but it keep asking for passwd again and again. Also tried adding password in security of my connection, so now it asks for password… with filled password window, so I just click “connect” and after few seconds I see password window again. I tried to make keyring (like with kdewallet) and now it seems to be open, but it seems to be useless now.

  2. Firefox, the same like above.

 > /usr/sbin/hwinfo --netcard
29: PCI 100.0: 0200 Ethernet controller                         
  [Created at pci.378]
  Unique ID: rBUF.YLAopfhREjE
  Parent ID: 8otl.G5Dfw+ssufC
  SysFS ID: /devices/pci0000:00/0000:00:04.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Qualcomm Atheros AR8162 Fast Ethernet"
  Vendor: pci 0x1969 "Qualcomm Atheros"
  Device: pci 0x1090 "AR8162 Fast Ethernet"
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xfa86 
  Revision: 0x10
  Driver: "alx"
  Driver Modules: "alx"
  Device File: eth0
  Memory Range: 0xf0100000-0xf013ffff (rw,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  IRQ: 30 (29849 events)
  HW Address: 08:9e:01:e7:c2:06
  Permanent HW Address: 08:9e:01:e7:c2:06
  Link detected: yes
  Module Alias: "pci:v00001969d00001090sv00001179sd0000FA86bc02sc00i00"
  Driver Info #0:
    Driver Status: alx is active
    Driver Activation Cmd: "modprobe alx"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

30: PCI 200.0: 0282 WLAN controller
  [Created at pci.378]
  Unique ID: y9sn.jFzboAZNCYE
  Parent ID: CvwD.nV9PPa_ZQ2D
  SysFS ID: /devices/pci0000:00/0000:00:05.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Realtek RTL8188EE Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8179 "RTL8188EE Wireless Network Adapter"
  SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  SubDevice: pci 0x0181 
  Revision: 0x01
  Driver: "rtl8188ee"
  Driver Modules: "rtl8188ee"
  Device File: wlan0
  Features: WLAN
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0xf0000000-0xf0003fff (rw,non-prefetchable)
  IRQ: 28 (20701 events)
  HW Address: a4:db:30:3c:1c:3a
  Permanent HW Address: a4:db:30:3c:1c:3a
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000010ECd00008179sv000010ECsd00000181bc02sc80i00"
  Driver Info #0:
    Driver Status: rtl8188ee is active
    Driver Activation Cmd: "modprobe rtl8188ee"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

Any ideas about what I should be looking for? My goal is to make fresh install with KDE, but before that I would like to make wireless connection working.


A few things that come to mind;

  1. Make sure you have kernel-firmware package installed (if you do not and install it, reboot)
  2. Make sure you’re running NetworkManager (YAST -> System -> Network Settings -> Global Options -> Network Setup Method: NetworkManager Service)

In the network applet (bottom right corner taskbar network icon) make sure WLAN is enabled.

Thank you for answer.

I see in YaST2 that I have “kernel-firmware - Linux kernel firmware files” ver. 20170530-9.1
alternative version has the same number.

I’m running Network Manager Service right now. Because during installation I didn’t make network settings I had to change from Network Manager to Wicked to edit connections, but I made that with default settings.
Now it looks like that (in polish language but you can see what’s there):
It says that Wireless Network Adapter is unconnected.

“In the network applet (bottom right corner taskbar network icon) make sure WLAN is enabled.”
It is enabled, I can turn it OFF, but now it’s on and I can see available networks. When I choose my wifi and try to connect it keeps asking for password.

Thank you for your interested in my topic.

It was some kind of router problem, realized that not only my notebook had that problem with new connection. Once it’s restarded it seems to work… shame on me.>:(

Fronts are still a problem, after trying few tricks Firefox fronts rendering is still awful, but not on every site (google search results looks very bad). I’ll try something other.