Switchable graphics and Ati 6600M HD

I’m running openSUSE Factory with all the latest updates. I was able to get the Ati graphics working in openSUSE 13.1, but Factory is so much nicer. I added a repo that had the fglrx package (https://lizards.opensuse.org/tag/ati/) and I have the “nomodeset” option in the bootloader. I also have a systemd service that switches graphics cards, so it SHOULD work, unless I’m doing something wrong. My systemd service looks like this:


#place in /lib/systemd/system/gfx.service
#run 'systemctl enable gfx.service'

[Unit]
Description=Turn off ATI graphics card

[Service]
Type=simple
ExecStart=/bin/sh -c '/bin/echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch'
#ExecStart=/bin/sh -c '/bin/echo OFF > /sys/kernel/debug/vgaswitcheroo/switch'

[Install]
WantedBy=multi-user.target


So here’s the steps I did:

added nomodeset to bootloader
enabled the systemd service
installed fglrx package
rebooted

But I cannot get to X anymore. The fglrx package, after installing, says it failed to build a kernel module, but when I rebuild it manually and use the --force command as it says, then it says it succeeded. (unless it’s a LIAR!!!)

Well you forced it. LOL trying to use the propritary drivers in an alpha build is really hit or miss… You should wait until things settle a bit and try it when the beta releases start in ab couple of weeks I’d guess.

Beta release of what? The FLGRX package? I already found the repo for that: http://geeko.ioda.net/mirror/amd-fglrx-beta/

I’m getting antsy to get ATI working on linux (again). I ran a bunch of Windows 8.1 updates that pretty much ruined my windows intstall. Frame rates in my games dropped from 120 FPS to 30.

13.2 is in alpha now soon to go to beta. But it is experimental at this point meant for testing. You should never expect things to work smoothly when in alpha. If you want to test things great but don’t expect the propritary stuff to keep up. It is not uncommon for it to take several weeks to get the proprietary drivers full up to date

Will be moved to Pre-release/Beta and is CLOSED for the moment.

Moved from Hardware and open again.

Thanks. I’m still confused. Which part is considered beta? The factory part or the catalyst driver?

If it’s the catalyst driver, what can I do to help troubleshoot this to better openSUSE and the Factory version?

I am using the latest factory and the ati beta fglrx driver doesn’t work yet. It isn’t the factory install that is the problem but the fglrx driver (it can’t cope with the latest kernel).

Maybe both ;). In any case Factory is not a released openSUSE version.

Are you using switchable graphcs? Dual graphics cards?

No - I tried the beta driver with two different systems, 1 with a built in ati card and another system with a r290 graphic card

Ok, thanks for the info. Do you know of a repository I should be adding or a site I can keep checking for driver updates for Factory?

The ati graphic driver repo is at:

http://geeko.ioda.net/mirror/