"switch user" on Dual User install does not switch back! How to fix?


I am fairly new to OpenSuse and totally new to Tumbleweed.

First, my system:*
HDD Installed from openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180618-Media.iso
Processor Intel Core i3-2328M CPU 2.2 GHz x 4
Graphics Intel Sandybbridge Mobile
OS openSUSE Tumbleweed
GNOME 3.28.2
OS type 64-bit
Disk 29.8 GB*

Second, my Problem
At Logout I (user1) can easily switch to the other user (user2) on our dual-user system (for system see below*). However, after logging out user2 I can never again login to user1, after entering user1’s ID and Password, the login screen appears again. I have to reboot the system to login again as user1.

This is strange and has never occired to me with other distros.

How can I fix this, please?

Thank you, susecub

The default first graphical user session runs on tty7 – accessed with <Ctrl+Alt+F7>.
The second graphical user session then runs on tty8 – accessed with <Ctrl+Alt+F8>.

Use those key combinations to switch between sessions. I.e. after logging out as user 2 press <Ctrl+Alt+F7> to switch to user (session) one.

Thank you, eng-int! Seems a little bit complicated to me as compared to how Debian and Ubuntu do this.

I am not sure that you understand each other.

I understand that the OP has loged out user1 and loged out before he loged in user2 and again loged out before he tried to log in as user1 again. That means that there is at the maximum but one Grapfical session active.

eng-int talks about the situation where there are two user loged in, using the systems own keyoard/mouse/monotor, for a GUI session at the same time ( that can be different users or the same user twice). Those sessions are then on the 7th, 8th, etc. logical screen.

So please @susecub, can you explain what is the correct interpretation of your problem.

I not fully understand what you mean, sorry, not expert enough. That is what I mean (and only occasionally do, on Debian and Ubuntu):

User2 is logged in, has a problem. I know, I, User1, have a text- or html-file or bookmark for that on my account. So, he goes to the logout menu but chooses “switch user” instead of logout. The Login Screen for both of us appears, I login as me, User1, find the solution, then log out. User2 now logs in again (or however you call it, maybe he was kind of in a “suspend”). He is at once in his own “surroundings” and can continue his work. If finished, he logs out; if I wish I can log in again, with Debian and Ubuntu, that is. But not with OpenSuse Tumbleweed, as pointed out above.

Hopefully I could make myself understandable, hcvv?

Well I was not sure that I understood either!
From another post this morning it seemed that susecub is using Gnome. I made a guess that “Switch User” was an entry under “Logout” in the launcher menu (where it used to be in KDE3), and that is what was meant.

Switch User is a bit weird 'though if two sessions with the same user are attempted. In KDE, when I tried to switch user and login as the same user I was switched back to the original session, which was fine. But then the Switch User option stopped working (nothing appeared to happen) and tty8 was blank. I restarted the display-manager daemon to get Switch User back.

P.S. this was cross-posted with susecub’s reply.

Well, it seems now that this is indeed about a “switch users” functionality in the desktop. And then “which desktop” becomes important.

Thus @ susecub, can you confirm that eng-int’s assumption that you use Gnome is correct?

(in that case I will hang off, because I am not a Gnome user).

Yes, except that’s the way that it used to be.

With Tumbleweed and with Leap 15, I am finding:

CTRL-ALT-F7 gives me the GDM login screen
CTRL-ALT-F2 gives me my logged in session (using KDE).

I have never had a need for switch-user. Well, I might occasionally do that at the command line (in a terminal application with “su”), but not a second GUI login. So I don’t have the user’s experience with this. But I can test if I know what I am supposed to be testing.

Another question for susecub : Are you using GDM for login, or some other login manager? It is possible that you don’t know the answer. However, the following command would also tell us that:

ls -l /etc/alternatives/default-displaymanager

Interesting and more interesting. My description still seem to hold for SDDM (just tested with latest Leap-15.0 and TW).

Yes, but GDM runs on Wayland (not X11) by default, unlike all other DMs, that’s what makes the difference I think.

This can be changed in GDM’s config files though AFAIK.

I cannot comment on current Tumbleweed behaviour, but since I happen to be testing just that on SLED beta (GMC actually) with Gnome, GDM and Wayland-on-Xserver let me describe what I see.
User1 logs in, then “switch user” via the desktop menu…
…brings up the GDM login screen where User2 can login.
If either user tries to “switch user” again, GDM login screen is brought up and choosing one or the other user switches to the relevant (still alive) session.
If either user “logs out”, the GDM login screen is shown: choosing a user still logged in brings to its still alive session, choosing the other (just logged out) user starts a new session.

With this last case I had occasional, not reproducible instances of GDM NOT showing up after logout of one user; disabling “autologin” for that user seemed to help, and I could still find the login screen via Ctrl+ALT+F2 (on SLED, might be F7 on TW as nrickert suggests).
I also recall to have seen something similar to the OP in the past with TW, with Gnome+GDM (but maybe not Wayland) and that was related to GDM sort of crashing IIRC, something to be treated as a bug and reported as such IMHO.

Hope This Helps, even if a bit off-topic.

Yes, I am using gdm

and yes also GNOME 3.28.2

"Authentification failure"
that is what runs very briefly when I “switch user”. It is so fast I did not notice it before.

I mostly use KDE, though I occasionally try Gnome.

I have no idea where to find that “switch user” in Gnome. I know where to find it in KDE, but not in Gnome.

As a test, I logged into Gnome. Since I can’t find “switch user”, I used CTRL-ALT-F7 to get back to the GDM login screen. I selected a different user to login. And I got “Authentification failure” – before I even tried to enter a password.

So I tried again – same user. And this time I was able to login. When I logged out, an attempt to login as the original user failed (repeatedly). But CTRL-ALT-F2 got me back to the original user. It looks as if I can switch between two users with CTRL-ALT-F2 and CTRL-ALT-F3 (assuming that both are logged in).


I’m using Tumbleweed and I’ve been using the switch user facility quite alot for the past years. However, now it’s broken.

From a fresh boot, I first login to my main account, open a browser, check my mail etc. then after discovering the switch user entry is gone from the menu I choose to lock the screen. On the lock screen I choose to login to another account which works fine. I do some work and decides to return the the first user. Again, I lock the user2 session, and click on the first user. First I get an error stating “Authentication failure” (or something like that) then I click on the first user again, enter my password, and nothing happens - I’m simply redirected to the screen listing the two users. Choosing the last active user, user2, results in exactly the same scenario (error mesg., click, password entry, and nothing).

Simply put, changing from one user to another works, but any further switching attempts results in a locked state.

Lenovo T430s, openSuSE Tumbleweed 20180620, Gnome 3.28.2



In the Gnome system panel (upper right corner of the desktop) click on the name of the logged-in user, if at least two users are defined in the system a “Switch user” option should be shown along with “Logout”.
If it doesn’t show up, it’s a bug IMHO.

I think this is what the OP is trying to use. Fiddling with Ctrl+Alt+Fx is a workaround in case of trouble but definitely not the standard procedure.

Well, as most systems will have at least about 20 users defined in /etc/passwd, that can not really be a restriction.

And after @m_hillerstrom’s post, where he states that that worked in the past, I think a bug report is in place.

Apparently system users (those with UID<1000) are not counted, so unless you explicitly define at least two users (say 1000 and 1001) that menu entry does not show.

Hi again,

I’ve got more than 1 user with UID > 999.



OK, UID > 999, that might be the definition used by gdm.