switch language

I have a primary language, Italian, and I want also use a secondary language, English.
I want to switch language in order to have all the writings and messages in English not to write special characters by keyboard.
I switched language in both kde system settings>Regional & language and in yast system>language leaving the keyboard layout Italian, but in the kde menu (the lizard on the left of panel) the groups of applications (multimedia, giochi, sistema) are in Italian and yast too (impostazioni amministratore), instead others are in English.
few questions:
1)is this a bug or I forgot something?
2)which is the differences switching languages by yast and by kde system settings?
3)Is it possible to switch language and don’t restart or logout the system?

1)is this a bug or I forgot something?
2)which is the differences switching languages by yast and by kde system settings?
3)Is it possible to switch language and don’t restart or logout the system?

  1. I suppose that switching languages in yast affects the whole system. Doing that in kde system settings affects just kde programs for that specific user.

I don’t know about questions 1 and 3 as I use only english and have never changed. But:

  1. I suppose it’s not a bug (maybe not everything is translated);
  2. I think that you have to start again the application, the kde session or the system if you change language in an application, in kde, or in the system.
    (Se non si capisce posso scriverlo in italiano).

for 3)
It is of course possible to not logout, etc. but the effect of your change will be minimal then. The language setting is in an environment variable. The environment is inherited from the parent process when a process is started.

When a user changes his language settings this means that in his .profile the variable is set so al child processes will have it. From my .profile:

# Most applications support several languages for their output.
# To make use of this feature, simply uncomment one of the lines below or
# add your own one (see /usr/share/locale/locale.alias for more codes)
#export LANG=de_DE.UTF-8        # uncomment this line for German output
#export LANG=fr_FR.UTF-8        # uncomment this line for French output
#export LANG=es_ES.UTF-8        # uncomment this line for Spanish output
export LANG=nl_NL.UTF-8 # uncomment this line for Dutch output

It will be clear that only a relogin will spread this environment variable to all processes that run from the login.

Same for the systems one, to be sure it is everywhere you must reboot.

To clarify hcvvs comment a bit: any new started program will talk the new language, for example a fresh started Dolphin, right after you switched the language. Programs, that are not restarted (for example the KMenu) will feature the old language.

As hcw says, there are two processes involved. The KDE System settings>Regional and language only affects the input from your keyboard, not the input from applications.

You might get half way to what you want by creating another user and changing their .profile file but I assume this would only affect those applications which were loaded after KDE had read .profile.

However, as least you would not have to reboot, just login to the other user.

May be I am to much wanting to explain it by explaining the mechanisms behind it in the hope that one learns why it is as it is for the future.

Thanks to all who translate my professoral language into plain english lol!

May be, but I expect that the non translatetd things should be in English, the mine ones are in Italian:-)

:slight_smile: It’s ok, your English is better than mine :slight_smile:

But many parts of my kmenu remain in Italian (after switched in KDE and YAST), even after a full restart of the system.

Could it be that you have edited those parts yourself (via KMenueditor)?

No are the standard Italian names given by suse to groups of programs, multimedia, sistema, istruzione divertente etc

Go to the KDE region and language screen and you should have the 2 languages, Italian and English in the list. Move English to the top and logoff and logon. It may be necessary to configure some other applications via their own settings e.g. openOffice. Some may have been installed in an Italian only version.

You may also encounter other bizarre ‘features’. I originally tried to install 11.2 on my laptop in French with a UK keyboard. On each reboot grub kept defaulting to a French keyboard so I reinstalled all in English UK. With the entire system running in English network manager uses French. I appears to have stored the old French setting in its own parameter file which it should not have done.

I may have been better if the KDE project had put a bit of effort into making things more intuitive rather than producing a nice new system that is full of bugs and not yet implemented features