Switch GTX 650 by 1050 - only console (no X) after nvidia blob update

I`m still running 13.2 in this system, for now at least.

I changed the graphics card from gtx 650 to gtx 1050.

Before changing I tried to upgrade the nvidia blob from G03 version 325 (IIRC) to G04 version 375 from nvidia repo using Yast, as I read somewhere that G04 would support the GFX-400 and newer series. But no dice, got a VESA display and Xorg.0.log gave

(EE) NVIDIA Failed to initialize the NVIDIA kernel module.

Reinstalling G03 version 375 worked, so I suppose G04 is not compatible with the 400 series.

Then I switched cards, installing a GTX-1050 from Asus. It would drop to a console, so I used ncurses Yast to install the G04 version 375 again. It appeared to install normally - no error messages in the installation log, but I got the same issue.

Xorg.0.log gives the same error message plus

(EE) No devices detected.
(EE) no screens found

Booting to that other OS I also got a VESA display but after a driver update from the accompanying CDROM the card worked as it should. And it is fast, compared to the old one.

I intend to reinstall everything (a new retail W10 and LEAP 42.3), but this will not be possible for a couple of weeks - a dastard online supplier took my money and then changed the delivery date to “delayed”, so I canceled the purchase and started the process again.

Meanwhile, how can I fix this, preferably using yast and not the hard way if possible?



Couldn’t fix it, had to put the older card back. Sigh…:frowning: