switch from gdm to kdm dosen't work on 11.3

Hey,

after using Gnome on my 11.3 system I wanted to go back to KDE4. So I installed the patterns and now I can choose it from gdm and it works fine.
But if I also try to use kdm, nothing works. I see the kdm login screen without any users. Autologin isn’t set in system settings.

Any idea how to reset all the kdm settings to default?

KDM Screenshot (oxygen theme):
http://www.dansesociety.de/img/kdm.jpg

If gdm and kdm are both installed, you should be able to use both.
So you could for example boot in runlevel 3 (console mode), type ‘gdm’, switch to console, type ‘gdm-stop’ and type ‘kdm’. This works.
Make sure that kdm is installed : rpm -qa | grep kdm
In GDM, start a KDE session and try to configure KDM from there : Personal Settings -> Advanced -> Login Manager.

Of course KDM is installed - see screenshot in first post. But to make sure:


# rpm -qa | grep kdm
kdm-4.5.1-494.2.i586
kdm-branding-upstream-4.5.1-494.2.i586
kdm-debuginfo-4.5.1-494.2.i586   

I think it’s a configuration-issue but don’t know how to reset the settings.

I just told you. Login into KDE grom GDM and see if you can configure KDM from there.
For info: kdm related configuration is written in the file /usr/share/kde4/config/kdm/kdmrc.
I wouldn’t advice you to edit this file without a little bit knowledge … although it doesn’t explode.
But you could type:
grep ‘SessionDirs=’ /usr/share/kde4/config/kdm/kdmrc

to make sure that the outputed directories contain some session files (.desktop files)

You need to get a virgin kdmrc. Either you delete your actual kdmrc, then your kdm will look really strange or you delete and reinstall the package
with the kdmrc. I am not sure in which package it is. I think in kdm, but you can look up in yast2.

Yes, it is in kdm.

Ok, I removed all kdm-related packages, then deleted everything in /usr/share/kde4/config/kdm and re-installed kdm.
Then I changed gdm to kdm in /etc/sysconfig/displaymanager
It’s even worse now: kdm isn’t starting at all, kdm.log finished with “kdmgreet: cannot connect to X server :0”

DISPLAYMANAGER_STARTS_XSERVER ist set to “yes” and DISPLAYMANAGER_XSERVER=“Xorg” in /etc/sysconfig/displaymanager. I also tried to install kdm-branding-openSUSE instead of upstream and change DISPLAYMANAGER_KDM_THEME to “SUSE”, nothing worked.

Perhaps someone can post his/her (unchanged) displaymanager file so I can do a diff.

Or is there somewhere else to look? Otherwise I think I have to use gdm for now.

Try to boot in runlevel 3 (console mode) and start kdm by typing ‘kdm’.
It’s not going to work either but you might get some interesting error messages.

It was not necessary to delete all that files! Just uninstall the packages “kdm” and “desktop-data-openSUSE” amd reinstall them again to get virgin kdmrc and backgroundrc.