Sway will not launch on fresh install (minimal desktop) - does the installer need an update?

I have done an install of tumbleweed today (20230528) and selected the minimal GUI install with the Sway & Open SUSE branding for sway.
After the install sway will not launch - journalctl is showing the following error:

May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [libseat] [libseat/backend/logind.c:310] Could not activate session: Interactive authentication required.
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [libseat] [libseat/libseat.c:79] No backend was able to open a seat
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [backend/session/session.c:83] Unable to create seat: Function not implemented
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [backend/session/session.c:248] Failed to load session backend
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [backend/backend.c:86] Failed to start a session
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [wlr] [backend/backend.c:357] Failed to start a DRM session
May 28 22:50:43 localhost.localdomain sway[2470]: 00:00:00.005 [ERROR] [sway/server.c:73] Unable to create backend

I could log in with the minimal WM and tried a few things. Firstly I added my user to the wheel, video, audio and input groups and then installed seatd (which did not seem to have an effect on reboot).

Secondly I installed KDE and then set the display manager to sddm. On reboot I could then log in to Sway as expected.

Not sure where this should go - is it something that the installer should do (use a different displaymanager for sway) or something else?


This implies that the requested action needs polkit authentication and no polkit agent is available to do it. Is polkit installed?

Thanks for the response. Now there is a polkit.service running (looking at systemctl status) - though I suspect that was because I installed KDE as well.
I am going to fresh install over this disk today and look at the above - am after a more minimal install here for my base system (and use flatpak for apps, and perhaps distrobox for my desire to tinker…)

I tried installing sway on my VM with GNOME and after booting into run level 3, logging in on tty1 as my user and running sway I got some (I assume sway) desktop (I had visual artifacts but that is likely due to using virgl). So you need to provide more details what you do when sway fails to start.

Thanks for looking at this.

When I said sway fails to start I meant I booted the system and got to the graphical login screen. When logging in with sway selected the screen goes black for a couple of seconds then dumps me back at the graphical login screen. Switching to icewm gets to a desktop.

As I noted above if I switch to sddm as the graphical login then it works as expected. So this is just the default installation when selecting the minimal window manager and the sway packages in the installer.

I have not had a chance to investigate more just yet. However, I will try and reproduce with clear steps. The first thing I will check is the polkit running and I will also verify what display manager is being used - perhaps it is a simple case that is not compatible with wayland… With luck I will get a chance tomorrow.

Switch from what? You never told us what you used as display manager.

Only just had time to come back to this and try a fresh install with the 20230622 version. I did get to the same error.
Here I went through the installer and chose the defaults, opting for the Generic Desktop.
Once logged in to IceWM I installed the sway-branding-openSUSE pattern through YAST. On logging out and trying to log in with sway I get the same behaviour (screen blanks then comes back to the graphical login prompt, same journalctl error as before).

In a terminal in IceWM or in another tty

systemctl status display-manager.service

shows that it is lightdm.


systemctl status polkit.service

I can see /usr/libexec/polkit-1/polkitd

Looking in the sway config (/etc/sway/config.d/50-openSUSE.conf) I can see the last line does run

exec /usr/libexec/polkit-gnome-authentication-agent-1

(which does exist on the machine)

Searching online there was a suggestion to try running the command “sway” from a tty - which in this case works fine and I get into a functioning sway session.
Looking at the openSUSE sway page Sway - openSUSE Wiki it does list lightDM as supporting wayland.

So at this point it seems my initial thing of changing display manager is the solution I need to look at. I will try out some alternatives later in the week but will look for something with fewer dependencies than sddm. It just seems odd to me that the default choice of display manager does not support both wayland and X11 - it caught me out certainly.