Suspending via pm-utils worked for weeks, but no longer?

I’ve had my 10.3 64bit system suspending just fine for weeks with pm-utils via ‘powersave -u’ and 2 days ago it failed to resume for no apparent reason. Since that failure I haven’t gotten it to suspend again using either powersave or pm-suspend.

I checked to make sure my /etc/pm/config.d/ file still has s2ram set to forced and I watched /var/log/messages and /var/log/pm-suspend.log for errors but found nothing at all. And I mean nothing… The pm-suspend.log file is empty, zero length. It’s modification time updates each time I run pm-suspend or powersave, but nothing gets written to it. No entries appear at all in messages either.

I have the example 66dummy hook script in my /etc/pm/sleep.d that simply echos information into the log, and not even those are appearing, so the net effect when I run pm-suspend (as root of course) is nil, no visible evidence that anything happens at all!

If I run ‘s2ram -f’ directly, the system does indeed suspend, and behaves exactly as before this pm-suspend mystery began. I’ve only ever directly used s2ram for testing though, since various components (such as my network interface) don’t resume properly without the pre/post prepwork that pm-utils does…

I have reinstalled my hal and pm-utils packages, and I’m completely baffled as to why pm-suspend touches the log file yet doesn’t log anything at all. Since s2ram itself does work when run directly, I’m pretty sure pm-suspend never calls it, which fits with it also not writing to it’s log.

I wasn’t making any changes to my system at the time this started happening, and indeed hadn’t made any software or hardware changes for many days so I have no idea what kicked this situation off.

Any ideas at all?

Permissions of config or script files got screwed somehow?