I am using openSUSE RC1 x86_64 with all the updates and with Gnome desktop environment, and I have a problem when I want to suspend/put to sleep the computer, whenever I click the button it seems that the computer will suspend but nothing happens.

I don’t know much about this myself, but try checking out these two pages and seeing if they help.

S2ram - openSUSE

ACPI Suspend debugging - openSUSE

I had a similar problem in KDE, though I received an error message saying the system couldn’t suspend.

S2ram didn’t recognize my laptop, so it wasn’t permitting suspend. I was able to make suspend work by adding the “-f” option.

Try running the command “s2ram -f” to see if the system suspends properly, that will at least point you in the right direction as to where the problem may lie. You’ll find more details in the links that Trauts posted above.


thank you for the replies,
I will check the pages, by the way I tried “s2ram -f” and then appeared a black screen with a lot of info but the computer wasn’t really suspended, the last line said linux login but the keyboard didn’t respond, so I press the power button and it sent me to my current session.

When I was playing with standby on PCLOS, I was using the openSUSE guide I linked.

Doing s2ram -f worked, but using kpowersave in kde did NOT properly do standby, even after I cheated by adding my laptop to the whitelist and recompiling. Klaptop seemed to work fine. Of course, if you’re using gnome, you probably won’t have an issue on that end, anyhow.

There are a bunch of different tweaks you can try with different parameters to s2ram. Hopefully one of them will work for you!

Well, I discovered that my brute-force approach of adding it to the whitelist was kinda pointless =)

Once you find the s2ram parameters that work for you, try this:

Pm-utils - openSUSE

This is much more elegant and much less painful.