Suspend to RAM

New to openSUSE - installed 11 RC 1/KDE on Toshiba laptop. Suspend to RAM works fine in Ubuntu Hardy on this laptop. In openSUSE I get ‘Could not call DCOP interface to umount external media.’ The problem is, there is no external media that I know of (nothing at all plugged in, no CD, etc.). When I click ‘Suspend anyway’ I get errorcode ‘127’. Is this a known issue?

i have the opposite problem on my vaio; suspend works but after sometime it suspends automaticaly even if i’m watching a film (i’ve disabled it on power-manager).
I’ve completely uninstall it, but no change.
Try updating perhaps you have better luck.

Are you using KDE 3 or KDE4 (both overall and kpowersave)? Cause KDE 4 doesn’t use dcop anymore so if you are using some mix of KDE 3 and KDE 4 packages that could be the source of the problem …

At the time of my original post I was using 11 RC1 which is KDE 4.04. I’ve since upgraded to the 11.0 release which is still KDE 4.04. This is all standard off-the-rack, nothing customized. I still get the DCOP message when trying to suspend to RAM.

Try checking ~/.xsession-errors for any error messages related to kpowersave, or alternatively, shut it down and then launch it from a terminal to view any error messages it outputs.

Please post back anything you find.


Nothing in .xsession-errors for kpowersave. If I select ‘Suspend to RAM’ by rightclicking the kpowersave icon in the tray, I get the error message referred to in my original post. It says in full:

Could not umount external media before suspend/standby. (Reason: Could not call DCOP interface to umount external media.) Would you like to continue suspend/standby anyway? (Warning: Continue suspend can cause data loss!)

This sounds like it can be a Kpowersave issue and not OpenSuse specific.

I did a bit of a search online about this, and it has shown up for a few people on many different distros so it doesn’t sound like it is OpenSuse specific.

I am sure it will likely be fixed soon in an upgrade. Until then I have to live without a suspend if I can’t figure out a fix for people

I had same problem but this message disappeared when I installed KDE3. Also you can click continue and everything works fine(just make sure you dont have external media mounted :))

I’ve HP NX9420 rh450ea and the same problem occurs on it. Suspend-to-RAM works just fine in SuSE 10.3 so i’ve tried downgrading kernel to and Suspend-to-RAM works again.

$ rpm -qa | grep kernel

My /etc/pm/config.d/default:

SUSPEND_MODULES="ndiswrapper" # or any module name for your wireless network interface

I hope it works for you too unless the older version of the Linux kernel is a problem.

Suspend to disk and ram are broken in the 2.6.26 and later kernels.

I can suspend and resume from disk, but no luck resuming from ram…my system just reboots.

I’m on a desktop and suspend works fine. Though I just don’t use it. I hardly ever power down or re-boot and boot up time is so quick I see no advantage of suspend.
SO I guess you either roll back the kernel if that works - or wait for a fix.

If you get a error 127 you should read the log, which states what to do. It’s not KDE’s fault. Have a look at:

For power-management in LXDE, the most reliable and flexible is:
to install, first update hal, dbus, and dbus-qt3.
kpowersave was for kde3 so you have to load old repos like 11.1 to find it but it’s forwards compatible.
Also get kpowersave-lang.
REM: that because of the generational issue the desktop file gets put in opt/kde3/share/applications/kde
newer systems will req and run the devkit-power-daemon