suspend to ram, touchpad not working after resume i2c_hid

I have just acquired an acer aspire e3-111-P60S
It has a synaptics clickpad/touchpad
It works fine, although I had to add a couple entries into /etc/X11/xorg.conf.d/50-synaptics.conf
for middle button click and right click etc…
But when I resume a suspend to ram the touchpad is unresponsive.
I have tried

rmmod i2c_hid
modprobe i2c_hid

this does nothing for the state of my touchpad
I believe this is the driver being used, for when I rmmod the i2c_hid driver I get an unresponsive touchpad
or when blacklisting
when I go to modprobe the i2c_hid driver after a rmmod without suspending, it also leaves my touchpad unresponsive

The touchpad has problems from the start, mind you. It registers as

Virtual core pointer                          id=2    [master pointer  (3)]                                                                                                                   
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]                                                                                                                   
⎜   ↳ SYN1B7D:01 06CB:2991 UNKNOWN              id=11   [slave  pointer  (2)]                                                                                                                   
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]                                                                                                                   
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]                                                                                                                   
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ VGA Webcam                                id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=13   [slave  keyboard (3)] 

SYN1B7D:01 06CD:2991 UNKNOWN

i2c_hid i2c-SYN1B7D:01: failed to retrieve report from device.
   11.439423] i2c_hid i2c-SYN1B7D:01: failed to retrieve report from device.                                                                                                                   
   11.440212] i2c_hid i2c-SYN1B7D:01: failed to retrieve report from device.                                                                                                                   
   11.441045] i2c_hid i2c-SYN1B7D:01: failed to retrieve report from device.                                                                                                                   
   11.441754] i2c_hid i2c-SYN1B7D:01: failed to retrieve report from device.                                                                                                                   
   11.441907] input: SYN1B7D:01 06CB:2991 UNKNOWN as /devices/platform/80860F41:00/i2c-8/i2c-SYN1B7D:01/0018:06CB:2991.0001/input/input7
   11.442130] hid-multitouch 0018:06CB:2991.0001: input,hidraw0: <UNKNOWN> HID v1.00 Mouse [SYN1B7D:01 06CB:2991] on 
   11.488516] mei_txe 00

I also have a problem that when I CTRL-ALT-F(1-6) and then CTRL-ALT-F7 back to graphical, the display is either black
or using KDE Plasma 5 it is at the beginning KDE splash screen with the progress indicator and it stays as this. tried F8-F12 as well.

Any help would be appreciated.

I don’t have a definitive answer here, but I note your output shows that the hid_multictouch driver is in use. What happens if that module is unloaded and reloaded? If this works manually, it can be automated as described here

FWIW, there is a bug report describing similar behaviour for some hardware

There are some workarounds mentioned, but it does seem that a kernel patch was submitted and now included in kernel versions >=3.17, so maybe upgrading the kernel (kernel:stable repo) is worth a shot.

I created a repo to

noticed that kernel-desktop is not in that repo, searched, found that it has been merged into kernel-default for the time being

zypper in -r <name of repo> kernel-default

it upgraded to 4.2.??? and it fixed everything I asked about.
It fixed the suspend to ram problem
It fixed the Ctrl-Alt-F7 problem

Thank you very much for the pointer. SOLVED

Glad to have been of help! :slight_smile: