Suspend to ram hangs machine Asus p52 laptop 11.4 64bit

I’m trying to make suspend works on my laptop. I followed this guide Asus P52F [LinLap - Linux Laptop Wiki] (changing uswsusp.conf with suspend.conf) but without success.
Anyone can help ?


EDIT: following this link The Chakra Project - Forums / Sleep mode / suspend to ram doesn’t work and changing the script suspend works but after resume I have black screen. Any ideas?

On 05/20/2011 12:06 AM, marasciallo wrote:
> Anyone can help ?

you didn’t mention what operating system you are using or what desktop
environment, and none of us here can guess…

but i’ll assume they are same as mine: go Personal Settings Configure
Desktop > Power Profiles and set yours to suspend or sleep as you wish…

however i do not know what you might have solved or broken with that
changing of files by that guide (i could not actually find the guide,
was it written for YOUR operating system and DE? that is to say that the
directions for Red Hat, openSUSE, Mint and etc could all be
different…VERY different)

so, may need to put your system back to the way it was before my
suggestion works…

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

SOLVED: now, after reboot suspend works fine!

Hi! How exactly did you solve the issue? I’m experiencing problems on my Lenovo Z470 with 4GB of RAM running Suse 11.4 64bit (KDE). A moment ago I resumed from suspend to ram and I got a blank screen. Did a ctrl-alt-backspace and that did nothing. No mouse cursor or anything. I had to do a hard reset.


Thanks in advance!

thanks marasciallo, following the link fixed my suspend issues as well.