Suspend, to Disk and Ram, how to wake up ?

Toshiba Satellite Pro
opensuse 12.3
KDE 4.10

I tried both this morning and with to-ram, I cannot make it wake up. I had thought pressing the proper key would do it so I tried
Esc, enter, power, but he is still asleep.

With to-disk, the screen started showing strange displays, like a line flashing on/off, about in the middle of the screen.
Pressing the power button woke it up.

So, how do I wake him up from suspend to ram ?

I started reading posts relating to “suspend” and there millions of them, most of which I have no clue what they are talking about.

On all my laptops they wake from suspend when I either lift the lid (If I closed it to put it to sleep) or if I press any key (if the lid is open and I had put it to sleep with the Fn+F1 combo

For now, press the power button longer than 4 secs. That should turn the machine completely off. Than switch it back on again.

On 2013-08-22 15:56, hextejas wrote:

> So, how do I wake him up from suspend to ram ?

Suspend to ram simply does not work on all machines. How to wake up
depends on the bios and bios settings.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I’ve examined most of the threads concerning suspend to ram and disk in 12.3 and 13.1. I don’t see any solutions.

S2R DID work in 12.2. I decided to upgrade to 12.3 because it seems 12.2 is not getting anymore updates.

Here is my set up:

Linux 3.7.10-1.24 desktop
OpenSuse 12.3 (Dartmouth) (x86_64)
KDE V. 4.10.5 “release 1”

From S2R, the screen contains the usual commands wherein it looks like it will wake up, then the screen blinks, goes back to suspend and does not want to wake up, so I have to do a hard restart.

What is the latest news concerning the suspend function? Thanks in advance!

On 2014-02-06 23:46, HealingMindNOS wrote:
> What is the latest news concerning the suspend function? Thanks in
> advance!

This is very machine specific. On this one, it works perfectly. Better
than ever, in fact.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Thanks for the reply, but what is the fix since 12.3 fails to wake up from S2R? I don’t want to go back to 12.2 because 12.3 is faster.

On 2014-02-07 02:36, HealingMindNOS wrote:
>
> Thanks for the reply, but what is the fix since 12.3 fails to wake up
> from S2R? I don’t want to go back to 12.2 because 12.3 is faster.

Dunno. Maybe there is none. Try 13.1, perhaps.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I had similar problem with suspend on my laptop (13.1-64bit), what I did (not as good power wise but it does not hang the laptop)
In Configure Desktop > Power Management > Energy Saving I unchecked the Suspend Session in both the On AC Power and On Battery tabs.
Also, in Configure Desktop > Hardware > Display and Monitor > Screen Locker enter an appropriate start time, password time (if used) and set the screen saver to a blank screen.

If I close the lid I do not have the wak up problem.