Suspend stopped working - unknown error

While fixing my broken wifi driver (described in this thread RaLink RT2860 won’t connect to D-Link DI-624 router with WPA2 encryption anymore (openSUSE 11.1) - openSUSE Forums), I somehow managed to also break the suspend mode on my eee 1000H.
Neither suspend to disk nor ram work anymore. Instead, I get a screensaver (so much is normal), no suspend, and, after entering my password:

“An unknown error occurred while Suspend to RAM. The errorcode is: ‘1’” from kpowersafe.
It asks “Do you want to have a look at the log file?” - but /var/log/pm-suspend.log is empty, so that’s not a lot of info to go on.

I have installed:
kpowersave 0.7.3_svn3167 / 1.11
suspend 0.80.20081103 / 1.30
pm-utils / 10.3

I’m using KDE 3.5.

When running s2ram without any options, the eee goes into suspend mode just fine - but unfortunately, it doesn’t come back when I press a key - the screen just stays blank.

Any ideas where in the system to poke around in order to find a solution for this?

Hm, it seems that s2ram works now (don’t know what changed). Just calling s2ram from a root console sends the laptop into suspend and pressing a key will resume it just fine. But calling pm-suspend from the root console does… nothing at all.

I get no output whatsoever in /var/log/pm-suspend.log. In /var/log/messages I get:

Mar 22 11:28:52 myeee pm-suspend[11465]: Entering suspend. In case of problems, please check /var/log/pm-suspend.log

and then nothing.

So pm-suspend runs but does nothing?

Issue solved (hopefully)…

So I poked my nose around in /usr/lib/pm-utils/functions and it seems that pm-suspend will check for a file called /.suspended, which is supposed to contain a process id. If the file exists and there is a dir of that process under /proc/, then the script will exit without any error message (grrrr). My problem was that I had an old .suspended file still lying around (maybe it didn’t get deleted during the last wakeup?), but it was empty. So the script just checked if /proc existed and then quietly exited…
Just removing the old /.suspended file solved the issue.

ginkobonsai wrote:
> the script will exit without any error message (grrrr).


but, maybe a trip to bugzilla to growl about the MISSING error message
would also be very nice! <>


Where is that .suspended file ? I commented the function you mentioned about the lock and my laptop suspends again.