suspend/resume problem in 11.0 RC1

On a HP pavilion dv1000 series laptop, using ‘intel’ driver. It has the 855 series chipset.

Resume corrupts video s.t. resizing windows erases the portion ( but gets redrawn later). I tried all combinations of vbe_post and vbestate_restore with same effect. If I switch to ‘i810’ driver, resume works with both above options set to false. I have mandriva 2008.1 on the same laptop in another partition and it works with both the drivers, with the settings false. Mandriva installs xorg version 7.4.

Is this problem resolved in the final ?


And yes, the console always works fine. I can Alt-F2 and do command line tasks.

It might be good to check and see if there is a bug open for this.
If you are expiring it in RC I don’t think it will be fixed at first release.

I’m also using the intel driver but with the 945 GM chipset… no issues here whatsoever.

Have you tried adding other options like;
Option “XAANoOffscreenPixmaps” “true”
Option “MigrationHeuristic” “greedy”
Option “AccelMethod” “XAA”

Also it could help to select indirect rendering for compiz.

After resuming is it enough to logout and back in again to get things running normally again?


I am pretty sure that the solution cannot be found in the xorg.conf file. It has to do with suspend/resume (acpi) and its configuration via hal-info.

And of course, the driver code. The ‘intel’ driver is flaky but it does external monitor better so I want to use it. The ‘i810’ driver is more stable but it doesn’t do external monitor well.

There is also a bug in opensuse 11 where it sometimes thinks it is still resuming when it isn’t ( This somehow causes kpowersave to cause KDE login to block for that user). I tried looking for files to delete but couldn’t find any. I looked under /var/run… and /var/lock…