Suspend / Resume issues with nVidia software

I have a tricky problem with power management. I suspect there’s no solution that will be satisfactory, but I’m posting in hopes that I’m wrong.

Here’s the scenario: The PC is a Toshiba laptop model# x205-s9359 running 11.2, KDE 4.3.5. Its video card is an nVidia 8700 GT.

For two years now I’ve been plagued by random flashes, flickers and even missing scan lines on my screen when I use the nVidia drivers (up to and including 195.36.15), so lately I’ve been using the nv drivers. I miss the effects, etc. but I can live with that. At least I can get my work done, even if the display isn’t as fancy as I’d like.

Here’s the problem:

When I run the nv drivers I can’t suspend the PC to RAM or Disk. This means a lot of wasted time waiting for the machine to shut down and reboot every time I leave my desk for any length of time.

If I try to suspend to RAM the only thing that happens is that the network connection disconnects then reconnects immediately. Here’s the log file.

If I try to suspend to Disk the PC appears to suspend as expected, but when it resumes it hangs before restarting X, and there’s no keyboard or power button response. I have to use alt-prtsc-reisub to reboot. When the reboot is complete the screen shows all the windows, etc that were present before the suspend. Here’s that log file.

When I run the nVidia drivers the suspend/resume functions work perfectly, but I have to put up with all the problems described above. Here’s the log file for Suspend to RAM with nVidia, and here’s the one for Suspend to Disk.

I’ve spent hours searching for clues in these forums, on the site in general, at and with Google and I’m sorry to say that most of I’ve found is horribly out of date, and/or it’s way over my head. or (worst of all) not even dated, so I’ve no idea whether it’s current info relevant to my situation or so out of date that I might do real harm if I were to trust it. (RANT: Is it too hard to put a date on an article?.. end of RANT)

I’d be quite content to use the nv drivers if I could solve the power management issues, but I’d be equally happy to solve the flickering etc. with nVidia drivers. Anybody got a suggestion?

I found a couple of suggestions you could try if you have not seen them before. This was what to do after installing nVidia drivers, but I would try it none the less.

How to use suspend to disk or RAM with the binary nVidia drivers

To use suspend with the binary only driver for nVidia graphics cards, you need to take some extra precautions. Note that this apparently does not work on all nVidia graphics chipsets, YMMV:

Install nVidia drivers

Download the nVidia driver with Yast Online Update, configure the card for 3D with sax2. You might need a fairly recent version of the nVidia driver,

Enable NvAGP

Put the line

Option “NvAGP” “1”

in the “Device” section, after the line ‘Vendor Name “nVidia”’ in /etc/X11/xorg.conf

If you’re on a x86_64 System, agpgart is statically linked into the Kernel. This means you have to deactivate agpgart at boot time. Simply add the “agp=off” kernel parameter to /boot/grub/menu.lst.

Another solution: in /etc/suspend.conf , insert the line:

shutdown method = shutdown

Let us know if this does anything good for you…

Thank You,

Thanks for the information. Unfortunately I tried each suggestion, and I can’t report that it helped. The only change is that, after changing to “shutdown method = shutdown”, when I ran the nv drivers, whether I tried to suspend to RAM or to Disk, when the PC resumed it hung before restarting X, and there was no keyboard or power button response. I had to use alt-prtsc-reisub to reboot. Also, unlike before, I now saw a fresh, clean desktop once the reboot was finished.

I also repeated with the latest stable nVidia drivers (195.36.15, installed “the hard way”, not with Yast)… same results.

Now I’ll change back to “shutdown method = shutdown” and hope for another suggestion .