Suspend/resume broken on ThinkPad X32 [SOLVED]

My ThinkPad X32 doesn’t shut off the backlight when I suspend it. It also doesn’t resume properly. Shutdown works normally. I’m using OpenSuse 11.3 Gnome.

Had the same issue with an install of Linux Mint Debian Edition (201101). It is a well-known Debian issue that has evidently trickled down through Ubuntu to Mint. It also exists in Fedora.

In search of a distro that would handle suspend/resume without problems, I first tried Scientific Linux. Suspend/resume worked flawlessly, but I was not happy with the package manager in SL, which leaves it to the user to resolve dependency issues that are automatically handled by Synaptic in Mint/Ubuntu/Debian and by the Package Manager in OpenSuse.

OpenSuse 11.3 Gnome had the same problem - the backlight remained on upon suspend, and resume didn’t work at all.

I solved this issue by making a simple change in a start-up file in OpenSuse. I’m hoping the solution will work in Mint as well, as it is my favorite distro which I have used for three years.

The solution:

  1. With OpenSuse: open a terminal and type gnomesu gedit /etc/grub/menu.lst. When prompted, type your root password and click OK.

  2. Gedit opens with the menu.lst file displayed. Down the page a bit, you’ll see several sections that begin with “###Don’t change this comment”

  3. The first section gives details for the default boot operating system. Somewhere in this long spec, you’ll find “vga=0x314” or vga=(something different for your system).

  4. Just before or after this part, type “nomodeset” separated from the vga spec by a space.

  5. Save the file and reboot. In OpenSuse, suspend/resume now works normally.

Again, I would appreciate it if someone could let future readers know where the menu.lst file is located under Linux Mint. In the past, I’ve found it frustrating to try to edit the menu spec with Mint 10 versions, which use Grub2. Anyway, thanks.

Do you actually know what the “nomodeset” boot option does? Clue - what graphics chipset do you have and what driver loads when you use “nomodeset”?