Suspend not working

Hi, I am very new here and I am looking for some help. I installed Opesuse 42.3 on my new Asus Vivobook and I am happy so far. All other distros on this laptop keeps freezing the whole computer. Opensuse works well overall. There is one problem though. The laptop is not going to suspend mode. When I put it on suspend mode the screens turns off but the power remains on. It doesn’t respond to the keyboard or mouse. I have to do a hard reset. I am at a loss here. Thanks in advance.

Hi ibenzawla. Welcome to openSUSE Forums. Unfortunately I don’t have a simple solution to your problem, but more information might help others advise further. To start with can you please provide graphics hardware details. That can be the cause of issues like this. You can provide that info using the following command…

/usr/sbin/hwinfo --gfxcard

Report back with the relevant info, and please make sure that you enclose it within

[/COD.] tags (refer to the '#' button in the forum editor). There may well be further questions.

Also, please say which Vivobook model you have and, which optional hardware is present.

Have you installed openSUSE as a dual-boot system?

Hello everyone!
I am having a similar problem since I upgraded my Leap 42.2 installation to the 42.3 version. I don’t know if the thread starter already solved this problem or if lost interest in it but I would like to take the chance to continue this thread and provide you information regarding my issue, hoping to solve it.

I observe the same behaviour as reported by ibenzawla, with the difference that I can in effect put my computer in the suspend mode. However, when I lift the lid (or press the power button) I get the black screen, the keyboard is frozen, the mouse also, the mouse pointer is on screen but won’t nudge.

My laptop is a Toshiba Satellite L50-12G with a AMD Radeon R7 M260.
The output requested by deano_ferrari is the following

/usr/sbin/hwinfo --gfxcard
07: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.378]
  Unique ID: _Znp.vIQ7oLNCqO7
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Haswell-ULT Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0a16 "Haswell-ULT Integrated Graphics Controller"
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xf920
  Revision: 0x09
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xb3000000-0xb33fffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0x6000-0x603f (rw)
  IRQ: 46 (350818 events)
  Module Alias: "pci:v00008086d00000A16sv00001179sd0000F920bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

23: PCI 900.0: 0380 Display controller
  [Created at pci.378]
  Unique ID: x1VA.+YEm2ikm6Y9
  Parent ID: QSNP.VLhJkpe3_N2
  SysFS ID: /devices/pci0000:00/0000:00:1c.4/0000:09:00.0
  SysFS BusID: 0000:09:00.0
  Hardware Class: graphics card
  Model: "Toshiba America Info Radeon R7 M260"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x6900 "Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]"
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xf922 "Radeon R7 M260"
  Driver: "amdgpu"
  Driver Modules: "drm"
  Memory Range: 0xa0000000-0xafffffff (ro,non-prefetchable)
  Memory Range: 0xb0000000-0xb01fffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  Memory Range: 0xb3500000-0xb353ffff (rw,non-prefetchable)
  Memory Range: 0xb3540000-0xb355ffff (ro,non-prefetchable,disabled)
  IRQ: 47 (11 events)
  Module Alias: "pci:v00001002d00006900sv00001179sd0000F922bc03sc80i00"
  Driver Info #0:
    Driver Status: amdgpu is active
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

Primary display adapter: #7


I have to say that I had no problems with Leap 42.2, only after upgrading to 42.3 the suspend to RAM started freezing when waking my pc from the suspend mode.
Thank you in advance

Hi all,

the same problem appears on my laptop HP ProBook 470 G2 with AMD Radeon R5 M255 2GB. No problems in Leap 42.2. Recently I have made clean installation of 42.3. I can suspend to RAM, however after waking up, the screen is black. Nothing but hard reset helps.

My graphics card:

07: PCI 02.0: 0300 VGA compatible controller (VGA)               
  [Created at pci.378]
  Unique ID: _Znp.FCi20V4wLBC
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "512"
  Model: "Intel Haswell-ULT Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0a16 "Haswell-ULT Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x2249  
  Revision: 0x0b
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xd0000000-0xd03fffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0x8000-0x803f (rw)
  IRQ: 47 (20735 events)
  Module Alias: "pci:v00008086d00000A16sv0000103Csd00002249bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

24: PCI a00.0: 0380 Display controller
  [Created at pci.378]
  Unique ID: cuhJ.Jc7rYli0403
  Parent ID: QSNP.pbD4s7UoH4F
  SysFS ID: /devices/pci0000:00/0000:00:1c.4/0000:0a:00.0
  SysFS BusID: 0000:0a:00.0
  Hardware Class: graphics card
  Model: "ATI Topaz PRO [Radeon R5 M255]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x6901 "Topaz PRO [Radeon R5 M255]"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x224a  
  Driver: "amdgpu"
  Driver Modules: "drm"
  Memory Range: 0xa0000000-0xafffffff (ro,non-prefetchable)                                                                                                        
  Memory Range: 0xb0000000-0xb01fffff (ro,non-prefetchable)                                                                                                        
  I/O Ports: 0x3000-0x3fff (rw)                                                                                                                                    
  Memory Range: 0xd0400000-0xd043ffff (rw,non-prefetchable)                                                                                                        
  Memory Range: 0xd0440000-0xd045ffff (ro,non-prefetchable,disabled)                                                                                               
  IRQ: 48 (13 events)                                                                                                                                              
  Module Alias: "pci:v00001002d00006901sv0000103Csd0000224Abc03sc80i00"                                                                                            
  Driver Info #0:                                                                                                                                                  
    Driver Status: amdgpu is active                                                                                                                                
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #16 (PCI bridge)

Primary display adapter: #7

You both appear to be using laptops with hybrid (Intel+AMD) graphics. I’m don’t own such hardware, but hopefully someone more familiar with it can assist here.

  1. While waiting for support, can you both provide info from the following please?
cat /sys/kernel/debug/vgaswitcheroo/switch
xrandr --listproviders
  1. Are you using vgaswitcheroo or prime to switch graphics cards, (or maybe you were unaware of your hybrid graphics architecture)?

  2. I’m in uncharted territory here and no little about what is happening during the resume. It could be a kernel regression. Perhaps its fixed in a later kernel, in which case upgrading to the current stable kernel might help. I haven’t checked for bug reports related to such behaviour, so please understand that this is pure speculation on my part.

  3. It might be possible to configure the graphics cards before suspend takes place so that resuming behaves properly. FWIW, I did find a custom systemd unit file which seems to prepare the integrated (Intel) graphics device so that it is activated at resume…

https://github.com/aelveborn/vgaswitcheroo-systemd/blob/master/vgaswitcheroo-suspend.service

I have no idea whether such a service would help here though. It might take some experimentation.

Thank you,

output from cat /sys/kernel/debug/vgaswitcheroo/switch is here:

0:DIS: :DynOff:0000:0a:00.0
1:IGD:+:Pwr:0000:00:02.0

and from xrandr --listproviders

Provider 0: id: 0x8d; cap: 0x3 (Source Output, Sink Output); crtcs: 3; outputs: 4; associated providers: 1; name: modesetting
    output eDP-1
    output HDMI-1
    output DP-1
    output HDMI-2
Provider 1: id: 0x61; cap: 0x3 (Source Output, Sink Output); crtcs: 1; outputs: 1; associated providers: 1; name: modesetting
    output DVI-I-1
Provider 2: id: 0x3f; cap: 0x0 (); crtcs: 0; outputs: 0; associated providers: 0; name: AMD Radeon R5 M255 @ pci:0000:0a:00.0

I know about my hybrid architecture. It appears vgaswitcheroo is not used in my laptop.
Myabe you are right and this might be fixed with next kernel release. However, since it worked well in 42.2, I did not expect problems in 42.3.
Your help is appreciated.

Well, you could try upgrading to the current stable kernel I guess, and easy enough to remove again if it doesn’t help.

zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel
zypper ref
zypper in --from kernel --dry-run kernel-default

*This will leave the current kernel installed

Reboot, and try the new kernel. Any different with suspend/resume behaviour?

Hello,

my /sys/kernel/debug/vgaswitcheroo/switch reads


0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:09:00.0

and my xrandr list is


Providers: number : 2
Provider 0: id: 0x67; cap: 0xb (Source Output, Sink Output, Sink Offload); crtcs: 4; outputs: 4; associated providers: 0; name: Intel
    output eDP1
    output DP1
    output HDMI1
    output VIRTUAL1
Provider 1: id: 0x3f; cap: 0x0 (); crtcs: 0; outputs: 0; associated providers: 0; name: AMD Radeon R7 M260 @ pci:0000:09:00.0

I had noticed my hybrid cards for some time but never had any issues with it.
I also tried to the newer kernel as you suggested but I must be doing something wrong. I added and refreshed the repo, zypper installed the kernel as suggested but than I reboot and things seem exactly the same, that is the 4.4.92-31.1 kernel is loaded and not the kernel-default-4.14.1-2.1.ga5bca71 as I would expect. Is there something I’m missing. I’m not very experienced with this stuff (e.g. changing kernels).

I also tried to the newer kernel as you suggested but I must be doing something wrong. I added and refreshed the repo, zypper installed the kernel as suggested but than I reboot and things seem exactly the same, that is the 4.4.92-31.1 kernel is loaded and not the kernel-default-4.14.1-2.1.ga5bca71 as I would expect. Is there something I’m missing. I’m not very experienced with this stuff (e.g. changing kernels).

Are you not able to choose it via the grub menu?

My apologies. I accidentally pasted the —dry-run option in the command. I’d used it while testing ahead of my post. It should have been

zypper in --from kernel kernel-default[/CODE]

Ah yes that went allright! But before I commit to any changes I tested it on a openSUSE installed in a virtual box (I am cautious when doing stuff I’m not experienced). I think it installed kernel-default-4.14.1-2.1.ga5bca71 over the old 4.4.92… I think that’s ok but I would like to know how to revert to the old version, or better yet, how do I create a new grub entry for this updated version, leaving the former intact?

If you ran the command to install the kernel-default package from the kernel repo it won’t replace it…

# zypper in --from kernel kernel-default 
Retrieving repository 'packman' metadata ...............................................................[done]
Building repository 'packman' cache ....................................................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  kernel-default-4.14.1-2.1.ga5bca71

1 new package to install.
Overall download size: 59.1 MiB. Already cached: 0 B. After the operation, additional 318.8 MiB will be used.
Continue? [y/n/...? shows all options] (y):

I think that’s ok but I would like to know how to revert to the old version, or better yet, how do I create a new grub entry for this updated version, leaving the former intact?

When you reboot select ‘Adavenced options…’ at the grub boot menu, then choose the kernel to boot from.

Hello,

thank you for help, I have updated the kernel.

Original kernel:

linux-obe0:/uname -r
4.4.92-31-default

New kernel is:

4.14.1-2.ga5bca71-default

And it was good step forward. Now the laptop screen seems to be communicating (a few lines are written on black screen), however system itself does not wake up. But I was wondering, if something is not wrong with amdgpu? See output from kernel update:

(1/1) Instaluje se: kernel-default-4.14.1-2.1.ga5bca71.x86_64 .........................................[dokončeno]
Další výstup programu rpm:
Creating initrd: /boot/initrd-4.14.1-2.ga5bca71-default
dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.14.1-2.ga5bca71-default 4.14.1-2.ga5bca71-default
dracut: *** Including module: bash ***
dracut: *** Including module: systemd ***
dracut: *** Including module: warpclock ***
dracut: *** Including module: systemd-initrd ***
dracut: *** Including module: i18n ***
dracut: Could not find FONT_MAP none!
dracut: *** Including module: drm ***
dracut: Possible missing firmware "amdgpu/raven_gpu_info.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_gpu_info.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_asd.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_sos.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_rlc.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_mec2.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_mec.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_me.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_pfp.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_ce.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_rlc.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_mec2.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_mec.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_me.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_pfp.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_ce.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_sdma.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_sdma1.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_sdma.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_uvd.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_vce.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/raven_vcn.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_acg_smc.bin" for kernel module "amdgpu.ko"
dracut: Possible missing firmware "amdgpu/vega10_smc.bin" for kernel module "amdgpu.ko"
dracut: *** Including module: plymouth ***
dracut: *** Including module: btrfs ***
dracut: *** Including module: kernel-modules ***
...

However, libraries libdrm_amdgpu1, libdrm_amdgpu1-32bit and xf86-video-amdgpu are installed.
And sorry, I have vgaswitcheroo.

​linux-obe0:/sys/kernel/debug/vgaswitcheroo # cat switch
0:DIS: :DynOff:0000:0a:00.0 
1:IGD:+:Pwr:0000:00:02.0

Ok. Does switching way to a VT (eg CTRL+ALT+F2)and back again (CTRL+ALT+F7) help with getting a working display? A bug report might be required to help progress this.

But I was wondering, if something is not wrong with amdgpu? See output from kernel update:

Not convinced of a problem with that particularly.

It seems that the kernel update solved the issue for me. The suspend to RAM feature is fully working now. The only thing I noted with this kernel (i.e. kernel-default-4.14.1-2.1.ga5bca71) is that it does not comply with secure boot, since it didn’t boot for me when the latter was active… but I guess this is no big deal.
Thank you for the help with this issue.

Ok, thanks for the update. :slight_smile:

I have tested the switching to and back and it works without any error.
Besides, I do not know what has changed but suspend to RAM and waking up works perfectly now. I use the new kernel. No other problems appeared.
Many thanks for your kind help.

Glad to have been of help with this. :slight_smile: