Suspend fails (s2ram)

11.2 x86_64, Nvidia 190.53, Geforce 210

I need some help getting suspend to ram working for a HTPC box.Ultimately I’d like this controlled by lirc (remote) but for now I’d settle for getting it to work at all.

If I choose ‘Suspend to RAM’ from the logout menu, I end up in a in console 1 which is unresponsive. In other words, its just like I hit CTRL+ALT+1 but the console is unresponsive - keyboard dead (no caps lock light if used). Fans etc are still spinning.

If I open a terminal, and enter s2ram -f I get exactly the same result.

If I open a terminal and telinit 3, then enter s2ram -f I get the exact same result.

I’ve tried all of the suggestions at and none of them have worked for me. The best I’ve had, is by using pm-suspend, which does appear to suspend the box, but then when I try to resume, I get no video display at all.

I’m beginning to wonder if its an nvidia driver issue. Does anyone have this driver working with suspend to ram ok?


You man need to edit the settings file in /etc/pm/config.d/defaults go to line that states S2RAM_OPTS="". in between the quotes add --force --vbe_save. eg. S2RAM_OPTS="–force --vbe_save" this will force S2RAM and save your video state before suspend and will restore your video state after resume. Also, have you checked to see if your system is in the whitelist?

Should say “You may need…” not “You man…” oops! :slight_smile:

Thanks for replying. No my machine is not in the whitelist as its a custom built htpc. I should’ve explained that I’ve tried s2ram directly from the command line (as root), with all of the -f (force) options, including --vbe_save individually and together. None have worked. This seems to indicate an issue with the nvidia driver - so I just want to know if anyone else has this working with the same driver and card.