suspend doesn't work

I’ve got this problem after kde and kernel update to 4.4.2 and x86_64 respectively. I’ve updated both in the same time so I don’t know who realy screwed it up. Before the update suspend worked perfectly. Now instead of suspend I just get my screen locked no metter what kind of suspend i pick. Somebody help, please. It’s realy necessary for me to get suspend working again.

my machine is
sys_vendor = “TOSHIBA”
sys_product = “SATELLITE A100”
sys_version = “PSAA9E-0R201WRU”
bios_version = "6.00 "

openSUSE 11.2 (x86_64), Linux x86_64, KDE 4.4.2 “release 234”, nVidia GeForce Go 7600, nvidia-gfxG02-kmp-desktop 190.42_2.6.31.5_0.1-8.2

Here are tidbits I found that you might try. Please let us know if it works. I have also heard there is a bug in the present kernel that might prevent suspend from working.

How to use suspend to disk or RAM with the binary NVidia drivers

To use suspend with the binary only driver for NVidia graphics cards, you need to take some extra precautions.

Note that this apparently does not work on all NVidia graphics chipsets, YMMV:

Install NVidia drivers as normal

Download the NVidia driver with Yast Online Update, configure the card for 3D with sax2. You might need a fairly recent version of the NVidia driver,

Enable NvAGP

Put the line

Option “NvAGP” “1”

in the “Device” section, after the line ‘Vendor Name “NVidia”’ in /etc/X11/xorg.conf

If you’re on a x86_64 System, agpgart is statically linked into the Kernel. This means you have to deactivate agpgart at boot time.

Simply add the “agp=off” kernel parameter to /boot/grub/menu.lst.

I found another solution: in /etc/suspend.conf. Insert a line:

shutdown method = shutdown

It is worth a try…

Thank You,

thanks, i’ll try as soon as i get some free time. for now i find out that i can suspend by doing “s2ram --force” from root. it’s not a perfect way, but it works at least)

Well, i’ve finally got some free time. i fegured out that there is no xorg.conf file at all… And modification of suspend.conf didn’t work too (

sudo s2ram -f

should work.

If you add s2ram to sudoers whitelist so that it is configured as nopasswd using visudo then you could just bind the command using metacity gconf editor apps/metacity

googling ‘sudoers editing’ and ‘metacity keybinding’ should find the info for you

then just pressing e.g. F5 should execute s2ram -f or s2ram --force (if you really prefer that)