Suspend aweking failure in Lenovo z50

Hi,
I am relatively new to openSUSE (I used it a long time ago, and have recently tried different Linux distros) and I am trying to run it in my laptop in order to make it my main OS. I am running the GNOME desktop and I’ve liked it a lot, but there is an issue that wont let me move fully to this distro, namely, that when ever I close my laptop’s lid or let it go into hibernation or suspend and try to turn it back on the computer will start running but the screen will shut off, making me unable to unfreeze with out a manual restart. I have looked a lot for the solution to this bug but i have not fond a satisfactory answer yet (I’ve had this problem with other distros to). I was hoping someone here knows how to solve it, my laptop is a Lenovo z50-70 running openSUSE tumbleweed in dual boot with Windows 10, i tried updating the linux kernel but ended up messing up my linux booting system. I hope some one can help me, i didn’t really knew where to post the thread so i went under laptop.

Hi and welcome to the forum :slight_smile:
Maybe some details on the CPU and GPU, not dual graphics is it?

I don’t let my laptops do anything when I shut the lid… I set the /etc/systemd/logind.conf to HandleLidSwitch=ignore rather than suspend.

Hi, thanks :slight_smile:

The CPU is Intel(R) Core™ i7-4510U and it may be dual graphics because it has an NVIDIA GeForce 820M, but i am not really sure or good in this particular matter. I hadn’t thought of that but it might be good, although i have to move the laptop a lot and don’t always like (or can) shutting it completely off to do it.
Thanks a lot for your response.

Hi
Run the following command and post the output;


/sbin/lspci -nnk | grep -A VGA

Also check the BIOS settings for any GPU related settings.

If it is dual graphics I suspect it’s getting confused as to which one to use on resume…

This is what I get when running the command, I dont know if I missed something:


grep: VGA: invalid context length argument

I already checked the BIOS settings and everything seems to be fine. Thanks again.

Hi
Oops that should be grep -A3, apologies.

It’s okay :slight_smile:

i ran the command and got this

juan@linux-bmf0:~> /sbin/lspci -nnk | grep -A3 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
Subsystem: Lenovo Device [17aa:380d]
Kernel driver in use: i915
Kernel modules: i915

Hi
If you just run the command without the grep part, do you see the nvidia card as well? If you have them both then you need to look at bumblebee…
SDB:NVIDIA Bumblebee - openSUSE Wiki and this repo;


http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Tumbleweed/

I’m not sure about it running in Tumbleweed, but in another thread the user was able to switch off the intel card in the BIOS and just use the NVidia one…

I do, i get a second controller:

03:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)
Subsystem: Lenovo GeForce 820M [17aa:380d]
Kernel driver in use: nouveau
Kernel modules: nouveau

so should I download and install the bumblebee package?

Hi
Have a browse of the forum (advanced search, bumblebee and just set the date for say last three months) and have a read, but AFAIK, yes to install, I have no idea how it goes on Tumbleweed.

Thanks,

I will try i then, thanks for your help, i’ll post my result

Hi again I installed Bumblebee and it did it for me, the waking issue got solved. thanks a lot you where really helpful

Hi
Good news indeed :slight_smile: Now go and enjoy and have fun :slight_smile: