SuSEfirewall2 -> firewald

not sure if it was the right way, but it worked for me so it might for others.
I am no expert, my system had nothing fancy firewall related.

on the TW update I got this:

Problem: SuSEfirewall2-3.6.378-2.1.noarch conflicts with firewalld
provided by firewalld-0.5.1-1.1.noarch
Solution 1: Following actions will be done:
deinstallation of firewalld-0.5.1-1.1.noarch
deinstallation of firewalld-lang-0.5.1-1.1.noarch
deinstallation of firewall-config-0.5.1-1.1.noarch
Solution 2: deinstallation of SuSEfirewall2-3.6.378-1.1.noarch
Solution 3: keep obsolete SuSEfirewall2-3.6.378-1.1.noarch

Choose from above solutions by number or cancel [1/2/3/c] (c):

I solved it this way:

pressed cancel.
went to yast and installed susefirewall2-to-firewalld
as root I executed susefirewall2-to-firewalld, it all looked good so did it again with a susefirewall2-to-firewalld -c
then as displayed on the screen when the script is done I did a firewall-cmd --list-all-zones and firewall-cmd --runtime-to-permanent

next went into yast and uninstalled SuseFirewall2 & susefirewall2-to-firewalld
went to services and enabled firewalld so it would startup.
rebooted and tested with systemctl status firewalld.

maybe it helps someone, or maybe it can be done easier/better