Suse12.3 install problems with screen resolution and nvidia GeForce 210

I am trying to do a fresh install of 64bit Suse12.3 Gnome. The PC is a AMD quadcore and the graphics card is a Nvidia GE Force 210.
The install went through without a hitch but it finally booted with display error messages into a 640x480 (4:3) resolution screen.
This the same as what happened when I installed 12.2 last year.
Fortunately I wrote down the command lines that this forum helped me with to get the PC to sort out the Nvidia drivers.
I still can’t understand why the Suse developers cant leave one in a better resolution that one can work with when display errors are encountered. At this resolution some of the windows one tries to use have the Abort Accept buttons in the bottom right corner and you can’t get to them - they are out of reach off the screen! I mean the whole install is done through this card and is in a resolution that is fine to work with. And then we are dropped to 640x480 after boot. :frowning:

Anyway I ran through the commands I had written down:
From the terminal in root:

zypper ar -f http://download.nvidia.com/opensuse/12.3/ nvidia
zypper ref
zypper patch
zypper up

$ su -l

zypper in x11-video-nvidiaG02

This all went through fine and I rebooted.
The boot looked fine and the new spash screen with the suse chameleon on a green vine went through to the blank dark screen - then the cursor arrow (which is now a normal small size) shows at the top left corner of the screen and nothing more happens.
I can move the cursor arrow around and sometimes if I put it into the top left corner I get a white screen which I can only reboot from.
I can get to the command prompt using Ctrl/Alt/F1 and do a reboot from there.
Once upon a time we were able to alter screen/monitor resolutions doing
int 3
Sax2

But this no longer works.
I am assuming this problem is a graphics resolution one
Is there a new way of adjusting the rresolutions from the keybaord/command line?
Where do I go from here?
If you give me command line instructions to feed back to you please also give the instructions to save the outputs so I can transfer them for insertion into my replies. Thanks
I’m currently booted into Ubuntu, one of my alternate boots.:’( BTW Ubuntu is quite happy with the Nvidio card.

This may not work.Try safe mode boot (in boot screen choose Advanced… and then second option). After booting and logging in . Alt+F2==>gnome-control-center==>Display==>change resolution

Can you boot in Failsafe mode?
I’d like to see output of


rpm -qa | grep nvidia

, between CODE tags.

And, in Yast - System - Sysconfigeditor, check if the value of NO_KMS_IN_INITRD is set to “yes”. It should be.

Doing this I boot into safe mode with the 640x480 res. When I try runing gnome-control-centre nothing happens. If I run it setting “in terminal” I have a screen flash and then nothing else.

My Display Error code looks like this

Could not apply the stored configuration for monitors
CRTC 81: trying mode 640x480@73Hz with output at 1280x1024@77Hz (pass 0)

  •                      this line is repeated for (pass 1)*
    

This is the original error which now stayed on the screen for me to write down.

In the console you can login with username and password, then do:


su -c yast

Start the software manager, select the repo view, select the nvidia repo, and check which packages are installed. You should normally have nvidia-gfx02-kmp-desktop installed. Please report.

Okay. Here’s the rpm output

garth@linux-l71t:~> rpm -qa | grep nvidia
nvidia-gfxG02-kmp-desktop-304.64_k3.7.9_1.1-26.3.x86_64
x11-video-nvidiaG02-304.64-27.1.x86_64
nvidia-computeG02-304.64-27.1.x86_64
garth@linux-l71t:~>

And the value of NO_KMS_IN_INITRD is “Yes”
I had to hunt around for where to find it but got in under Kernel.

A long shot highly speculative suggestion: some users with 12.3 and the proprietary nvidia driver have noted inappropriate behaviour, that was fixed only by adding their user to the ‘video’ group and then restarting. Other than some time, it should not hurt to try.

IMO everyone who boots using a propretary nVidia driver and the bootup proceeds past selecting choosing the OS but freezes before the login screen should take a look at the links in my post
http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/484553-12-3-proprietary-nvidia-drivers-combination-broken.html

In particular, look at the bugzilla.
It describes how to gather information, and if your error looks the same as what I encountered, it describes the steps to remove nVidia drivers and install the nouveau driver (which works).

TSU

I posted the simple steps (without explanation) how to “recover” from faulty propretary drivers and install working nouveau drivers instead.

So, without the Gorry Details, this should work
https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/484402-upgrade-12-3-12-2-cannot-start-x-nvidia-3.html#post2537060

HTH,
TSU

Be sure that you remove neuveau if it is still installed I had trouble and that is also one of the things I tried, Note that neuveau may not fully support all 3 D programs. I think it is missing a couple of extensions.

Well this has done the trick! Thanks
Have been contimplating getting an ATI Radeon card to stop this problem in future. What do you think?

I think I followed you intructions ok. What I see intalled is nvidia-gfxG02-kmp-desktop also “G01”
Anyway adding my user to the video group seems to have solved it.

It is a toss up which hardware is having the most problems on the new release. I believe that in the past NVIDIA has done an over all better job then ATI/AMD but that does not mean it is good lol
.