SUSE11 KDE4 Screensavers Problem

I have a new install of openSUSE 11.0 (i586) on a Dell Dimension 9100 desktop pc. Many of the screensavers that come supplied with the new install are causing X windows to freeze. In particular the OpenGL screensavers, eg. Euphoria. The screensaver appears to work ok but when trying to regain focus of the desktop the application crashes and just gives a white screen. The only way to regain control is to stop the X Server with CNTRL ALT BACKSPACE which reverts back to the login prompt. Trying out the screensaver with the test button also produces similar symptoms, sometimes causing the ‘Settings’ window itself to stop responding.

I’m running KDE 4.0.4 >= 20080505 “release 15.2”

When Open-GL screensavers fail, the very FIRST thing
to suspect is the graphics driver. So, downgrade your
graphics driver to ‘vesa’, and see if that changes the behavior.

[Additionally, KDE 4.0 is beta-level, so anytime there is any
problem, you need to switch to some other (non-beta)
desktop to check whether the symptom is related to KDE 4.
KDE 4.0 is especially to be avoided, since most everyone
has moved to 4.1, which is getting active development and

The recommended way to do that is to install KDE 3.5, which can
co-exist with KDE 4.x. Then, you’ll be able to login to whichever
version you want.

Ok, thanks for the direction.

I have only recently changed my graphics driver in order to allow the Google-earth application to work correctly. The previous default installed Radeon driver did not have 3D acceleration and caused the application to crash. My current graphics driver is the recommended fglrx to run OpenGL with 3D acceleration. So I shall put replacing the driver option to one side for now and explore the KDE options.

In line with your recommendation I have upgraded KDE to 4.1.2 (KDE 4.1.1 (KDE 4.1 >= 20080828)) “release 52.2” by using the one click install option at the KDE web site. I then installed KDE3.5 using the backport repository via Yast. The default installation of KDE3.5 did not have any OpenGL screensaver options in the desktop setting configuration so I tried to download and install the OpenGL rss-screensaver package using KDE3.5 and Yast. For some reason Yast has not installed the screensavers in the KDE3.5 nor KDE4.1 desktop setting configuration menu. The only screensavers available for selection are those made available by the default install of KDE4.0 and KDE3.5.

I then attempted to run the available OpenGL screensavers in KDE4.1 and ALL the OpenGL screensavers crashed in exactly the same way they did with KDE4.0.

I then attempted to locate the dowloaded but uninstalled rss OpenGL screensavers in the SUSE file system. The rss OpenGL screensaver binary files were located in /usr/lib/xscreensaver directory. I was unable to locate the default screensavers installed in the KDE desktop. I was able to execute ALL 19 OpenGL screensavers by clicking on the icon in a filebrowser in both KDE3.5 and KDE4.1. I was able to close the window with no problems encountered.

This seems to indicate that:

(1)The fglrx driver is ok.
(2)The OpenGL rss-screensavers appear to work in both KDE3.5 and KDE4.1…although they are not installed in either KDE desktop.
(3)It is the default OpenGL screensavers provided with the initial installation and integrated into the KDE4.1 desktop setting configuration that are causing the problem.

My next step would be to try and install the rss-screensavers into the KDE desktop but I’m not sure how to do this.

Ok. I located the default installed screensavers in KDE4. All the binaries are in /usr/bin/

A typical screensaver binary file is named keuphoria.kss and would simply appear under the name Euphoria in the desktop settings screen. The configuration files are in /usr/share/kde4/services/ScreenSavers/, e.g.KEuphoria.desktop

All of the OpenGL binaries run with no problem in KDE4.1 when I click on them from the dolphin filebrowser. A small window opens and the screensaver runs and the window can be closed again.

Now I don’t know where to go from here.

I have installed a number of additional OpenGL screensavers via the Yast package manager utilising the kdeartwork4-sceensaver and kdeartwork3-xscreensaver packages. The additional screensavers were auto installed by Yast and worked perfectly.

The original (default) installed openGL screensavers STILL crash. They are BitmapFlag, Euphoria, Flux, Gravity, Particle Fountain and SolarWinds. These screensavers are integrated into the KDE4 desktop differently. The binaries are located in /usr/bin/ directory as opposed to /usr/lib/xscreensaver/ and the desktop configuration files in /usr/share/kde4/services/ScreenSavers/ directory are also set up slightly differently to my working screensavers.

I experimented. Copied one of the default binaries to /usr/lib/screensaver/ and tweaked its config file. It ran in the test window but crashed X server on trying to close the window.

I have many working OpenGL screensavers but I’m left confused regarding how these applications should normally be integrated into kde4 and as to why the default installed ones don’t work properly.

My default install of openSUSE11.0 via the live CD KDE4(644Mb) presumably installed the kscreensaver package. The screensaver files that I have on my pc correspond with the files in that package (info taken from debian packages). The openGL screensavers associated with that package all crashed in the kde4 desktop setting window, but worked ok by directly running the binary.

I have subsequently installed xscreensaver and kdeartwork packages. All of the screensavers supplied work with no problems in the kde4 desktop setting window.

I can only assume that the kscreensaver package has problems with regard to the openGL screensavers configuration in the kde4 desktop.

To be honest, I’m a little confused about kscreensaver.Does it work as a standalone package in kde4 without any need for xscreensaver???

I guess I have found the answer to my question. Taken from the xscreensaver website:

Instead of using the usual xscreensaver mechanisms, the KDE folks have chosen to roll their own screen saver wrapper that is inferior to the xscreensaver-demo way of doing things in any number of ways.

The only sensible (and secure) way to use a screen saver under KDE is to turn off KDE’s built-in screen saver, and use xscreensaver instead. How you go about this is explained in the “Using KDE” section of the xscreensaver manual.

In the late 1990s, the GNOME people had the same class of bugs as the KDE folks now have, but the GNOME crew eventually came to their senses, and we worked together to come up with a solution that resulted in their being one and only one xscreensaver configurator, instead of two: mine and theirs.

Then, in 2005, the next generation of idiots took over GNOME, and went back to the “bad old days” by introducing “gnome-screensaver”, so now the GNOME users are screwed again, too.

Will the KDE people ever wise up? Will the GNOME people wise up a second time? Only time will tell. I encourage you to encourage them to stop this “Not Invented Here” madness.