SUSE11 HP Pavilion dv2600tx Laptop - Microphone not working

Hi

I have HP Pavilion dv2600tx laptop with SUSE 11 installed on it. Yesterday I installed Skype and found that the Microphone is not working on it. Then I tried with a default SuSE Microphone Audio recorder application which again unable to record audio.

Could anybody please help me in get out of this problem.

Pleeeeaaaaaaaaseeeeeee…

Welcome to our forum.

I can not help you with skype, as I do not use that software. I “might” be able to help you to generically get your mic working.

When I test my mic, I typically use a simple arecord command. ie something likearecord -d 10 myrecording.wavorarecord -d 10 -f cd secondrecording.wavwhere “-d 10” sets a 10 second recording. I then play back the recording with xine or mplayer or xmms (or any audio playback program).

When advising of the results of that, please make it clear as to whether you were trying your Internal mic or your external mic.

If while recording audio with the basic “arecord” does not work, then we need more information on your hardware/software audio configuration and on your mixer. To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Good luck!

Here is the output of the commands

URL

tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-1.0.16-57.1
alsa-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1

rpm -qa | grep pulse

pulseaudio-module-bluetooth-0.9.10-26.1
gstreamer-0_10-pulse-0.9.5-54.1
pulseaudio-module-lirc-0.9.10-26.1
libpulse0-0.9.10-26.1
pulseaudio-module-x11-0.9.10-26.1
pulseaudio-module-zeroconf-0.9.10-26.1
libpulse-mainloop-glib0-0.9.10-26.1
pulseaudio-0.9.10-26.1
pulseaudio-module-gconf-0.9.10-26.1
pulseaudio-esound-compat-0.9.10-26.1
alsa-plugins-pulse-1.0.16-57.1
libpulsecore4-0.9.10-26.1
libpulse-browse0-0.9.10-26.1
pulseaudio-utils-0.9.10-26.1

rpm -q libasound2

libasound2-1.0.16-39.1

uname -a

Linux linux-pc 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.l7q1YApzaEE:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

OK, I note you have an ALC268.

From that diagnostic script, I note this in your mixer:

cardcnt: 0         
Amixer item options for card 0 [Intel] _________________________________        
  : values=off        
'Input Source'  ; Item #0 'Mic'  ; Item #1 'Front Mic'  ; Item #2 'Line'  ; Item #3 'CD'        

Amixer contents for card 0 [Intel] _____________________________________        
amixer set 'Front Mic Boost',0 0% 0%        
amixer set 'Line In Boost',0 0% 0%        
amixer set 'Mic Boost',0 0% 0%        
amixer set 'Capture',0 Capture 0 0%,Capture 0 0% on        
amixer set 'Input Source',0 Items: 'Mic' 'Front Mic' 'Line' 'CD' Item0: 'Mic'        
amixer set 'Off-hook',0 off  

You have this set to “Mic” but you have Mic boost switched OFF and at 0%. That appears to be a problem.

I assume “mic” is an external Mic? In which case try set “Mic Boost” ON and move it up to a higher % (in your mixer).

If this is an integrated Mic, I think you need to use “Front Mic” ? (I’m not sure) and also switch ON and move up “Front Mic Boost” in your mixer. Again, test using the arecord command I provided in a previous post (above).

Now if the mixer turning does not work, you could try tuning your /etc/modprobe.d/sound file. You posted this:

You could try changing that file to:

options snd slots=snd-hda-intel
# u1Nb.l7q1YApzaEE:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto 

with the idea being that maybe the alsa auto configuration did not work for you. After making the edit, restart your alsa with su -c ‘rcalsasound restart’ and enter root password when prompted and test your mic. I obtained the “auto” parameter from the ALSA-Configuration.txt file for an ALC268 which is has this for the ALC268:

	ALC268
	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
			$CONFIG_SND_DEBUG=y
	  auto		auto-config reading BIOS (default)  

So if “auto” does not work in the /etc/modprobe.d/sound file, replace “auto” with the other entries, one at a time, restarting alsa after each attempt and test your mic. ie the values to try are 3stack, toshiba, acer, dell, zepto.

Now, reference your HP having an ALC268, I preformed a search on the alsa website for the ALC268 and obtained this:
Search results for ALC268 - AlsaProject
I note there are various updates for the ALC268 in the newer alsa drivers, and we can try install one of the updated drivers, if you wish. Let me know, and I’ll point you to a URL in how to update via rpms.

I have tried all with options values in /etc/modprobe.d/sound.

Still microphone not working…

Please tell me the URL to upadte via rpms (Please tell me the complete command as I am new to Linux)

My reference for the commands I am going to provide is:
Alsa-update - openSUSE

I note previous the output of “uname -a” was: Linux linux-pc 2.6.25.5-1.1-pae. Hence please open a gnome-terminal or konsole, and with your pc connected to the internet, type “su” (no quotes) and enter root password. That will give you root permissions in the gnome-terminal or konsole for the following size commands (which you should send sequentially) which need to be sent from that gnome-terminal or konsole. To ensure you do not make a typographical error, please copy and paste them to your gnome-terminal or konsole:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia 
zypper install alsa alsa-oss alsa-utils alsa-plugins alsa-plugins-pulse alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then restart your PC and test your mic. You also may need to retry the /etc/modprobe.d/sound options I suggested above. Note it is VITAL you get your mixer setup correctly. 90% of the users who try to get a mic working completely mess up their mixer settings.

I hope you tried changing your mixer like I suggested. As I noted, 90% of problems with a mic is due to users applying the wrong settings.

I just added the following to the /etdc/modeprobe.d/dound file and changed its values(3stack, toshiba, acer, zeto, test etc)

options snd-hda-intel model=auto

is mixer tuning different from it…

Yes! Tuning a mixer is different.

In KDE there is an application called “kmix” that has one’s mixer settings. I am not a gnome user, but it may be “alsaxmixer” in gnome.

could you please tell me how can I uninstall the zypper installation as my audio players are not working now and also I need to try something

You can always insert your installation CD/DVD, and select to install alsa from it. That will revert you back to version 1.0.16 of alsa.

But I am very suspicious your problem is NOT with alsa, but it is either:
a. you installed the wrong alsa apps (possibly because you changed something else since my recommendation that invalidated my recommendation), or
b. you have a misconfiguration that has absolutely nothing to do with your alsa version.

could you please tell me how can I uninstall the zypper installation as my audio players are not working now and also I need to try something

Uninstalling alsa is not a good idea. You could get dozens of dependency errors. Instead you should downgrade to the version of alsa that came with openSUSE-11. I already explained to you how to do that. ie as I already noted:

You can always insert your installation CD/DVD, and select to install alsa from it. That will revert you back to version 1.0.16 of alsa.

My guess is you also made a mistake with the updating of alsa using zypper. I can help you there quite possibly. What is the output of:
rpm -qa | grep alsa
rpm -q libasound2
uname -a
If you paste here the output of those commands, I will be able to tell if a mistake was made.

This thread helped me a lot :wink:
I had to fix the no-microphone problem on three different computers, and in two cases I had to edit /etc/modprobe.d/sound and supply an explicit option - in the case of my ULI M5461 on-board chip (on an ASRock 939 board) I even had to supply an incorrect ‘asus-laptop’ option to the ALC660 codec to get it to work, as ‘auto’ didn’t. Chip and codec information can be got with arecord -l, the list of applicable options is in ALSA-Configuration.txt
Btw, the wget link for tsalsa didn’t work for me, but there is a tsalsa RPM on the packman repo.
Oh yes, the wrong channel on alsamixer also applied in one case - as well as Skype needing an explicit ‘Sound in’ (not just default) device in Skype menu->Options->Sound devices.
I had a more or less default SuSE on all machines; so I imagine that a lot of people with the same problem might solve it the same way: anyway, it’s easier to reverse that an ALSA update, so try it first.
Cheers, avocadohead

Thanks ! Development of the tsalsa script has stopped. The developer of that script is now joined into helping the developer of the alsa-info.sh script, into supporting the alsa-info.sh script. That later (alsa-info.sh) script now is part of alsa (as of 1.0.17 of alsa).

Glad to read the thread was of some help.

Hi, I could make my Mic work on an ALC268 my HP Pavilion dv9535us.

To do that, I had to edit the alsa file and use model=acer:


       nano /etc/modprobe.d/alsa
       #use this line: options snd-hda-intel model=acer
       update-modules
       /etc/init.d/alsasound restart
       alsamixer


On the alsamixer, hit tab to change the view from “Playback” to "Capture"

This were the settings that worked best for me:


Front Mi: 0
Line In: 0
Mic Boos: 0
Capture: 27
Digital: 0  -> this sould be 0, not not a negative value like -30
Source: Front Mi

To test:


   arecord -vv -fdat -d3 foo.wav
   aplay -vv  foo.wav

Also, at the beguining speak with your mouth very near the Microfone. The built-in mics are sometimes directional and won’t pick up your voice. After you got it recording you can change the settings to something better for you.

You should see the bar ranging from 70% to 98%.

Anything much lower than 50% and your settings are too low.

If you see the bar always near 99% or hear any clicking noise it is becouse some of your settings are too high. Try setting the Digital or Capture (or the boosting) to a lower value.