suse11.4 screen again

I have written about it before with the upgrade of my old laptop ( further below). Because this laptop was 7 years old I bought a new Asus K52F-SX223V (64bit processor) today. In the shop it booted OK with the live CD. I took it home and installed Suse11.4. After the install it booted OK - did the online update and then the same thing as with my old laptop. Next boot brought only the background - no right click, no menu, nothing. Throw out the GUI with Ctrl Alt F1 and log in. Tried startx – :1 response:
Xauth: file /home/uli/.serverauth.5579 does not exist
Fatal server error
Cannot move old log file /var/log/Xorg.1.log to /var/log/Xorg.1.log.old
xinit giving up
xinit unable to connect to X server: Connection refused
xinit server error
xinit failed. /usr/bin/xorg is not setuid, maybe that’s the reason.

This was the same I had before which righted itself without me knowing why yesterday on my old laptop.
Loging in as root (network disconnected and startx – :1 worked - as root into the GUI - logged straight out again).

looked in /var/log/Xorg.0.log foung these lines:
falling back to old probe method for fbdev
further down
falling back to old probe method for vesa

Otherwise the install CD worked without error. MD5 sum was correct after download - I checked before I burned the DVD. Unfortunately the computer is not yet configured completely for the network so I scribbled the items above down and wrote them out again. Any ideas anyone?

I got a bit further with browsing the internet.
First thanks to oldcpu with his contribution in these forums:
openSUSE Graphic Card Practical Theory Guide for Users
/sbin/lspci -vv showed:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 1be2
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 45
Region 0: Memory at d0000000 (64-bit, non-prefetchable) [size=4]
Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256]
Region 4: I/O ports at e080 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

I am still not quite sure what driver would be the right one, but for now I used the Intel and so far it seem to work. Advice for better drivers is appreciated.

I thought the screen issue is solved. Everuthing was working yesterday. I spend over 3 hours getting the webcam working (with image upside down at first - see laptop forum) and installing skype and everything worked fine. Today the screen problem again! cannot start GUI except from root with startx – :1.
Not even failsafe works now and the computer hangs during failsafe boot witjh the last lines:
Boot logging started on /dev/tty1 (/dev/console) at Wed April 27 20:09:24 2011
Master Resource Control: Previous runlevel:N switching to runlevel:
Master Resource Control: Running /et/init.d/before.local
blogd: system console stolen at line 266 (this line is printed in red)
blogd: Can not read from fd0: Input/output error

And there it stops not reacting to Ctrl Alt del or any other key combinations. What is going on. I switched from Redhat/Fedore to suse at version 9.2 and it was always rocksolid and no major problems and now with 11.4 this. I cannot run a system which is starting once and not the next day!
Any help URGENTLY is appreciated.

How did you get it to work before? Did you try the intellegacy driver because you have an older system?

There is a bug report, where some users of Intel Integrated graphics have discovered that the vga=0xZZZ in the grub boot menu interferes with the laptop Linux boot loading.

You could try, when booting, to backspace that line out of grub boot manager menu, and see if that makes a difference with and without the ‘nomodeset’ boot code, and with and with out the ‘x11failsafe’ boot code.

I sense you are posting that there is a randomness to this working and not working, and it would be useful to obtain a better cause and effect associated with this. Do you encounter this only when rebooting from MS-Windows to Linux ? or do you also encounter this when switching on direct to Linux after a cold start ?

For future support cases, its far more helpful if you use the command:

/sbin/lspci -nnk 

… and then for graphics look for the line with ‘VGA’ in it , and copy that line and the subsequent three lines and post here. They provide more useful and succinct information.

Thanks, gogalthorp, I used the intel driver and it seemed to work. The laptop is new.
Hi oldcpu, I cannot copy the lines but I type them out - the network does not connect. Here are the lines.
“00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:3b64] (rev 18) Subsystem: ASUSTeK Computer Inc. Device [1043:1f27] Kernel Driver in use: i915”
You see that the driver i915 is there even though the /etc/X11/xorg.conf.d/50-device.conf file has the lines ‘Driver “intel”’
I have only booted into Windows once at the start. Then installed Opensuse11.4 (clean install) and since then every boot goes straight into Linux. I don’t use Windows (unless I need the computer and I haven’t got this problem fixed). I had problems with Linux before but not like this where I cannot use the computer at all. I don’t assume randomness - however I think there might be something very seriously wrong with the 11.4 version and graphics as I had the same problems with my old laptop after an upgrade from 11.3. Tis laptop had a Radeon graphics card and it seems to be fixed but a lot of things I cannot do there (only 512MB of RAM, etc…). However I have a suspicion: I have a 64bit processor and of course I installed the 64bit system. However Skype runs only on 32 bit. At first I tried to make symlinks but got the response something like “wrong ELF… class…” so I installed the 32 bit libraries required. This might have upset the system as the computer did not start since then and I must admit I have no idea where to look now.

The menu.lst file has the line vga=0x317. I have now commented this out and booted up again - no change except that the fontsize of the text is larger at the beginning but then switches back after a few lines. (I boot without the splash screen). With the nomodeset the whole boot process has the larger letters and it does not even attempt to boot into the GUI. The startx command brings as before:
“Tried startx – :1 response:
Xauth: file /home/uli/.serverauth.5579 does not exist
Fatal server error
Cannot move old log file /var/log/Xorg.1.log to /var/log/Xorg.1.log.old
xinit giving up
xinit unable to connect to X server: Connection refused
xinit server error
xinit failed. /usr/bin/xorg is not setuid, maybe that’s the reason.”
I don’t know what to do next.

I just tried one more thing - I typed modprobe intel (intellegacy, vesa …) each time i received the answer:
Fatal module not found. However when I typed modprobe -r i915 the answer was Fatal module in use. So I went into yast to update the xorg drivers. Rebooted and the GUI is there as it should be. What I don’t know is how these modules were lost - yast marked them as installed and they worked before. I hope that it is fine now and the modules don’t get lost when I install something else.

The last xorg-x11-video-drivers update was almost entirely update for the intel driver.

Note when the “intel” driver is specified, dependant on one’s hardware, the i915 will be loaded. So likely that was correct in your case.

I recommend you post in our network subforum area asking for help here. Network/Internet Note also, when logged in as a regular user in a full screen text mode, one can type “su” (no quotes, enter root password) one can type ‘yast’ and launch the ncurses version of the yast configuration tool, and use it to configure one’s network card.

You state ‘the same problems’. What problems ? If you installed from same installation CD/DVD that could mean a bad installation CD/DVD.

I confess I can make no sense out of what you typed there. Do you mean you think that your installing Skype and trying to run it caused a problem ?

That makes little sense to me. I have Skype running on a 64-bit openSUSE with no problems (with AMD Radeon graphic hardware, and also nVidia graphic hardware).

… and ??? ?Does it go to GUI, or only get as far as run level 3 full text screen log in ? Its VERY DIFFICULT to understand your posts, as I think you are assuming we can see over your shoulder and know exactly what you mean ? We don’t know. You need to tell us these things.

This is on what laptop? The one with the Intel hardware ? or the one with the Radeon hardware ? Does this mean with the vga=0x317 removed that the X GUI attempts to start ?

That reads to be strange. Such a copy operation should work. Possibly a bad install ?

I can’t tell what your symptoms are … you have two laptop configurations mixed in here, and describe booting with nomodeset and with the vga=0x317 removed and I have no idea as to what was attempted. Imagine yourself to be someone who knows nothing about your PC nor what you tested, and try to piece together what you attempted. Its not clear !

As already noted, there was a recent update to the xorg-x11-video-driver rpm, and since you now appear to have managed some sort of network access, its possible the update to that rpm (with its updates to the Intel driver) helped ?

Sorry, oldcpu, it was late yesterday when I checked if there was an answer on the forums. No need for the Network forum - I log into my network through a script in .bashrc and that does not work when I throw myself out of the GUI to log in with the commandline.
Forget about my old laptop. I had the same problem there when I upgraded from 11.3 to 11.4. GUI without rightclick and without menu. Downloading the last Radeon driver solved this problem but not the low hardware specs which caused other problems even with LXDE. That’s why I bought this new laptop and did a clean install.
I checked the MD5 sum after the download but haven’t checked the install DVD. You may be right that there is a problem. I did a media check however which came up without error.
Installing Skype withh the 32bit libraries and xawtv was the only thing I have done before the reboot after which the GUI did not work any more. It may not make sense to you but I thought there might be a relation to the GUI not starting any more. On my AMD/Radeon laptop this was no problem either. But that was all I could think of. I was trying to find a reason why this happened as I don’t believe it is random.
Re commenting out the line vga=0x317. Except for the change in font size nothing changed without the nomodeset boot - that meant it boots into the GUI which has no rightclick or menu facilities. With the nomodeset command it does not boot into the GUI - only runlevel 3. But the startx command does not change anything. This is on my new laptop - the old one is working now.
Re the line “Cannot move old log file /var/log/Xorg.1.log to /var/log/Xorg.1.log.old”. I know this looks strange but that is the response I received from the computer. Strange especially since the file /var/log/Xorg.1.log.old" does exist.
By the way I typed yast in the commandline to update the drivers. The xorg-x11-video-drivers update was done this way. I could have manually mounted the NFS server to copy the files across but I admit I don’t know how to copy text from the commandline in runlevel 3 - only from the bash shell in the GUI. Do you say when I type Driver “intel” in the /etc/X11/xorg.conf.d/50-device.conf file that it will load the i915 driver? After entering this line the computer booted correctly into the GUI.
Now to something strange. Now - this morning I started my laptop after it worked with the driver update and again I could not boot into the GUI. After another reboot it suddenly worked. I would be very happy if this problem could be sorted that I can reliably boot into this laptop. Thanks for your help - I will try to be more clearly next time, even if it is late at night.


When you booted Linux this morning, was it from a ‘cold start’ or was it in a reboot from ‘MS-Windows’ ? When you encounter this problem, does an immediate reboot always work ?

I only boot in linux - I have no need for Windows - so yes it was a cold start. I sometimes need word2007 for the maths equations to write edit scripts which come in this format. I therefore installed wine this morning and configured the printer. Now I tried several times to boot into my laptop and again I don’t get into the GUI. So an immediate reboot does not always work. I have no idea what can cause this.

This random behaviour is a bit bizarre, especially if it can take multiple reboot attempts (in one session) from a cold start to kick off the GUI. Possibly the only thing I can think of is there is a timing problem with the boot process that varies from boot to boot. What happens if you disable the parallel boot by going to /etc/sysconfig/boot:RUN_PARALLEL and try a different setting (such as NO). That can also be done under YaST > System > /etc/sysconfig Editor > System > Boot > RUN_PARALLEL and set that to “NO” and click OK and exit.

As you mentioned timing. When I log in and the background screen comes and nothing happenes and I go ctrl, alt and f1 to be thrown back into the commandline the computer is only at the configuring of the network card. After I changed the setting to RUN_PARALLEL to no and rebooted the login screen comes up after configuring the interfaces. When I log in, again only the background image appears and no menus no rightclick. So it does not make any difference only the booting process is longer.

and if you disable special desktop effects and leave them disabled ? Same behavior ?

Something else now caught my attention. When I shut down the computer with RUN_PARALLEL to yes the first approx 15 lines which came up read: “FIBMAP: invalid argument”. I disabled the desktop effects and set RUN_PARALLEL to no again. I booted into the desktop now 3 times and it worked each time and these lines did’t come up during shutdown. May be this tells you anything what can be wrong? Anyway I don’t need the special Desktop effects, I need a working computer and if everything is OK now that will do me.
Thanks a lot

I confess it does not tell me much, but three times in a row is encouraging.

There is a kernel preload program called “preload-kmp-default” or something like that, and maybe its struggling with special desktop effects enabled and sets things up incorrectly for the next boot when you shut down with special desktop effects enabled ? … now that is wild speculation and I think I need to apply for the ‘golden globe speculation’ award after suggesting that ! :smiley:

… anyway, let us know if you continue to have success after a dozen or so boots.

Your experience is very similar to mine. Mine is a Samsung R528 Laptop. The graphics hardware is Intel.

output of lspci --nnk

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
	Subsystem: Samsung Electronics Co Ltd Device [144d:c06d]
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)
	Subsystem: Samsung Electronics Co Ltd Device [144d:c06d]

It is baffling that this problem is not reproducible exactly. What settings you had when the intel i915 driver had correctly loaded, does not produce the same result when repeated again! It is as if the kernel knew what you did earlier and deliberately refused to do the same thing next time.!

What is so frustrating is once the i915 module has successfully loaded it works excellently with all glorious desktop effects working flawlessly. But once you shut down and repeat the booting with the same parameters again it will not complete the boot.
Once the boot hanging starts no matter what you do nothing will get the GUI,and you have to fall back to failsafe settings (The failsafe entry in the grub menu) which load the so called fb driver. The major draw back of this driver seems to be it will not allow you to switch the desktop resolution from the default 1024x768 to the natural one of the Laptop screen. (In my case it is 1366x768). with the result the screen looks squashed and ugly.
I had tried a large variety of combinations of boot parameters as suggested in this forum and various forums of other distros. These include the run_parallel=no and blanking the VGA=xxx parameter, even turning off the desktop effects as suggested by OLDCPU had no effect on this behavior.

I had even tried the latest xorg video driver compiled for 11.4 at this repo

Even this driver does not change anything.

Currently only viable option for me is the intellegacy driver. This driver allows the GUI to switch the desktop resolutions and will enable the correct monitor resolution of the laptop.(in fact there is no noticeable difference from the i915 driver. But even this driver will work (at least in my case ) only when the desktop effects are turned off.

To get this driver working I did as follows

I booted into the gnome desktop using the failsafe setting first. This automatically turns off the desktop effects. After that i did the following steps

I added nomodeset boot parameter on the grub entry by editing the ***/boot/grub/menu.lst ***

# Modified by YaST2. Last modification on Sun May  1 01:53:48 IST 2011
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,7)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.4 -
    root (hd0,7)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-SAMSUNG_HM250HI_S20TJ9BZ514831-part8 resume=/dev/disk/by-id/ata-SAMSUNG_HM250HI_S20TJ9BZ514831-part7 splash=silent quiet showopts nomodeset
    initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.4 -
    root (hd0,7)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-SAMSUNG_HM250HI_S20TJ9BZ514831-part8 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
    initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1

and added the relevant code in the /etc/X11/xorg.conf.d/50-dev.conf file

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
   Driver "intellegacy"
  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


After doing this i can reboot into to the GUI always. and I have a reasonable working 11.4 atlast.:stuck_out_tongue:

Even though I miss the snazzy desktop effects, (I donot know about the status of other effects like 3d hardware acceleration, HDMI etc. since I donot need them in my work)
As for the reason of all this trouble may be a combination of many issues and the instinctive reasoning of the seemingly inexhaustible and vastly experienced user like OLDCPU in the earlier post # 17 could very well be true.
But rightnow I can only will wait for the day when the Linux Kernel with KMS and Intel Graphics eventually sort out the issues between them. I am sure this will be done sooner as this issue seems to be general and affecting all distributions very much.

ussivam, thanks for your post and sharing your experience/work-around solution.