Suse11.1 no sound

Helllo , I’m running Suse 11.1 and I have this problem:

while running movie with mplayer from the terminal the sound is fine. But when I try to play something else there is no sound. Even in youtube there is no sound. The sound manager in Yast gets my sound card, but when try to make a tets sound - Nothing?Any suggestions please ??

You have working sound? Just not when two applications are trying to use it? Correct?

This can be a problem. oldcpu to the rescue me thinks.

Hang on, he’ll spot it, he’s online.

Something to do with this:
SDB:AudioTroubleshooting - openSUSE

Ok, it appears you may have a couple of problems.

First, I note you state you can play a movie with mplayer from the terminal. Great ! So basic sound works. … As an aside - install smplayer from packman. Its a front end GUI to mplayer and it is great! Incredible even. :slight_smile:

Reference youtube. That could be your browsers ability to play flash. Some 32-bit and 64-bit users have discovered if they keep flash-player but remove libflashsupport, their audio will work. Try that. Maybe also let us know if your PC is a 32-bit or 64-bit ?

As for YaST test sound not working - there is a known bug in YaST sound module where for some sound cards the test sound does not work.

If you want to test your sound, take a look at step#1 here: SDB:AudioTroubleshooting - openSUSE - How to Test your sound

Thanks I will try my PC is 64bits

I have tried all of thise:
11.1 NO sound with 82801I (ICH9 Family) HD Audio Controller - openSUSE Forums

by the way, my sound card is the same ,when I tipped

speaker-test -c2 -l5 -twav

There was sound. I also run


the result :

rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

this output is :

linux-ha2a:/home # rpm -qa | grep alsa
linux-ha2a:/home  # rpm -qa | grep pulse
linux-ha2a:/home  # rpm -q libasound2
linux-ha2a:/home # uname -a
Linux linux-ha2a #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
linux-ha2a:/home # cat /etc/modprobe.d/sound

Still no sound :frowning:

I’m confused.

You stated sound in mplayer. and stated:

So there IS sound in a test !

But then you stated:

No sound where? With flash and firefox? You may have a 64-bit PC flash problem - in which case, I probably don’t know enough to help you there with wasting a lot of time hunting back and forth with various ideas. Someone else who can “cut to the chase” quicker with setting up flash on a 64-bit system should step in here.

Did you try smplayer?

Yes I tried smplayer but again nothing . I didn;t get how when testing in terminal there is sound : mplayer, the test sound left, right… but when I tried with vlc for example no sound?

There should be should in smplayer if there is sound in mplayer. Note smplayer lets one select the sound engine. Go to smplayer > options > preferences > audio and try different output drivers.

Some with vlc. Go to vlc > tools > preferences > audio > output and try different settings.

Also try it with different files, to ensure its no some obscure format that is causing the problem.

Hi, I think I get the problem. When I run a program Xmms to play a file - no sound , but when run it from terminal as su yes the sound is ok how to fix that??any ideas??

Try adding your regular user to group audio. Follow the guidance here in step#6: SDB:AudioTroubleshooting - openSUSE - how to fix permissions problem - step#6

Then restart your pc and test.

Thanks man . Now the sound is OK :slight_smile: