SUSE wont start after gtk2 installed through Yast

My SUSE’s graphic desktop wont start anymore after I tried installing an updated version of gtk2 (because firefox 3 required me to install a newer version)

Now I only have my login prompt and when I run startx on my prompt, I get the error

/opt/gnome/bin/gnome-session: symbol lookup error: /opt/gnome/lib/libgtk-x11-2.0.so.0: undefined symbol: g_hash_table_ref

Please help me out.

Alan

First of all - how did you install the GTK2 “update”? With RPM? Zypper? YAST?

As a diagnostic please post the output of the following commands:
cat /etc/SuSE-release
**
zypper sl -d
**
rpm -qa | grep -i gtk

Note that the SuSE is written exactly like that, capital S’s and E.

If you are unable to copy paste the following information in any way, you can always restore the old gtk by running yast from the command line as root, you can navigate the menus with tabulator and cursor keys + enter and going to software management, then searching for gtk.

Since there is no restore button, I am attempting to first delete it then install again.

When I try to delete gtk2 through the commandline-gui, there are like 50 dependencies error to solve.

Is there a quick way to skip going through the 50 dependencies to press “ignore” ?

Thankyou, and Sorry copy and paste does not work.

You should not delete it, you should choose reinstall for gtk.

Did you add any repositories in order to upgrade the gtk? If you did, remove repositories first.

under the Action menu,
i only see

Toggle
Select
Delete
Update
Taboo Yes
Taboo No

I dont see a reinstall option

If you press space on the gtk in the “main window” (where you can scroll between different programs) it should make a > (reinstall) in front of the filename, instead of the i (installed).

Alternatively you can go to shell and type, as root; rpm -e --nodeps gtk2 (or whatever the package is that you wish to remove) and then go back to yast and install the package.

As for the dependencies unfortunately you have to manually select the proper action for them. (Most likely downgrade)

Thanks Alot Chrysantine for your quick reply!!!

I fixed it and now i can resume my work!:slight_smile:

While I am on the subject, I am trying to install firefox3.0 in my distribution.

I unpacked the .tar.gz and when i try to run ./firefox

I get the error

You have GTK+ 2.8; GTK+ 2.10 required.

That is the very reason I installed gtk which in turn breaks my startx.

Should i start a new thread. or can u answer my question here?

i got my repo from
http://download.opensuse.org/repositories/home:/psankar/SLE_10/i586/gtk2-2.12.3-10.2.i586.rpm

You’re running SLES 10? SLED 10?

Hmm, seems like the repositories indeed only contain 2.x series - that is very odd.

If you’re running SLED or SLES; you might want to try the SUSE Linux Enterprise Desktop (SLED) - NOVELL FORUMS (SLED) or SUSE Linux Enterprise Server (SLES) - NOVELL FORUMS (SLES) as people there are more familiar with those distributions - we mainly deal with openSUSE here and the various updates are somewhat different.