Suse won't login-stuck

I have gone round and round in circles. I have updated my software from the repositories and where there was conflict I deleted the conflict. It said there was a new kernel loaded and I had to re-boot. I did and thats the problem from there on. It just gets stuck on loading, showing running script info when loading (sorry not techno babble, but I hope you understand what I mean). I have loaded the disk and tried to repair, have tried twice, and different techniques from the disk and had no luck. It state on one part that it could not find the root/ partition.
When loading from the hard drive after the splash screen you have lists that are loading. The last it loads is
usb 8-3: Product: HP Scanjet 3300C
usb 8-3: Manufacturer: Hewlett-Packard

It has stated when trying to rescue the system
“/dev/sda1 is mounted. e2fsk: Cannot continue, aborting”

When I have gone through the motions of repairing it staes resolved I click ok and the I have Error on a blue screen and a red box

No idea what to do now. All I seem to have is just bad luck, its my only OS and I have used ALL my bandwidth nearly. Like you I need my computer as I live on morphine, in great pain and the computer is my sanctuary. SO I really am hoping someone has the elixir to resolve this problem

Many thanks and hoping for a quick responce

Tony

Have you tried Failsafe boot from the menu?

Yes I did and I have just redone it again and I shall type out verbaitum the last few lines
Mounting root /dev/disk/by-id’ata-Hitacji_HDP725025GLA380_GEK234RBUYPPDA-part1
Mount: unknown filesystem type ‘ext2’
couldnot mountroot filesystem – existing to /bin/sh
$

Thats it and then stuck

What version of openSUSE is this?

I only downloaded the other day Suse 11.1 64bit

Did you deliberately choose ext2 file sys?

Anyway. My advice run the installer again, use ext3.
You just need
/
/home
swap

If you already have a /home with files you want to keep, fine, just don’t format it.

This may help
Partitioning/Install Guide - openSUSE Forums

Thats what I thought I would have to do!!! Its a load of downloading as I hadn’t backed up anything and I am running out of bandwidth. NOT HAPPY

This is the fourth time loading. Last chance for Suse and Linux

And yes I had loaded up the system in that way, so something had happened after the updates and downloads!!! :’(:’(>:(