SUSE won't detect my Creative SB X-FI

I recently downloaded SUSE version 11.0 64 bit version, I’m trying to configure my sound card, , i have a Creative SB X-FI. I found out that there is a beta driver for my sound card. I downloaded it to my desktop and extracted the contents, on the “read me” file it says that to install it, i need to open the console and type “./install” I do that but it says that the command does not exist. This is the first time i install linux on my computer im a complete noob. Can you guys help me out?

make sure you cd to the dir where you extracted the folder

eg: cd /home/xxxx/Desktop/FolderName
xxxx= your user name
FolderName= Name of the folder

then in the console type: su
then your root password (NB; text does not display)

now try.

Might be worth try one of the closes drivers in Yast - Hardware -Sound

I logged in as root went over to the file where I have the drive, I typed in “./install” and it said “bash: ./install: No such file or directory”

are you sure it’s not

make install

On Tue, 22 Jul 2008 03:36:03 GMT
caf4926 <> wrote:

> are you sure it’s not
> make
> make install
> /install
It’s normally;

sudo make install

What files are in the directory you are cding to?

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 4:55, 1 user, load average: 0.39, 0.69, 0.60
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09

The X-Fi drivers won’t compile out of the box and even after some considerable punishment they’re still completely useless - they’re highly unstable (if they work) and require further stabbing as things like module loading order is wrong etc.

2 realistic options: Use motherboard integrated audio if you have or acquire the 4Front OSS Audio drivers.

ALSA project guys are working on X-Fi drivers for Linux and they’ll be available… someday.

Did you try Creative for drivers? - They do list one for the ExtremeMusic at

Creative Worldwide Support

Good luck