SUSE WEBCAM

Hi , I am using suse 10.0 and I ve got a webcam , creative PD1001

with lsusb I get

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 005: ID 041e:400d Creative Technology, Ltd WebCam PD1001
Bus 002 Device 004: ID 15ca:00c3
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

I am trying to find the drivers of the camera and to make it work
I downloaded ov511-2.29.tar.bz2 from Linux OV511 Driver - Download
but I didn’t make it. I also tried to find my webcam’s ID (041e:400d) in http://mxhaard.free.fr/spca5xx.html but I didn’t
find it. I 'm trying to make my camera work in amsn(but it doesn’t find it) and Im also trying to find a linux program to work with my camera.Are there any suggestions?

Thank you

I saw reference to an experimental driver being made, that has limited functionality with this webcam:
Linux drivers for SE401, SE402 and EP800 based USB webcams

I searched webpin, but did not see any precompiled drivers. Hence you will likely have to download the tarball, and compile / build it yourself. ie untar it to something like /home/username/tars
and then open a konsole and move to the directory where the untarr’d file is located and read the “readme.txt” and “install.txt” (if there are such files). Ensure kernel-source is installed (as a dependancy) and install any other needed dependencies. Also install checkinstall.

Then build it with:./configure
make
su
checkinstall(I recommend checkinstall instead of make install for home PC use) and then install the rpms created by checkinstall.

The odds are (IMHO) that you will run into various dependency problems that need be sorted.

BUT, having typed the above, in truth, thats not what I really commend. Instead, Webcams are inexpensive. My recommendation is to go purchase a compatible webcam instead.

I ve cheked the driver’s you ve told me about but I ve found out that its a *diff file(wich I really don’t know how to handle). The only thing I ve tried for it was to use command

cat file.diff | patch -p0

in the usr/src/ as a root user

programs that I am using for the camera tell me that normally they should have found it at at the /dev/video0/ directory (like v4l-info command)
Someone told me about drivers gspcav* but I didn’t find for my
kernel wich is 2.6.13-15.18-default

Good point. According to that web site, the ep800 should be included in the kernel already.

On my openSUSE-10.3 PC, if I look here:
/usr/src/linux-2.6.22.19-0.1/drivers/media/video
I see both an se401.h and se01.c file already in place.

Which suggests this webcam may “just” work.

Under:
/usr/src/linux-2.6.22.19-0.1/Documentation/video4linux
I find the documentatin file se401.txt, which states:

INTRODUCTION:

The SE401 chip is the used in low-cost usb webcams.
It is produced by Endpoints Inc. (www.endpoints.com).
It interfaces directly to a cmos image sensor and USB. The only other major
part in a se401 based camera is a dram chip.

.... snipped .....

WHAT YOU NEED:

-	USB support
-	VIDEO4LINUX support 

I’m not sure what openSUSE video4linux (v4l) file is needed. Searching under webpin I get: Webpin search for v4l

Possibly you need to install v4l-tools, or v4l-conf, or libv4l. I simply do not know.

As I noted previous, my recommendation is to purchase a webcam with known support. Its far easier. For example, my Phillips web cam (which I was very careful to select via its precise model number) “just works”.