Suse update = KDE crash :(

Do you mean you want to undo what I did for you.?

Is there a way I can do that without actually reinstalling from the CD and having to copy all my files over again? I’d still have to reinstall and configure everything, but it’s troublesome to have to back up my files again if there’s an alternative.

You need to be clear what you want.

Going back to before I gave you the .kde4 thing, isn’t going to fix your problem.

I would sure like to see your repo list

zypper lr -d

This is what I got after I did what you said…and no, I wasn’t meaning that I wanted to undo that, I wanted to know if I could reinstall the desktop and everything without having to back up my files again. I know reversing what you had me do won’t fix the problem since I had it before I even did that.

Here is the repo list. The only one I should have been subscribed to other than the defaults is Emulators; I’m positive I checked ‘do not remain subscribed’ for everything else I installed unless I forgot to for something.

Do the Console login again. Login as user and become su -

Now do this

zypper mr -d 5

Now do this

zypper ref


zypper dup

First command worked, but the rest need to access the internet. Since I did mv .kde4 .kde4-old it disabled my network password, and I don’t know how to reconnect the wifi aside from the icon in the plasma panel that no longer exists. I tried running KNetworkManager as both normal and root, and it won’t work. Is there a command I can use to connect to my network and input my wifi password via the console login?

console login
login as user

mv.kde4 .kde4-mk1


mv .kde4-old .kde4



Got that all to work. Now when I go to log in, it tells me ‘could not start kdeinit4. Check your installation.’ Console login still works, but can’t access the internet again.

I’m beginning to think I should just reinstall…

Did you do as I suggested here
Suse update = KDE crash :frowning: - Page 3 - openSUSE Forums

Yes, and upon reboot I got that new message. If I try to log in on the login screen that’s what it tells me, though the console login still works, but the wifi won’t work from console login again so downloading and upgrading fails.

I’m beginning to think I should just reinstall…
So am I .