Suse update = KDE crash :(

I’m wondering why everytime I install “recomended” updates, my KDE or X server crashes completely!!!
is there any guide or advice you can give me to succesfully update only the packages that are really needed?

I had the same thing happen 2 days ago with a fresh install of 11.2 Gnome. Installed updates, reboot and although X loaded, I got a WM and no Gnome.

What I wish is that there was someplace I could find an authoritative source/guide for these sorts of ‘can’t boot’, ‘won’t load’, ‘filesystem not found’ etc issues.

So that way there is a way of diagnosing errors and some deductive way of determining what the cause is.

Unless you tell us about your system we are shooting in the dark.

Well you’ll see, I’m running Suse 11.1 on my Compaq Presario F700:

AMD Athlon 64 X2 TK-55 Dual-Core 1,8 GHz
NVIDIA GeForce 7000M

for example, yesterday I downloaded some Qt developing libraries for using QT Creator, I shutdown computer and went to sleep, seemed like the plasma dashboard was all moved and I could not click anithing in the start menu, so I decided (wrongly) to update system, after that I rebooted and I got stuck with a:

rtc0: alarms set up to 1 year stuff

and I have absolutely no idea what is that, so I decided to press SysRq to continue and load and do some:

zypper update

as root, took hours and now I can load kde whit a very nice looking, but the initial problem was not solved :frowning: I cant click anything… so I’m frustrated :’(

can you help me?

Please post result of

zypper lr -d

Ok, here it is…

| Alias | Nombre | Activado | Refresco | Prioridad | Tipo | URI | Servicio

1 | NVIDIA Repository | NVIDIA Repository | Sí | Sí | 99 | rpm-md | |
2 | openSUSE:11.2 | openSUSE:11.2 | Sí | Sí | 99 | yast2 | |
3 | repo-debug | openSUSE-11.1-Debug | Sí | Sí | 100 | yast2 | |
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Sí | No | 99 | yast2 | |
5 | repo-oss | openSUSE-11.1-Oss | Sí | No | 99 | yast2 | |
6 | repo-source | openSUSE-11.1-Source | Sí | Sí | 100 | yast2 | |
7 | repo-update | openSUSE-11.1-Update | Sí | No | 99 | rpm-md | |

Am I missing something? I tried to restart plasma like they say here KDE/KDE4 - openSUSE, but no luck…

Repo #7 Updates is not refreshing
Make sure it’s enabled AND refreshing. Also in 11.1 it’s priority should be 20 NOT 99

Once you have done that.

su terminal

zypper ref
zypper up

Done, but still have the problem. Thank you very much for your advice, is there anything I should try other than reinstalling suse?

Updating qt can be a bad idea if it does not come from an official repository. Where did you get this QT from that you refer to ?? Did you by chance add a repository, install the QT, and then remove the repository? If so, you need to tell us.

Can you explain what you mean by “X server crashes”.

Is it possible you were using a proprietary nVidia video graphic driver, and a kernel or xorg update broke the driver? If you think that is possible then you could try to configure with the vesa or nv driver until you rebuild or re-install the proprietary graphic driver.

That is a wild guess on my part. I am more suspicious you installed a non-official version of QT.

Some information reference nVidia graphic drivers here: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users

Hi oldcpu, I installed all QT updates from YaST, after that I cant stop get the following when start session, and when closing a konsole:

[Thread debugging using libthread_db enabled]
[New Thread 0xb142cb90 (LWP 3080)]
0xffffe430 in __kernel_vsyscall ()
[Current thread is 1 (Thread 0xb55cf700 (LWP 3079))]

Thread 2 (Thread 0xb142cb90 (LWP 3080)):
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb5ebf401 in select () from /lib/
#2 0xb759d69c in ?? () from /usr/lib/
#3 0xb74c9623 in ?? () from /usr/lib/
#4 0xb74671b5 in start_thread () from /lib/
#5 0xb5ec63ae in clone () from /lib/

Thread 1 (Thread 0xb55cf700 (LWP 3079)):
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb5e8ee86 in nanosleep () from /lib/
#2 0xb5e8ec6e in sleep () from /lib/
#3 0xb6c167c8 in ?? () from /usr/lib/
#4 0xb6c173a8 in KCrash::defaultCrashHandler(int) () from /usr/lib/
#5 <signal handler called>
#6 0x00000000 in ?? ()
#7 0xb2a7b371 in ?? () from /usr/lib/
#8 0xb2a7b437 in ?? () from /usr/lib/
#9 0xb2a7fe8a in ?? () from /usr/lib/
#10 0xb75d6864 in QMetaObject::activate(QObject*, int, int, void** ) () from /usr/lib/
#11 0xb75d6d41 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void** ) () from /usr/lib/
#12 0xb75d6ddd in QObject:: destroyed(QObject* ) () from /usr/lib/
#13 0xb75d7c27 in QObject::~QObject() () from /usr/lib/
#14 0xb61b7208 in QWidget::~QWidget() () from /usr/lib/
#15 0xb2a73a35 in ?? () from /usr/lib/
#16 0xb75cf58c in QObjectPrivate:: deleteChildren() () from /usr/lib/
#17 0xb61b7097 in QWidget::~QWidget() () from /usr/lib/
#18 0xb6558f0f in QFrame::~QFrame() () from /usr/lib/
#19 0xb65c90c5 in QStackedWidget:: ~QStackedWidget() () from /usr/lib/
#20 0xb75cf58c in QObjectPrivate:: deleteChildren() () from /usr/lib/
#21 0xb61b7577 in QWidget:: ~QWidget() () from /usr/lib/
#22 0xb75cf58c in QObjectPrivate:: deleteChildren() () from /usr/lib/
#23 0xb61b7097 in QWidget:: ~QWidget() () from /usr/lib/
#24 0xb6558f0f in QFrame:: ~QFrame() () from /usr/lib/
#25 0xb65c394c in QSplitter:: ~QSplitter() () from /usr/lib/
#26 0xb2a8a0cd in ?? () from /usr/lib/
#27 0xb75cf58c in QObjectPrivate:: deleteChildren() () from /usr/lib/
#28 0xb61b7577 in QWidget::~QWidget() () from /usr/lib/
#29 0xb75cf58c in QObjectPrivate:: deleteChildren() () from /usr/lib/
#30 0xb61b7097 in QWidget::~QWidget() () from /usr/lib/
#31 0xb6575b4f in QMainWindow::~QMainWindow() () from /usr/lib/
#32 0xb6c91ac1 in KMainWindow::~KMainWindow() () from /usr/lib/
#33 0xb6cd5c3a in KXmlGuiWindow::~KXmlGuiWindow() () from /usr/lib/
#34 0xb2a951c8 in ?? () from /usr/lib/
#35 0xb75cf253 in qDeleteInEventHandler(QObject*) () from /usr/lib/
#36 0xb75d07c7 in QObject::event(QEvent* ) () from /usr/lib/
#37 0xb61bb230 in QWidget::event(QEvent* ) () from /usr/lib/
#38 0xb6576aa4 in QMainWindow::event(QEvent*) () from /usr/lib/
#39 0xb6c8e9e4 in KMainWindow::event(QEvent*) () from /usr/lib/
#40 0xb6cd6522 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/
#41 0xb61648fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/
#42 0xb616c29e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/
#43 0xb6ba2ce1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/
#44 0xb75c032e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/
#45 0xb75c0fdc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/
#46 0xb75c119c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/
#47 0xb75ec4dd in ?? () from /usr/lib/
#48 0xb5d434c2 in g_main_context_dispatch () from /usr/lib/
#49 0xb5d46d98 in ?? () from /usr/lib/
#50 0xb5d46ebe in g_main_context_iteration () from /usr/lib/
#51 0xb75ec011 in QEventDispatcherGlib:: processEvents(QFlags<QEventLoop:: ProcessEventsFlag>) () from /usr/lib/
#52 0xb620629a in ?? () from /usr/lib/
#53 0xb75be98d in QEventLoop:: processEvents(QFlags<QEventLoop:: ProcessEventsFlag> ) () from /usr/lib/
#54 0xb75bedd9 in QEventLoop::exec(QFlags<QEventLoop:: ProcessEventsFlag> ) () from /usr/lib/
#55 0xb75c1270 in QCoreApplication::exec() () from /usr/lib/
#56 0xb6164774 in QApplication::exec() () from /usr/lib/
#57 0xb2a97322 in kdemain () from /usr/lib/
#58 0x0804e147 in _start ()

is not allways the same, for example when login in, there is also some threads… and so on.

sometimes, when I just updated the X server did not started unless I type startx, but that is now solved. But I sitll have the rtc0: alarms set up to one year problem, it takes like 5 minutes to boot

sorry for asking a lot of stuff, but I have no idea on what to do.

I have no idea either.

If it were me, I would log in to openSUSE in run level 3 (full text mode) and switch to root and create a new user. This can be done with “yast” . Then exit root.

Then I would login as that new user, and see if the problem exists there.

Please post this again

zypper lr -d

| Alias | Nombre | Activado | Actualizar | Prioridad | Tipo | URI | Servicio

1 | 20100417-202719 | 20100417-202719 | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Qt/openSUSE_11.1 |
2 | KDE:Qt46 | KDE:Qt46 | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Qt46/openSUSE_11.1 |
3 | NVIDIA Repository | NVIDIA Repository | Si | Si | 20 | rpm-md | |
4 | devel:tools:building | devel:tools:building | Si | Si | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
5 | openSUSE:11.1:Update | openSUSE:11.1:Update | Si | Si | 99 | rpm-md | Index of /update/11.1 |
6 | repo-debug | openSUSE-11.1-Debug | Si | Si | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
7 | repo-non-oss | openSUSE-11.1-Non-Oss | Si | Si | 20 | yast2 | Index of /distribution/11.1/repo/non-oss |
8 | repo-oss | openSUSE-11.1-Oss | Si | Si | 20 | yast2 | Index of /distribution/11.1/repo/oss |
9 | repo-source | openSUSE-11.1-Source | Si | Si | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
10 | repo-update | openSUSE-11.1-Update | Si | Si | 20 | rpm-md | Index of /update/11.1 |

I reinstaled SuSE! now KDE and everything works fine, but I cant start Qt Creator :frowning: it reads as this:

qtcreator.bin: cannot connect to X server

You should not be adding repos 1 and 2 in that list

You have changed all the priorities because 11.1 installs with OSS and NON-OSS at 120, Update at 20
all added repos will default to 99.

Is there a reason you didn’t re-install with 11.2?

Is there a reason you didn’t re-install with 11.2?

Still downloading it :s and I urgently need this up and running…

You have changed all the priorities because 11.1 installs with OSS and NON-OSS at 120, Update at 20
all added repos will default to 99.

Thanks, I will check, I think the Yast Qt Creator installer added those ones.

Adding those two QT repositories BROKE your KDE.

You should not have added them.

What might be possible is a complete roll back to OSS, Non-OSS, and Update. But you need to do that from the text mode yast, and I do not know if that is a text mode yast feature.

If you have the bandwidth, re-installing with 11.2 may be the easiest approach, although there are risks with that approach too (such as your having a specific model of older intel hardware that is not supported in 11.2).

I just had a similar problem…the last thing I did was install Aurorae, and when I went to the ‘get new themes’ thing it told me they couldn’t be loaded. So I rebooted my machine and when it came back, KDE wasn’t loading…I can still access all my applications via hotkeys and the terminal (thankfully I have Yakuake start up when I boot in), but my desktop is gone. Is there a way to get it back?

I just installed OpenSuSE over the weekend and finally got everything set up like I like it…I just wanted to get a new window decorator, and now everything’s screwed up. I really don’t want to have to reinstall fresh again.


I want to post the terminal output from trying to run plasma-desktop, too, but it’s too long and I can’t post attachments…um, this is the best I can do.

Console login

Login as user and do this

mv .kde4 .kde4-old



Didn’t work. Noticeable changes - my window colors reset to the default Oxygen theme, programs started booting like it was the first run, I got the first-run SuSE intro screen, etc…but no Plasma. It’s still gone, and worse now, I can’t get online because I can’t access the wifi icon on my panel (I know there are other ways but I do not know what they are). I had to boot from my flashdrive just to come back here and report this.

This happened to me a few times before, too, because I’m new to SuSE and was doing some careless experimenting. I figured the source of my problems had been subscribing to the repositories of everything I installed. I stopped doing that, and things had been going fine for the past few days. Obviously it’s something to do with something I installed, but all I installed prior to the crash was Aurorae and a few themes. How can I get Plasma back? As far as I know, Linux lacks a feature akin to Windows’ ‘system restore’ (at least Kubuntu did). If I can undo whatever it is I did and go back to how things were as of this morning/yesterday, then I’d be all set…

Renaming .kde4 simply takes you back to day one. There is something foobar in your KDE configuration. Finding the problem takes real expertize. For you the simplest way is to reset up your desktop.