SUSE-SU-2022:2056-1: important: Security update for u-boot

SUSE Security Update: Security update for u-boot______________________________________________________________________________Announcement ID: SUSE-SU-2022:2056-1Rating: importantReferences: #1200363 #1200364 Cross-References: CVE-2022-30552 CVE-2022-30790CVSS scores: CVE-2022-30552 (SUSE): 7.1 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H CVE-2022-30790 (SUSE): 9.6 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HAffected Products: SUSE Enterprise Storage 7 SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS SUSE Linux Enterprise Server 15-SP2-BCL SUSE Linux Enterprise Server 15-SP2-LTSS SUSE Linux Enterprise Server for SAP 15-SP2 SUSE Manager Proxy 4.1 SUSE Manager Retail Branch Server 4.1 SUSE Manager Server 4.1 openSUSE Leap 15.3 openSUSE Leap 15.4______________________________________________________________________________ An update that fixes two vulnerabilities is now available.Description: This update for u-boot fixes the following issues: - A large buffer overflow could have lead to a denial of service in the IP Packet deframentation code. (CVE-2022-30552, bsc#1200363) - A Hole Descriptor Overwrite could have lead to an arbitrary out of bounds write primitive. (CVE-2022-30790, bsc#1200364)Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2056=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-2056=1 - SUSE Manager Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2056=1 - SUSE Manager Retail Branch Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2056=1 - SUSE Manager Proxy 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2056=1 - SUSE Linux Enterprise Server for SAP 15-SP2: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2056=1 - SUSE Linux Enterprise Server 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2056=1 - SUSE Linux Enterprise Server 15-SP2-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2056=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2056=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2056=1 - SUSE Enterprise Storage 7: zypper in -t patch SUSE-Storage-7-2022-2056=1Package List: - openSUSE Leap 15.4 (aarch64): u-boot-xilinxzynqmpgeneric-2020.01-150200.10.12.1 u-boot-xilinxzynqmpgeneric-doc-2020.01-150200.10.12.1 - openSUSE Leap 15.3 (aarch64): u-boot-xilinxzynqmpgeneric-2020.01-150200.10.12.1 u-boot-xilinxzynqmpgeneric-doc-2020.01-150200.10.12.1 - SUSE Manager Server 4.1 (ppc64le s390x x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Manager Retail Branch Server 4.1 (x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Manager Proxy 4.1 (x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise Server for SAP 15-SP2 (ppc64le x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise Server 15-SP2-LTSS (aarch64 ppc64le s390x x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise Server 15-SP2-LTSS (aarch64): u-boot-rpiarm64-2020.01-150200.10.12.1 u-boot-rpiarm64-doc-2020.01-150200.10.12.1 - SUSE Linux Enterprise Server 15-SP2-BCL (x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (aarch64 x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (aarch64): u-boot-rpiarm64-2020.01-150200.10.12.1 u-boot-rpiarm64-doc-2020.01-150200.10.12.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (aarch64 x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (aarch64): u-boot-rpiarm64-2020.01-150200.10.12.1 u-boot-rpiarm64-doc-2020.01-150200.10.12.1 - SUSE Enterprise Storage 7 (aarch64 x86_64): u-boot-tools-2020.01-150200.10.12.1 u-boot-tools-debuginfo-2020.01-150200.10.12.1 - SUSE Enterprise Storage 7 (aarch64): u-boot-rpiarm64-2020.01-150200.10.12.1 u-boot-rpiarm64-doc-2020.01-150200.10.12.1References: https://www.suse.com/security/cve/CVE-2022-30552.html https://www.suse.com/security/cve/CVE-2022-30790.html https://bugzilla.suse.com/1200363 https://bugzilla.suse.com/1200364

More…