SUSE-SU-2022:2919-1: important: Security update for gnutls

SUSE Security Update: Security update for gnutls______________________________________________________________________________Announcement ID: SUSE-SU-2022:2919-1Rating: importantReferences: #1190698 #1198979 #1202020 Cross-References: CVE-2022-2509CVSS scores: CVE-2022-2509 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2022-2509 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HAffected Products: SUSE Linux Enterprise Desktop 15-SP4 SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Module for Basesystem 15-SP4 SUSE Linux Enterprise Server 15-SP4 SUSE Linux Enterprise Server for SAP Applications 15-SP4 SUSE Manager Proxy 4.3 SUSE Manager Retail Branch Server 4.3 SUSE Manager Server 4.3 openSUSE Leap 15.4______________________________________________________________________________ An update that solves one vulnerability and has two fixes is now available.Description: This update for gnutls fixes the following issues: - CVE-2022-2509: Fixed a double free issue during PKCS7 verification (bsc#1202020). Non-security fixes: - FIPS: Check minimum keylength for symmetric key generation [bsc#1190698] - FIPS: Only allows ECDSA signature with valid set of hashes (SHA2 and SHA3) [bsc#1190698] - FIPS: Provides interface for running library self tests on-demand [bsc#1198979]Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or “zypper patch”. Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2919=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2919=1Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): gnutls-3.7.3-150400.4.10.1 gnutls-debuginfo-3.7.3-150400.4.10.1 gnutls-debugsource-3.7.3-150400.4.10.1 gnutls-guile-3.7.3-150400.4.10.1 gnutls-guile-debuginfo-3.7.3-150400.4.10.1 libgnutls-devel-3.7.3-150400.4.10.1 libgnutls30-3.7.3-150400.4.10.1 libgnutls30-debuginfo-3.7.3-150400.4.10.1 libgnutls30-hmac-3.7.3-150400.4.10.1 libgnutlsxx-devel-3.7.3-150400.4.10.1 libgnutlsxx28-3.7.3-150400.4.10.1 libgnutlsxx28-debuginfo-3.7.3-150400.4.10.1 - openSUSE Leap 15.4 (x86_64): libgnutls-devel-32bit-3.7.3-150400.4.10.1 libgnutls30-32bit-3.7.3-150400.4.10.1 libgnutls30-32bit-debuginfo-3.7.3-150400.4.10.1 libgnutls30-hmac-32bit-3.7.3-150400.4.10.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): gnutls-3.7.3-150400.4.10.1 gnutls-debuginfo-3.7.3-150400.4.10.1 gnutls-debugsource-3.7.3-150400.4.10.1 libgnutls-devel-3.7.3-150400.4.10.1 libgnutls30-3.7.3-150400.4.10.1 libgnutls30-debuginfo-3.7.3-150400.4.10.1 libgnutls30-hmac-3.7.3-150400.4.10.1 libgnutlsxx-devel-3.7.3-150400.4.10.1 libgnutlsxx28-3.7.3-150400.4.10.1 libgnutlsxx28-debuginfo-3.7.3-150400.4.10.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (x86_64): libgnutls30-32bit-3.7.3-150400.4.10.1 libgnutls30-32bit-debuginfo-3.7.3-150400.4.10.1 libgnutls30-hmac-32bit-3.7.3-150400.4.10.1References: https://www.suse.com/security/cve/CVE-2022-2509.html https://bugzilla.suse.com/1190698 https://bugzilla.suse.com/1198979 https://bugzilla.suse.com/1202020

More…