Suse radeon HD 5850 drivers

Hi,

I have been having lots of trouble getting my system up and running after I installed a Radeon HD 5850 on my suse machine.

I did as they told by uninstalling the previous drivers and installing the new ones as stated in ATI Catalyst™ 10.2
Linux Installer Note.


2)sh ./ati-driver-installer-10-2-x86.x86_64.run

7) /usr/bin/aticonfig --initial

This was all done from a terminal… And I did this for Suse distributions 11.1 and 11.2. Both times my mouse cursor disappeared, but this could easily be fixed by adding the option “SWCursor” “on” option under the Device section.

This was only part of the solution as I still have incredible lag on my windows e.g. when I scroll down a web page it takes incredibaly long to render and you can see it rendering the page in steps from the bottom up. As well as when I drag a window across my desktop it lags behind and you can se it reforming at the new position.

Finally I tried different releases of the proprietary driver. I tried 10.1 and this did not give me the mouse cursor issue, but the window lag still prevails.

These are my xorg.conf and xorg.0.log files for my current setup. Opensuse 11.1 and proprietary driver version 10.1. I have an Radeon HD 5850 card.
http://pastebin.be/23851, http://pastebin.be/23852

I should add that I am on a private network, and only have the oss, non-oss and packman repositories available. (Is it possible to add the AMD driver repository? Because I have trid and the firewall refuses connection.)

Please help!?

OK xorg.conf has this:

Section "Device"
        Identifier  "Device[0]"
        Driver      "fbdev"
        VendorName  "VESA"
        BoardName   "Framebuffer Graphics" 

According to your Xorg.conf you are NOT using the proprietary driver, but **you are using the “fbdev” driver **which is the slowest performing of all the drivers.

According to the /var/log/Xorg.0.log your PC has the fglrx driver, but it is instead loading the VESA (or fbdev) driver

(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
(--) Chipset Supported AMD Graphics Processor (0x6899) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found 

and

(II) Loading /usr/lib64/xorg/modules//libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
        compiled for 1.5.2, module version = 1.1.0
        ABI class: X.Org Video Driver, version 4.1
(II) fglrx(0): VESA BIOS detected
(II) fglrx(0): VESA VBE Version 3.0 

Please, is there a specific reason why you are forcing a load of the fbdev driver in your xorg.conf, when you should be instead loading the fglrx driver in your Xorg.conf ? … is there something here I do not understand, or could this be a simple misconfiguration/unintentional omitted (or wrong) step on your part ?

Please read post#1 of the practical theory guide here: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums … Based on what I saw in your /etc/X11/xorg.conf file, I do not believe you understood post#1 above in that practical theory guide.

Also, if you follow the link for the fglrx driver, it will ultimately take you to ATI drivers - openSUSE which should also make it clear not to use an xorg.conf file for an fbdev driver when you want to be loading the fglrx driver.

Please confirm you have the fglrx rpm installed (although it does appear you do based on the above) by typing:

rpm -qa '*fglrx*'

Then after that, I recommend you backup you /etc/xorg.conf file to some name (say /etc/xorg.conf.oldfbdev) and then DELETE the xorg.conf, and once done, reboot your PC to a text mode (run level 3) by typing “3” (no quotes) in the boot/splash menu once it appears. That will take you to a full screen login. Login as a regular user with regular user password. Then type ‘su’ (no quotes - enter root password) to switch users to root. Then, assuming your /etc/X11/xorg.conf file has been deleted 1st, type:

aticonfig --initial 

and assuming that works, restart your PC with

shutdown -r now

and let us know how that works.

Note you can always restore your “backed up” /etc/X11/xorg.conf file (which we called xorg.conf.oldfbdev) if things do not work out.

Right, let me start from the beginning…

Clean suse 11.1 installation!
Load repositories: oss
non-oss
update
packman

Update my system.

Make sure I am able to build the kernel module:
sudo zypper in kernel-source linux-kernel-headers kernel-syms module-init-tools make gcc

Log into runlevel 3:
su
sax2 -r -m 0=vesa

Still get bad resolution and screen does not fit monitor, but everything seems to work, mouse pointer is visible and windows don’t lag.

login again runlevel 3:
su
sax2 -r -m 0=radeonhd

Get the following error:

sax: startup
xc: sorry could not start configuration server
xc: for details refer to the log file

 /var/log/Sax.log

xc: abort

This is the Sax.log file: PasteBin.be

Next I tried the Proprietary drivers (I start with a more stable release 10.1)

Download
login to runlevel 3:
su
sh ./ati-driver-installer-10-2-x86.x86_64.run
follow instructions for Automatic Driver Installation Option ATI Catalyst™ Proprietary Display Driver
cd /usr/bin/
aticonfig --initial
shutdown -r now

After restart the xorg.conf file looks as follows:

xorg.conf file

Section “Device”
Identifier “Device[0]”
Driver “vesa”
VendorName “VESA”
BoardName “Framebuffer Graphics”
EndSection

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:0:0”
EndSection

and the xorg.0.log file: PasteBin.be

At this moment everything works fine as well, resolution looks good and screen fits monitor properly. The mouse pointer is visible and windows render correctly.

However, it still seems as though the VESA driver is loaded, how do I ensure that only the fglrx driver is loaded?

I am afraid that if I remove the
Section “Device”
Identifier “Device[0]”
Driver “vesa”
VendorName “VESA”
BoardName “Framebuffer Graphics”
EndSection

part from xorg.conf that I might end up back where I started! How can I proceed in order not to load VESA, but only fglrx?

Really glad this is close to working! Thanx…sometimes helps to start from scratch! :smiley:

Boot to run level 3 (full screen text mode).

Backkup the /etc/X11/xorg.conf file to xorg.conf.somename.

Then delete the xorg.conf file.

Then run:

aticonfig --initial

(ie run this with NO xorg.conf)

restart with:

shutdown -r now

Is that any better?

Since the xorg.conf.somename is a backup file somewhere, you can always put it back.

:frowning: No it did not work, after initialising without the xorg.conf file there was no mouse or keyboard response, so I reloaded the old xorg.conf files. Here is the log file for that login though. Is it possible to force the mouse and keybord to respond?

Xorg.0.log
PasteBin.be

My knowledge is not good enough to deduce anything out of the Xorg.0.log.

Since you now have confidence in restoring a backup /etc/X11/xorg.conf file, how about trying this again, but this time, use a modified version of the “functional” xorg.conf, but with the following section removed:

Section "Device"
Identifier "Device[0]"
Driver "vesa"
VendorName "VESA"
BoardName "Framebuffer Graphics"
EndSection

Just be certain to keep your backup, and restore the backup if things don’t work.

Thanx, I will give it a try. It might take some trial and error, but at least I now have a decently functioning system again.

All the best!