SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)


I have a ThinkPad W541 with Nvidia Quadro K1100m. I am trying to setup SUSE-Prime package.
It works however regardless of whether I select intel, intel2 or nvidia, nvidia gpu will always be turned on.

[bbswitch] NVIDIA card is ON

As far as I understand this is due to render offloading feature in 440 driver.
The problem is, that nvidia power management works only with Turing GPU. K1100m is Kepler, so driver itself cannot power off the GPU completely.

Here comes my question: is it possible to use SUSE-Prime the old way (intel = intel GPU only, nvidia = nvidia GPU only) without render offloading?

I read about this on GitHub page of SUSE-Prime, but I am confused, since the solution with bbswitch seems to apply only to older drivers.

Thank you for your help

Your card is not compatible with the 440 series, it’s a Legacy card… install the 390.132 driver.

Thank you for your answer. I have removed G05 driver and installed G04.
However, SUSE-Prime still doesn’t work as expected.

I tried following guide on the GitHub page of the SUSE-Prime project, but executing:

 cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f

results in:

dracut: Executing: /usr/bin/dracut -f
dracut: No permission to write to /boot.

and service prime-select (mentioned in next step does not exist).

Is this a result of an incorrect driver being installed before? Do I need to take some extra steps to remove and clean some leftovers?

Thank you for your help.

Unfortunately I don’t have a laptop with Nvidia, hopefully the other Forum users with this hardware will chime in in due course…

Besides the github page,
There is an SDB that can provide guidance

Additionally, if you’re unable to make suse-prime work (we’ll provide as much assistance as we can here but like Malcolm I don’t have immediate access to a machine with an nVidia GPU), you also have the option to implement the older, “tried and true” way configuring Bumblebee.


This sounds like a permissions problem, not a code or content bug.
Are you running your commands in a full elevated console?
To switch to a proper elevated console run the following before executing commands

su --login