Suse or Microsoft?

From Windows To Linux
And Maybe Back?

Sometime in late 2007 or early 2008, we decided on our laptop at home to replace Windows XP Home with Windows Vista Home Premium, a purchased 32-bit OEM version. In retrospect, I’m not sure why. I have worked in IT for decades and maybe this was just a journey that had to be made, who knows now.

So I ordered the DVD and the day it arrived, double-checked with ‘She who must be obeyed’ that I go ahead with the install, and getting the go-ahead, did just that. This was the beginning of one of the least progressive journeys I have made in IT in modern times.

I list below just a few of the negatives encountered in this foray over a six month-ish period…

  • we actually paid for Windows Vista and the ensuing grief it brought
  • I had to double the memory in our machine from 1Gb to 2Gb to achieve an acceptable operational speed
  • User Account Control – Jesus, who dreampt that one up? That was gone within minutes of the install (‘Are you sure you want to disable UAC?’ - God, yes.)
  • one of our printers was not in the list of compatible devices and was now seemingly obsolete
  • the filing system was totally reorganised. This may ok in itself, but for instance, navigating to C:\Users\Me\My Documents and double-clicking on the icon to open it, the response is “Access is Denied”, wrong by definition.
  • Try and find a file using the new search facility. No, a degree in MS Search is not where I’m heading in life, I give up.
  • And where is the ‘up a directory level’ button gone?
  • Windows Mail – the same old follies included as with Outlook Express – no surprise as it probably is that with a new name.
  • Control Panel – major revamp, e.g. ‘Add or Remove Programs’ becomes ‘Programs and Features’. Network centre, similarly rehashed so you can’t find anything. Why mend something that isn’t broken?
  • I ended up using ‘VirtualPC’ and ‘VirtualBox’ programs to run Vista-incompatible programs. They do work but this isn’t an ideal way to carry on.
  • Disk drive banging away for some reason of its own, even with indexing disabled, and no obvious way to discover why. Very annoying.
  • There were many, many more ‘nags’ and annoyances that we reluctantly learnt to tolerate…

We lived with this mishmash for six months or so and then I began to think of what might be a long term, viable alternative to this sales-oriented, hype-driven bandwagon. I should explain that I am on the brink of retirement, committed to IT and communications of today but the option of exploring free, open source alternatives to Microsoft suddenly became a real lure for the future.

At roughly the same time as this was happening, we by chance visited a friend who was exploring the joys of the Linux family of OS. We left that evening, me with a double-sided DVD containing distros of Ubuntu and Suse 10.3 safely tucked away in my inside coat pocket.

Looking on the net, Suse seemed to be a pretty well respected OS, so I started with this as a complete newbie. I installed it and then after this was complete, sat there and just looked at the unfamiliar, but not off-putting, green screen. I started by fiddling with the on-screen buttons but homed in on the ‘Computer’ link in the panel at the base of the screen. It looked interesting. I explored enough to break off and list for myself a set of evaluation critera. These consisted of a number of facilities that I needed for my wife and I to continue our day to day internet use and also, some programs to enable me to work from home and access the resources on my home and company’s networks which I have been able to do for a good number of years now.

The list of criteria that I needed to work were as follows…

  • File sharing over a network, Linux and Windows
  • Remote control using VNC or equivalent
  • Filezilla (if poss.) FTP client access to my website and work
  • Exchange Server and pop mail access
  • Internet messaging
  • Telnet client access to work
  • Install my two home printers
  • A decent photo editing program
  • Radio streaming
  • MPG and AVI video playing (mostly e-mail attachments!)
    …and more…

My wife and I agreed to regard this change to Suse 10.3, not as an inconvenience or a chore, but as an opportunity to undertake new things. And this we did indeed do with enthusiasm.

It was not long before we were both totally hooked, it is an absolutely brilliant OS, different from MS, granted, but unrestricting in everything we wished/needed to do. Within a few days, all of the listed critera were met and more and we were committed Linux fans for life.

And all of this brilliant software was either available free as part of the distro, or available for free download and install. You cannot complain about that.

Criticisms? Yes, of course there are, for instance, the screen displays are not quite as glitzy/flashy but functionally they are all there. There are unforeseen advantages too, for example - memory usage is fantastically less greedy, you rarely see more than 512Mb being used; The need to defragment the filing system at regular intervals disappears. And to repeat, it’s ALL FREE (though you can, and should donate).

Mid-2008, the emergence of Suse 11.0 was announced for download some time in October (I think) and this was eagerly awaited by us new converts. Come the day, I duely went online and downloaded the Suse 11.0 ISO and installed it on a spare test machine at home. This technological advance into new Suse territory was truly exciting.

I started to work through my list of criteria starting with good old Samba and network sharing. FAILED, I could not get this box to talk to Windows and/or Linux machines for the life of me. Looking online for the ever-present help on this, I found that the Samba and Susefirewall2 configuration had been pretty much reworked and assumed that this was the problem. I followed the new, updated, procedures only to find that the end result was the same as before – it would not talk to the outside world. This is pretty seriously wrong, mmm.

Moving on to VNC/remote desktop, that had all changed. SAX2 config. no longer showed a ‘Remote’ tab but there was a new Remote Administration option available in Yast2. Following this, all it really offered was a yes/no setting and if yes was selected, a port number, default 5900. The nearest I got to getting this to work was from another machine’s web browser, very slowly, and it seemed to start another session on the Suse box rather than pick up the current session, not what I wanted.
Back to Samba, give this another try, no success. Back to VNC, crummy, awful. Try some other packages, no success here either, buried in dependancy problems. Conclusion – they have broken Suse 11.0, my upgrade path for the future has gone.

But possible salvation appeared, the appearance of Suse 11.1 in mid-December 2008. I decided to wait for this, assuming that snags I had encountered in 11.0 would have been addressed. Would I be right?

Well, in a nutshell, no. It is still badly broken and in those basic areas that, for me, make it a non-option. So what are my options now that the upgrade path with Suse is gone? A good question…

Go back to MS Vista - arggghhh
Go back to MS XP (where this all started from!!)
Look for a better Linux flavour

The decision was somewhat preempted by our walking into a John Lewis store near where we live and my wife spotting a very appealing touchscreen machine sporting MS Windows Vista 64-bit and asking “can we have that?”. We ended up being the proud owners of said machine. Was that a good move? The machine and build are super but MS Windows Vista 64-bit offers a whole new raft of problems for us to live with as well as the previous ones, basically they have shot themselves in the 64-toed foot again, it is awful.

So where did we end up? I am still installing different Linux flavours looking to find an unbroken alternative to Suse. We are living with a very irksome Vista 64-bit that runs about 50 percent of the packages we have tried to install plus has all the foibles, and more, of our original OEM 32-bit Vista. It’s been a lot of effort, one way and another but what we do now have is a firm target to aim for. Our real challenge is that wherever we end up, it has to be used and liked by ‘She who must be obeyed’ and that isn’t a bad objective for an IT implementer like myself. And as a long term systems implementer, that criterion is one all too often forgotten – the needs of ‘She or He’, the customer.

We now have ‘Windows Version 7’ on the horizon, Microsoft having sort of admitted that Vista was a mistake. My suspicion and concern is that version 7 is a patched up version of Vista rather than a return to XP and ‘let’s try again’. What will I/we do now? Well, sorry MS, I may not have found the perfect Linux flavour for ourselves yet, but Linux is most definitely where we will stay. That is a certainty.

We really do hope that Suse returns with a vengeance and suspect that will happen. Until then, the Linux world has much to offer and explore and that in itself is a consuming challenge.

I hope you find this account of events informative and/or useful.
Regards
John

You are in the right place and if I`m you you should try or use suse11.1–>32-bit/64-bit,

That is my advice,Im using suse for 3 or 4months and Im very happy and lots of fun.:wink:

Good luck,

Mike

jbenet,

If you have found openSUSE 10.3 to be the best version of linux for you and your wife, you should continue to use that version. Editions of openSUSE are supported for 2 years from their release. This means that openSUSE 10.3 will be supported until October 2009. Having that bit of ‘cushion’ should allow you to continue using an os that works for your family while trying alternative Linux distributions on the side. It will also allow you to find out if the forthcoming openSUSE 11.2 is suitable for your needs.

openSUSE 11.1 is the right software for you! The only difficult thing is to bring the wireless to work, but we have a very good support in this forum and someone will quickly help you! :wink: Have fun! You will love openSUSE! The software is great…

great story here, and informative.

M$ seems to be moving toward linux-type permissions with UAC and addressing memory management vunerabilities in Vista, which is a good thing. Sure is a resource hungry thing thou.

the samba issue is in my point of view a real black eye for novell… i am amazed that this is allowed to linger unaddressed… novell means networking, it’s what they “do”.

i think you have the right approach, just do what “she who must be obeyed” says… :slight_smile:

I have similar (and more) requirements. Dependant on your hardware (for example your printers) this could be difficult or easy.

Telnet is really old. Does your work really use that and not ssh ?

I can NOT be bothered with samba myself. It IS the integated way to do things, and others can walk you thru how to do it. Me? No way. I don’t need it. There are other (less integrated) ways to do things.

In my case, I simply share using something like sftp. To go from one Linux PC to another Linux PC, i type in konqueror’s location bar:sftp://user@ip-address-of-other-pcThis works on a LAN, and it works on a PC a continent away. I have to ensure both PCs have port#22 open in their firewall. And thats it. Thats all.

To access my wife’s WinXP PC, I simply type (from my Linux PC):
smb://ip-address-of-my-wifes-pc
and I ensure her firewall allows my PC access. Typically that is the biggest problem. And thats it. Thats all.

For my wife’s winXP pc to access my PC, she needs to use a program called winSCP.

I do this from a konsole. I confess I tend to be one of those terminal geeks that new gui based users detest. What can I say? It just works for me.

On my mother’s WinXP partition, a continent away, she has installed tightvnc. She double clicks that, I type something like: “vncviewer ip-address-of-mothers-pc:0” and enter the password and I take over her desktop. Its a bit slow. We had to open port#22 and port#5900 for this to work.

Going from Linux to PC to Linux PC is much faster. But thats another post if necessary.

To go from windows PC to Linux PC we use an application called “nx”. “nx” also works going from Linux PC to Linux PC. Its fast. Real fast. Did I say it was fast? Its fast !

No is the right answer. The problem is not in the OS version. Its in the knowledge in how to use it.

Well, you have the right ideas.

I think if you have the patience, then you could ask for help on our openSUSE forum, in separate posts on each item you are trying to do. And openSUSE will work for you.

If thats not for you, then other technical solutions could be another Linux distribution (other than openSUSE) or even back to MS-Windows. Most my colleagues and friends use MS-Windows. They are smart people. I won’t berate their OS. But I do note its not for me.

Good luck in your endeavors.

Very interesting and well written, jbenet.

When using one of the Corporate sponsored open versions of Linux you need to keep in mind that a upgrade can be problematic (The paid corporate versions such as Sled or Redhat will be more stable than openSUSE or Fedora). Quite often there is a break in period where bugs are caught and new ways of accomplishing the same things have been introduced. This is why it is best to test before running the latest and greatest. It is also vital to keep reading the Forums to see what every one says about the upgrade. For myself, I never do automatic updates either. I want to see what I am updating so that I can fix it if need be.

Being as your background was IT I would suspect you already know that. You may not be aware however, that many things are solved through volunteers on Linux Forums that encounter problems and work through till a solution is found. Reading those encounters that others have is essential to solve your own issues. Never be afraid to ask when things go South.

Don’t give up on Linux!

jbenet, I see now, after searching your handle on this forum, that you already know about the “smb” method. Although you state you could not browse with that. … I’m not clear what you mean by can not browse. If you mean the network, then yes, that is true. But if you mean the PC whose IP address you typed, that CAN be browsed. But its important that the Windows PC has file sharing enabled of the various drives. … I use this method all the time without problem.

> I hope you find this account of events informative and/or useful.
> Regards

Personally I would have gone back to 10.3, it’s still supported.

Heh, I’ve been using it for 3 or 4 days and I’m very happy :wink:

Very interesting read and welcome to the forums.

@Sat, 28 Feb 2009 23:36:01 +0000, jbenet write:

> Moving on to VNC/remote desktop, that had all changed. SAX2 config. no
> longer showed a ‘Remote’ tab but there was a new Remote Administration
> option available in Yast2.

personly I am never use VNC from sax2 (even did not know how this works)
you can look at

http://en.wikipedia.org/wiki/Remote_Desktop_Protocol

use xrdp rdesktop or anything you want… I use this before i move all
my PC’s to linux… now I use ssh -X name@myremotepc

I did not think that something wrong with openSUSE 11.1 I am sure it “production ready”

>Following this, all it really offered was a yes/no setting and if yes was
>selected, a port number, default 5900.
> The nearest I got to getting this to work was from another machine’s web
> browser, very slowly, and it seemed to start another session on the Suse
> box rather than pick up the current session, not what I wanted.

not really clear to me what you are doing…

> Back to Samba, give this another try, no success.

It is very easy… why you have prob whith this???

> Back to VNC, crummy, awful.

no-comments

> Try some other packages, no success here either, buried in dependancy
> problems. Conclusion – they have broken Suse 11.0, my upgrade path for
> the future has gone.


~> rdesktop

The program 'rdesktop' can be found in the following package:
* rdesktop  path: /usr/bin/rdesktop, repository: zypp (repo-oss) ]

Try installing with: sudo zypper install rdesktop

bash: rdesktop: команда не найдена
~> sudo zypper in rdesktop
Загрузка данных репозитария...
Чтение установленных пакетов...
Разрешение зависимостей пакетов...

Будет установлен следующий НОВЫЙ пакет:
rdesktop


Полный размер загрузки: 141,0 K. После этой операции будет использовано дополнительно 386,0 K.
продолжить? Да/Нет]: yes
Получение пакет rdesktop-1.6.0-37.4.i586 (1/1), 141,0 K (386,0 K нераспаковано)
Получение: rdesktop-1.6.0-37.4.i586.rpm ГОТОВО (10,4 K/s)]
Устанавливается: rdesktop-1.6.0-37.4 ГОТОВО]

no problem with deps… at all

> But possible salvation appeared, the appearance of Suse 11.1 in
> mid-December 2008. I decided to wait for this, assuming that snags I
> had encountered in 11.0 would have been addressed. Would I be right?

maybe you should look at SLED 10 or 10.1?

personnally I am very happy with all innovation in opensuse…
especially I like new bootscreen it awesome :slight_smile: some man on the field with moon…

>Posts: 3

maybe you should ask questions in forum opensuse.org> applications

you in most cases you will have an answer less then 15 min :slight_smile: you should not wait
from mid-2008 to make your life some free :slight_smile:

try to ask… you’ll see how this change your life with oS

WBR

I’ve been using Opensuse 11.1 Gnome, and I’m really happy with it!

  • The first thing I have to do when I start up Windows at the first time is installing “Anti Virus/Spyware” software.
  • The first thing I have to do when I start up Opensuse at the first time is opening Firefox and watch youtube :wink:

The Thread is Amazingly written!

Nihilanth

It all can be done: filesharing, Windozes connecting to my server and vice versa, linux machines idem, apples idem. Not all at once, but step by step.

Ever tried fish://username@hostip ?

Samba can be realy tricky. I remember a HOWTO that started with a completely open en insecure basic setup (security=share for instance), after which things were secured step by step.
Permanent sharing can easily done by NFS-server and clients.

I think 11.1 would definitely meet your requirements, in more than one way, offering you a choice of possible solutions for every single item you want.

Frankly speaking using the Novell labeled version of linux, Enterprise Desktop Version 10, also known as SLED 10 is the best option for you. It is $50 a year for a license.

SUSE Linux Enterprise 10

@Tue, 17 Mar 2009 12:26:01 +0000, Knurpht write:

> Permanent sharing can
> easily done by NFS-server and clients.

not so easy for me… as you told…

I’m still can not configure this services…
opensuse wiki is very poor for this…
nothing about howto use yast for…

it more easy to me use sshfs, but i still need NFS

WBR

Hello All,

Many thanks for your interesting and varied responses to my original post. This is just to provide an update in May 2009 for anyone who might still care…

Well, you had my rundown on Suse 11.0 and 11.1 and that still stands, pretty poor. Some of you offered alternative ways of doing things and, although those were gratefully received, they detracted from the base fact that originally, things that worked in Suse 10.3, no longer did work.

I have, since then, tried numerous other Linux flavours but somehow, I cannot switch, I keep returning to OpenSuse as the technical level and general experience it offers seems to suit me. The others have not drawn me in.

Back to the current time… this week I discovered and loaded up OpenSuse Milestone 1 pre-release version and I am so pleased to report that, hey, things are getting back to where they used to be under 10.3 - i.e. working.

I have spent the last four or five days again going through my own personal list of acceptance critera and I am finding that, contrary to before, it is looking very good. There are some bugs, it is a bit slow and, and for certain, some things are different. But change is what it’s all about - moving forward. We have to get on with that, but the difference is that it basically all works again - full marks to all those guys out there doing their valuable work. (Yes, I do feel guilty, I should perhaps be helping!)

That’s about all I need to say for the time being except that I am now really looking forward to the formal release of OpenSuse 11.2 as it does look like salvation is at hand. My thanks to those guys.

I’ll do another update some time after 11.2 is released, hopefully the positive note will continue :slight_smile: Maybe some of you out there will be vaguely interested.

Regards,
John

Thanks for testing milestone1. There is a general call out for testers, who will hopefully do what you have done, and then also write bug reports: openSUSE-11.2 - CALL FOR TESTERS - openSUSE Forums

A lack of testing is a criticism that openSUSE has been receiving the last few releases, and we really need users to load up 11.2 milestone-x on a test PC, test what is important to them, and then write bug reports.

Milestone2 is due to be released today, or in the next day or two.

oldcpu,

in there openSUSE-11.2 - CALL FOR TESTERS - openSUSE Forums your saying use a old PC if something go wrong…
I like better turn off the PC and getting drunk ,that what I dorotfl!