Suse Newbie - Problems after installing NVidia Driver

Hi there,

Switched from Fedora this week, and love the distro. I installed the Nvidia drivers after adding the directory to the Repo. All installed fine, but im having 2 issues which im hoping you more knowledgeable people can help with…

  1. On login/logout, whenver it would change to a black screen for a second, im now getting random raw patterns on screen. These are red, or black and white, and sometimes you can see icons from the desktop underneath. They then go when it moves to the next screen.

  2. Some widgets arent displaying properly. The updater applet is overlaying, so the red triangle, the orange update icon and the green icon all overlay.

I did a clean install and redid, following instructions from opensuse help and FAQ, but have the same problems.

Can anyone assist me?

Many many thanks.

As far as I’m aware the random raw patterns glitch just seems to happen, less crippling and more a minor niggling, but Im not 100%sure on the 2nd point, you got a screenshot so we can better see?

Also, did you compile the nvidia drivers or install them from the repository via 1click?

Yes, true. Its a minor glitch of screen after login and b4 just for a second. Not sure, what cause them. May be of video card. I am using Intel.

Yeah that does seem to be the case, im running an NVIDIA 8400 using the most recent drivers (Compiled myself) and I get that glitch and yeah, it is really minor

If i’m not wrong then if You change the login theme from within YaST then it won’t happen anymore.

Is it YaST OR configure desktop->Appearance->Splash Screen?

I’ve done that before and it still did it, i’ll check again though, its one of those glitches that doesnt bother me to much though, its so minimal. lol

There as a BUG in KDE bug tracking system (or NOVELL’s) don’t remember now that the kde system settings tool doesn’t set most things related to login etc.

So YaST is the way to go.

P.S. It’s not the splash screen’s fault, it’s the login manager, i remember a guy saying something that the openSUSE’s login theme didn’t have a string where other theme’s had it by default and that adding that line to the login theme solved the problem for him. But i don’t care since i don’t use the default theme, too greenish :smiley:

I changed it from YaST->system->/etc/sysconfig Editor->Desktop->Display manager->DISPLAYMANAGER_KDM_THEME.
I changed the value from SUSE to oxygen.
oxygen theme is already there in:

But nothing changed after restarting PC. All the old theme with a glitch.

Try changing the branding.

Thanks for the tip.
What i did just now was:
There were two DISPLAYMANAGER_KDM_THEME, one at the bottom and one at the middle, i changed the bottom one b4, which did not work at all, then just now i changed the middle one value from SUSE to oxygen, and restart the PC, which works like a charm, AND WITH NO GLITCH THIS TIME. Very smooth.

My bad, i installed new theme from kde themes site (true-nature), but there was a problem in the theme, so when i restart the PC, it popup an error that true-nature theme has errors and it send me to command based. I tired to changed the sysconfig, but don’t know which file to change to set back the theme to oxygen or SUSE.
Any idea…


There are two ways to sort out this type of issues, If your login screen gone, and you can’t see your login screen anymore.

1st Solution is:
1- Login with your username and password from command based screen.(You can use failsafe OR your normal one).
2- type:


Hit enter, and you will be able to go to desktop.
3- After this, change the theme from YaST->system->/etc/sysconfig Editor->Desktop->Display manager->DISPLAYMANAGER_KDM_THEME.
There will be two DISPLAYMANAGER_KDM_THEME, choose the middle one.
and enter your desired working theme name and hit ok.
4- Logout from here.
5- Restart.

2nd Solution is:
1- Login with root from command based screen.(You can use failsafe OR your normal one).
2- type this:

vi /etc/sysconfig/displaymanager

3- search for line like this:
true-nature is theme name.just for example i put it there.
4- Change it to your desired one:
5- Save the file.
6- Reboot.
Howto save in vi: To change any text, use ‘i’ to insert any text, hit ESC to end writing, and then hold left shift+z(hit twice). And your changes will be saved.

And that’s it. You are done.
Hope it will help.