suse newb can't make install

hi, my first try on linux was with ubunutu, had some sound issues there so I’m trying suse.
but unlike ubunutu where in the terminal I could just use the commands
sudo make
and then sudo make install

with open suse I always get the reply “sudo: make: command not found”

if make isn’t the right command to install under suse then what is?

incase everyone needs to know I’m trying to install the sound drivers that caused so much trouble under ubuntu for me.

XFiDrv_Linux_Public_US_1.00.tar.gz

You can either set up sudo by adding to the list of sudo users or just use

su –

Because openSUSE has a proper root, sudo is not set up as it is in Ubuntu which doesn’t.

yeah I tried su? I was the master user when I went make or make install
but still got the same error message

arminius75 wrote:
> with open suse I always get the reply “sudo: make: command not found”

You don’t need root privileges to run “make”, just for “make install”.
In this case, however, you simply don’t have make installed. Run
“zypper in -t pattern devel_C_C++” first. As root, of course.

Kind regards,
Andreas Stieger

ok AndreasStieger, that’s downloading now, I forgot to mention, I had trouble with the opensuse DVD I got in a magazine, wouldn’t install properely at all, so I used the live CD instead, does that mean it’s missing the components u need to run commands like make?

ok andrea I’m making progress, after I installed that thing u advised I tried make and got

user@linux-1o9k:~/temp/XFiDrv_Linux_Public_US_1.00> make
make -C /lib/modules/2.6.27.19-3.2-default/build M=/home/user/temp/XFiDrv_Linux_Public_US_1.00
make[1]: Entering directory /usr/src/linux-2.6.27.19-3.2-obj/i386/default' make[1]: *** No targets specified and no makefile found. Stop. make[1]: Leaving directory /usr/src/linux-2.6.27.19-3.2-obj/i386/default’
make: *** [all] Error 2

and typing make install got

Copy module files…
cp: cannot stat `ctxfi.ko’: No such file or directory
make: *** [install] Error 1

with ubunutu I just typed make and then make install and that was it

arminius75 wrote:
> ok andrea I’m making progress, after I installed that thing u advised I
> tried make and got

It’s “Andreas”, german male name.

> user@linux-1o9k:~/temp/XFiDrv_Linux_Public_US_1.00> make
> make -C /lib/modules/2.6.27.19-3.2-default/build
> M=/home/user/temp/XFiDrv_Linux_Public_US_1.00
> make[1]: Entering directory
> `/usr/src/linux-2.6.27.19-3.2-obj/i386/default’

make[1]: *** No targets specified and no makefile found. Stop.
make[1]: Leaving directory
`/usr/src/linux-2.6.27.19-3.2-obj/i386/default’
> make: *** [all] Error 2

Install the package “kernel-source”.
“zypper in kernel-source”
Then run make again.

> and typing make install got

Can’t “make install” if make failed.

Kind regards,
Andreas Stieger

my apologies Andreas, anyway, you are a champ, that’s australian for champion, that’s solved my audio issues completely, and it’s coming across much better then it did under ubuntu.

one last thing, it’s not related to the original thread, but u seem familer now with my Live CD problem where everything seems missing.

I’m trying to use kaffeine player to play .avi files, and it’s not running any of them? or any video file.
know what might be missing that’s causing this?

Webpin - Results for CreativeXfi

arminius75 wrote:
> I’m trying to use kaffeine player to play .avi files, and it’s not
> running any of them? or any video file.
> know what might be missing that’s causing this?

For multimedia and other restricted format (MP3,Encrypted DVD,DiVX,etc)
issues, see http://opensuse-community.org/Restricted_Formats

Kind regards,
Andreas Stieger

And stop Crossposting, please.

kaffeine won’t play video - openSUSE Forums

Asking a question once is enough, no you got the same answer twice, wasting the time of the people trying to help you.