SUSe network Problem

Hi Guys,

First time I actually posted on this site, but I am truly grateful for all the information on this site.
Now to business. I have a DELL server with SuSe Enterprise 10 server installed. Not getting much support so I need your help.

The server has 2 NICs. The server was working find until an update to SP1 was done. after that, the NICs don’t appear. Plus when i do a ifconfig, the NICs don’t appear only the loop back. When i reboot the box, i get an error when it wants to load the NICs. It says device not found after 20 seconds of waiting.

I checked the hardware profile. It scanned it and saw the 2 NICs. I checked the BIOS everything was good there too.

when i went to yast>network settings> network cards (this is kinda different to openususe, but just berely), i tried to configure the 2 NICs. I am using ifup and even tried network manager. The configuration of the NICs go without a problem. I assign IPs and other stuff but no joy. I restart the network service. Even the server itself, but no joy.

I’ve read somewhere the driver is something like tg3 but i see in the modules it was using bzn2 for each NIC.

BTW: the NICs are broadcom nextreme gigabit ether adapters.

I know there is a driver issue but don’t know what to do in that case. I couldn’t find anything else on the internet so please help


Open a su terminal and do:

lspci -k

report the details for your NIC’s

Thanks guys,

I’ve figured out the problem. When i checked the harware profile again, i saw that the driver was there but not active. When i tried to load the module in the kernel using modprobe bnx2 i got an error say “invalid file information”.

I checked the software instalation for the driver and I found that the bnx2 driver was locked I deleted it. I then went to the broadcom site and downloaded the drivers for my machine. (of course on another machine then transfer it)

I ran the rpm file, loaded the module into the kernel (using the modprobe bnx2)and restarted the network service. (/etc/init.d/network restart)

I just wanted to post this just in case someone else has the problem. If i missed anything in between, anyone who knows just add the commands.

Thanks again:D