SuSE:Leap - Radeon - Cannot find Backlight Controller

On a new ASUS AMD-APU, running Win 10, I created a dual boot with SuSE Leap 42.1, all is well, until after install and I get the error - Radeon - ‘Can’t find backlight controller’. It boots only to a command line. I try startx and it bombs. I have googled and tried sudo zypper in fglrx and also tried to add nomodeset in a boot parameter, but nothing works. I understand the issue I believe to be is to remove any drivers coming from the install as the drivers are already in the kernel core, so I think. What I need help with is exactly how I can use the command line from SuSE Leap 42.1 on my ASUS A555D laptop with Radeon graphics R8 M350DX to fix this whether it is to install, uninstall, or set the parameters correctly in GRUB, in simply laymans terms. If i need to bring back data and config info, please let me know where I need to run what command lines.

Oddly enough, I have other AMD/ATI/Radeon cards and run SUSE 12.2 and Leap on with no issues.

In general you do not remove drivers The correct driver will be used when you have the correct drivers installed

I can not find specs for the numbers you gave is this an AMD or Intel CPU. A lot of notebooks are hybrids ie have an Intel +AMD or NVIDIA GPU. So need to know more about this hardware

You said you installed or tried to install fglrx but it is not at all clear how or what happened ie error messages etc.

On the laptops sticker, it say’s Radeon Graphics R8 M350DX 2GB and the CPU, in in his case the APU the Windows OS identifies it as:
AMD FX-8800P Radeon R7. The GPU and CPU are on the same chip.

After installing Leap 42.1, I booted, and during boot, in complained of 'Radeon - Can’t find backlight Controller, then allows to login from command line only. I tried startx and get a screen full of errors and it ends back to a goofed command line that complains about not finding the backlight controller, and then I have to boot because it takes no input from the keyboard.

While at a good command line (before doing an attempt at startx), I keyed in

sudo zypper in fglrx

and it goes through getting the repositories, and then reports that fglrx is not found

What else can I try to report back to give a better picture as to what I’m facing? I get the impression that I just need to hit the right repository, that has the right driver, with the correct install command line and all will be well.

A little more detail

i ran:

sudo lspci VGA

and the feedback on the card is

00:01.0 VGA compatible controller: Advanced micro Devices [AMD/ATI] Carizzo (Rev C4)

After carefully going though this link of instructions…

I basically keyed this in 1st:

sudo zypper ar -n FGLRX -cgf

then i keyed in

sudo zypper in fglrx_xpic_SUSE421

It installed, this is something that had not occurred previously nor as extensily.

Once done, I rebooted. Now, still get just the command line prompt.

Key in startx and press enter, and it craps out jsut like before, and renders the windows useless and have to punt by the powerswitch.

On the positive side, it no longer complains about the no find on the backlight controller.

I could sure use some help in this matter. Surely others have bought this Radeon APU and are running Leap 42.1.

I’m seeing that Leap 42.1 is based on Linux Kernel 4.1, and that Ubuntu Desktop 15.1 is based on 4.2, which mentions in its release notes that 4.2 newly supports the newer AMDGPU’s, interesting. Looks like this APU I’m running isn’t really supported by Leap just yet, and this would explain why I can’t seem to get a GUI to gen up.

Well with open source true but the proprietary driver should work. Did you modify the grub options??? if so set them back to normal