Suse don't start correctly

i just installed OpenSuse 11.2 whiteout problems, once finished i reboot my eeepc, but the startup stops at :

Starting udevd:
Loading drivers, configuring devices

pleaze can anyone help me ?

Seems there’s a problem loading some drivers. I’ll try to help you a little bit, until a guru arrives. :wink:

Hopefully, you should be able to boot into Failsafe mode. Choose that option in Grub when you boot. Then open a Terminal window and execute the following commands:

dsmeg | grep udev

Try also:

dsmeg | grep driver

Post the outputs here so that others can help you.

Thanks for replying, yes i can boot from safemode thank god,

the two commends give nothing, no outputs at all !!

Sorry, I only realized now there was a typo in the commands I sent you. I meant:

dmesg | grep udev


dmesg | grep driver

The command “dmesg” prints output from /var/log/boot.msg, and “grep” searches that output for words/phrases (udev, driver, etc). If there’s a problem related to udev when booting, it should show up there.

Ok, everything looks normal :

# dmesg | grep udev
    1.681379] udev: starting version 146  
    9.536154] udev: starting version 146
# dmesg | grep driver
    0.000000] Using APIC driver default     
    0.005753] Performance Counters: Atom events, Intel PMU driver.
    0.273753] ACPI: EC: driver started in interrupt mode          
    0.315006] usbcore: registered new interface driver usbfs      
    0.315075] usbcore: registered new interface driver hub        
    0.315180] usbcore: registered new device driver usb           
    0.712134] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
    0.712994] pcieport-driver 0000:00:1c.0: irq 16 for MSI/MSI-X                  
    0.713015] pcieport-driver 0000:00:1c.0: setting latency timer to 64           
    0.713327] pcieport-driver 0000:00:1c.1: irq 17 for MSI/MSI-X                  
    0.713347] pcieport-driver 0000:00:1c.1: setting latency timer to 64           
    0.713655] pcieport-driver 0000:00:1c.2: irq 18 for MSI/MSI-X                  
    0.713675] pcieport-driver 0000:00:1c.2: setting latency timer to 64           
    0.713980] pcieport-driver 0000:00:1c.3: irq 19 for MSI/MSI-X                  
    0.714000] pcieport-driver 0000:00:1c.3: setting latency timer to 64           
    1.127113] Non-volatile memory driver v1.3                                     
    1.127668] Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled            
    2.277726] uhci_hcd: USB Universal Host Controller Interface driver            
   10.501614] Initializing USB Mass Storage driver...                             
   10.821571] usbcore: registered new interface driver usb-storage                
   11.003056] usbcore: registered new interface driver usbserial                  
   11.131413] usbcore: registered new interface driver uvcvideo                   
   11.140787] USB Video Class driver (v0.1.0)                                     
   11.220444] usbcore: registered new interface driver usbserial_generic          
   11.325619] acerhdf: Acer Aspire One Fan driver, v.0.5.13                       
   11.483977] usbcore: registered new interface driver option                     
   11.799470] Broadcom 43xx driver loaded  Features: PML, Firmware-ID: FW13 ]    
   12.165799] Uniform CD-ROM driver Revision: 3.20                                
   97.837641] PPP generic driver version 2.4.2                                    
  595.573876] Uniform Multi-Platform E-IDE driver                                 
  595.611179] ide-cd driver 5.00                                                  
  595.655159] ide-gd driver 1.18

why the safemode start correctly ?

why the safemode start correctly ?

By this do you mean it boots to a desktop?

The above isn’t particularly helpful, as it is a successful boot. As to why failsafe works if you look at the kernel line from grub …

apm=off No advanced power management noresume nosmp No Symmetric Multiprocessing maxcpus=0 edd=off Extended Data Definition(probe monitor) powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe I think this is loading xorg.conf.install

The strange thing is I’m not to sure what in that lot would stall at udev and driver loading, of the above I’m inclined to think either edd or apm what you can do is at the grub choice screen.

First go to non graphic grub esc, choose the normal one, e to edit go down to the kernel line, e to edit and add one/some of the parameters till you find the combination that works for you. When you find the combination you can make it persistent by editing boot/grub/menu.lst it may be possible to use the boot module in yast.

What model eepc do you have? If it’s on of the smaller screens, it may be the video driver.
Check the screen resolution is set correctly.
Since you can get into safe mode, update the software (yast2>software>update) if you haven’t already done so.
I use suse on a samsung nc10 and an acer d150 with no problems. Since most netbooks are similar hardware, suse should run on your eeepc.

Thanks i will do that now,

I have an Aspire One D250, you think updating can stop this problem ?

eliach do the update first it is possible it is the video driver, you can test by using the xfailsafe if this boots then I suspect whych is correct.

You could look at the xorg log, but you might find it easier to amend a 3 from graphic grub on the line at the bottom so you have no gui then startx manually, after that fails then look at the log irrc.

egrep "EE|WW" /var/log/Xorg.0.log

But I would try the update first.

Thanks everybody,
It’s worked with apm=off Option, is that safe to run my eeepc with apm off ?

Should be fine it’s advanced power management, irrc it’ll just mean you may lose some of the advanced power management abilities. Exactly what I’m not sure but something like i.e the monitor going to standby after x mins.

I’m updating now, hope i would start normally my eee !

Doesn’t Opensuse Use the ACPI too?

Heah you’re taking me some where I don’t know(Can you tell my monitor doesn’t go to standby) but as the failsafe kernel line doesn’t have acpi I would presume it is fundamentally the same(But what do I know).

Its just if they where different I would expect acpi to be off too in failsafe. For the few years I’ve been using linux power management has caused more than a few headaches.

Okai, i will see if updates will change anything, if not i don’t know if i should report this as a bug …

many thanks for you … i appreciate your help !!

You could try but maybe it is a buggy bios. I recall seeing ways of fixing but I have to admit I rarely play with the power management stuff.

It may be fixed if there is a newer bios fix, it is possible it is in the apm/acpi stack. Though afaik the power management stuff isn’t always plain sailing, regardless of distro, bios or gpu, though it has improved vastly in the last 18mths or so.

I don’t know how you guys are installing, but I used the dvd to install (the gnome live didn’t install ldap support which I need) and all went fine. It could be the live cds don’t have all the drivers for eeepc/netbooks.
If you update the system and reboot and it still hangs, reboot the system.
When you get the initial grub screen, type a 3 and then enter.
This will take you to single user mode where you can cofigure sax2 for the display.
At the terminal login for runlevel 3, login as root and type sax2.
Configure the display and then exit sax2.
Now type: init 5 and it will give you a graphic login.

If all the updates are correct, acpi and apm works out the box.

The updates fix it…
i think the new kernel solved this problem …

that’s good rotfl!


Glad you got it sorted.
I found that hiding the taskbar gives a bit more deskspace on a netbook.
Enjoy your opensuse.