suse could only read the last windows partition

I installed windows xp and suse11 in my computer. but when I mount windows partition C,D,E,F to suse /windows/C,/windows/D,/windows/E and /windows/F, I could find file of F under suse, the left ones are empty. How could I solve this problem?
thank you very much.

Have you has a look at YaST > System > Partitioner? This tool can help with enabling the mounting of these other partitions.

Two useful commands:

cat /etc/fstab
fdisk -l

Post output if you need further help.

Very good HOWTO here, (courtesy of one of our linux gurus).

cat /etc/fstab

/dev/disk/by-id/scsi-SATA_ST3160815AS_5RA6D9SP-part1 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3160815AS_5RA6D9SP-part5 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3160815AS_5RA6D9SP-part6 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3160815AS_5RA6D9SP-part2 /usr ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PF1B75S0RR0HVM-part7 /windows/F vfat users,gid=users,umask=0002,utf8=true,codepage=936 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0

fdisk -l

Disk /dev/sda: 80.0 GB, 80032038912 bytes
255 heads, 63 sectors/track, 9730 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x13dbf84d

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1912 15358108+ 7 HPFS/NTFS
/dev/sda2 1913 9729 62790052+ f W95 Ext’d (LBA)
/dev/sda5 1913 3824 15358108+ 7 HPFS/NTFS
/dev/sda6 3825 6374 20482843+ 7 HPFS/NTFS
/dev/sda7 6375 9729 26949006 b W95 FAT32

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2b369736

Device Boot Start End Blocks Id System
/dev/sdb1 1 392 3148708+ 82 Linux swap / Solaris
/dev/sdb2 393 4309 31463302+ 83 Linux
/dev/sdb3 4310 19457 121676310 f W95 Ext’d (LBA)
/dev/sdb5 4310 6920 20972826 83 Linux
/dev/sdb6 6921 19457 100703421 83 Linux

/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PF1B75S0RR0HVM-part7 /windows/F vfat users,gid=users,umask=0002,utf8=true,codepage=936 0 0

So you can see the above line in your /etc/fstab config explains why only one ‘windows’ partition is mounting. The other NTFS partitions located on sda can be mounted by adding similar fstab entries. For example, /dev/sda1 is an NTFS partition. You could mount it at boot by adding a line like this:

/dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_X5CX6959T-part1 /windows/C ntfs-3g users,gid=users,fmask=113,dmask=002,locale=en_US.UTF-8 0 0

However, the easiest way to enable mounting of these partitions is by using the graphical yast partitioner tool. It will take care of the editing of fstab for you. If you want to get your hands dirty, you can edit fstab directly via an editor (as root user).

it doesn’t work. when I use your methods with yast2, it said:
“system error code:-3003”
"fail to mount ‘/dev/sda1’:operation not supported
mount is denied because NTFS is marked to be in use.choose one action:
choice 1: if you have windows then disconnect the external devices by clicking one the “safely remove hardware” icon in the windows taskbar then shutdown windows cleanly.
choice 2: if you don’t have windows then you can use the ‘force’ option for your own responsibility.
"
I don’t have any external device under my windows, then I choose choice 2. but it still doesn’t work.
could you please give me some advices?
thanks

An NTFS volume has a dirty bit which can be set under certain conditions (involving possible inconsistencies with the data on the volume). It can happen if the machine is not shutdown properly with these volumes mounted for example. This bit needs to be reset first (unless you force the mounting).

If you can, I suggest you boot windows and perform a chkdsk /f on the affected volume. Some info here.

Good guide on mounting ntfs partitions:

HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11