Suse boot problem

Hello, all

I installed Suse 10.1 on my computer (dell dimension 8300). Installation process went well, every thing seemed fine, I can even install several programs (and these programs also worked fine).

The problem happened when I restarted the computer:

the boot screen came up (which showed three boot options: Suse 10.1, floppy, and fail safe), however, after I chose Suse 10.1 option and entered, the screen went black, and the computer restarted again; next, the boot screen again came up , and I choose Suse 10.1 option and entered, and again the computer restart…

THe problem seems related to video card configuration. but I don’t how to fix it. CAn some one give me some help?

I guess there must be some reason for using 10.1?

Did you try failsafe?

I tried failsafe, it works. However I am quite new to linux, so I am not familar with the command line mode.

I tried to install new graphic driver using YAST by refering “”,
However, YAST tells me there is some “dependency conflict” so that new drive package can not be installed.

Please help!

In fact, I also tried Suse 10.3, but the same problem exists

OK, see if this will get you going

boot in failsafe
at the prompt login as root - type:
root (enter)
then type your root password (cursor does not move and text does not display)!! (enter)

now type and then hit enter:
sax2 -r -m 0=vesa


I tried your method. However, after I hit “Enter”, the screen simply became black within 5-10 seconds. So i have to restart the computer, and the old problem still exists.

are you saying you cannot login as root?

try going to the failsafe option, then use backspace to clear any text in the space lower down and then type the number : 3
just the number, that’s it

press enter
and what I said earlier

sorry for late reply.

I did log in as root and did every thing you had mentioned. however, it still doesn’t work.

Is there a way I can re-install Nvidia driver as “”?
I tried, but it says there is some dependency problem. How to solve those problems?

the most strange thing is: SOMETIMES it can boot successfully, as it is now. Can I do sth NOW in graphic mode?

First, you need to be sure you are using instructions that match the version you have installed. The link is for 10.2; you had installed 10.1.

Second, there is more than one version of the nvidia graphics driver, depending on which card you have.

And third, there are two different ways to install that driver; one from the software repository which is a binary version that matches the current kernel, and the other is a source-code version which you can compile against whatever kernel you have installed but that version requires you to have also installed the “kernel-sources”, “gcc” (compiler), and “make” (prep and build) packages.

The preferred method is the first one, from the software repository. If you look back at the linked page, under the 10.3 section, you will see two 1-click installs (a 1-click sets up the repository and does the installation for you), one for more recent nvidia cards and the other for legacy cards. The cards are listed so you can determine which is the right driver.

Now, you can try the 1-click, but my guess is that it will fail because the driver in that repository is matched to a kernel version which is later than what you have on the 10.3 installation (that is, there were kernel updates to 10.3 after the CD/DVD you have was produced). If it fails, you can try installing the 10.3 kernel that matches that nvidia driver with zypper (a command-line software package tool) . . . boot into init 3 which takes you to a command prompt, and then login or switch to root (“su” is the switch command). Then do this (exactly!):

zypper addrepo  openSUSE-10.3-Updates

If you get an error saying it already exists, that’s OK. We just need to be sure it got added during the installation. If it wasn’t, this will do that. Then do this:

zypper addrepo  nvidia-repo

That will add the nvidia repository. Then do:

zypper install kernel-default

That will upgrade the kernel to the latest for 10.3. At this point, you MUST reboot and get back to where you were at the command prompt as root, as above. Then at the prompt do one (and only one) of the following, depending on which matches your card from the list at the link above.

zypper install x11-video-nvidiaG01


zypper install x11-video-nvidia

You should now have the nvidia drivers and kernel module installed. Reboot. You may be started up in graphical mode, but may still need to configure your card and monitor. You do that by going to YaST on the menu, Hardware, Graphics Card. If you did not get into the gui and are still at the command prompt, do:

sax2 -r

And then reboot. If you got this far successfully but still no gui, post back exactly what you did and what happened for more instructions. If the kernel and nvidia driver got installed, we are very close to getting it all sorted out.

Thank you. But my current version is 10.1. Do you suggest I have to re-install the system to 10.3?

Yes, I do. If you look at that page you linked, you will notice that the instructions begin with 10.2. It’s been quite a while since 10.1, but as I recall, at that time nvidia was not providing the repository. The only alternative at that time was downloading the source script and compiling it, or using the open-source version (name of “nv”). But the open-source version does not have many of the capabilities that the nvidia driver does. Also, that long ago, the kernel in 10.1 is a much earlier version, and also the update repository is no longer active because support has been dropped for 10.1. Finally, software package management was significantly improved (and fixed) with 10.3; the commands above would not work in 10.1

You will also be much happier with 10.3 overall; it is one of the best versions in a long time.

Thank you. Just now, I found a way to make the re-boot work. So I decide to live with it for now. But any way, thank you very much for your advice.

You’re quite welcome. Please don’t hesitate to ask for any help you might need in the future. :slight_smile:

I most probably will.
Thank you again for your time.