Suse becomes "Black" after upgrade from KDE 4.4.4 to 4.6

I have upgraded my Suse 11.3 KDE installation from KDE 4.4.4 to KDE 4.6.
But after this upgrade, the screen has become black and above this black screen are more than 100 windows of “KDE Crash Handler”.

Presently I am writing this post through Win 7 partition.
Please help me save the Suse installation as I have lot of data stored on Suse partition.
Thanks in advance.

Can you log into the terminal (press 3 at boot screen)

Rename the ~/.kde4 (in your home) to .kde.old or something then try again to log into the GUI.

Can you please explain how to do this.
Whenever I switch on my computer, I get the option of logging in Suse, fail safe Suse and windows.
Entering in Failsafe mode gives some “terminal” type screen… I got into that but didn’t know how to get out of this. So had to unplug the power swich.
Please explain the way how to rename ~/.kde4

ok at the boot screen simple press the 3 key then select a normal boot. This should bring you to a terminal login. Log in as yourself

then type

mv ~/.kde4 ~/.ked4.old

then reboot by typing


I did it, nothing happened. It didn’t follow this command.
I noticed “~” sign was at a higher level in that command. But here it is at a mid level.

That is just because different fonts are used to render ‘~’ aka tilde. It signifies that the filepath is your homedirectory, i.e. ‘/home/[username]/.kde’ is the same as ‘~/.kde’

And as an aside, you do not happen to have (a) an Nvidia GPU, (b) are using the 260.x driver and (c) are on 32-bit architecture?

You might find it helpful to learn a few very basic terminal commands. Try this:


That will list your current directory. If you see Desktop, Documents, Download, etc., then you’re in your home directory. Now enter

ls -a

That will show you hidden files and directories as well. Hidden entries start with “.”

Now use the “mv” (move) command to rename the “.kde4” subdirectory:

mv -i .kde4 .kde4_old

You don’t need the “~” since you are already in your home directory. The “-i” option will warn you if your target file already exists.

I got the folder renamed through the command.

Output of ls -a yields:
ImageShack® - Online Photo and Video Hosting

But the problem still persists.

As @Lord_Emsworth already asked are you running 32-bit openSUSE and if you are do you have an NVIDIA graphics card and if you do are you using the 260.x closed driver?

I am on a 32-bit machine. Yes I have a nVIDIA Graphic card inside this computer. But I have no knowledge of this 260.x driver.

What is the output of:

rpm -qa '*nvidia*'

That should tell us if you are using the closed source driver and if you are what version. If you are running the 260.x driver then the problem may be able to be fixed by downgrading the NVIDIA driver to 256.53.

Presently I am saving my data on Suse partition through Ubuntu Live CD. I tried this process with Suse Live CD, but that forbid me to access the Suse files. Please let me save my data with this Live CD. i will post the output of nvidia driver after saving the data.
Thanks once again.

I think its 260 one. I have attached the pic below:
ImageShack® - Online Photo and Video Hosting

What should I do now?

Just now i witnessed one more strange thing:
I rebooted into Suse normal mode. Got the same black screen and over it the KDE Crash Handler windows (>100 in number) and continuously increasing. in one of these windows, I clicked “Report Bug”. this opened another window and lots of info was written on it along with a blue colored net link. Where I clicked and opened the Konqueror window.
Through this Konqueror I was able to open Suse website, but was not able to log in since Crash Handler windows kept on popping up and prevented me from typing anything.
I feel, if there was a Graphic card problem, I should not have been able to see even this Konqueror or KDE Crash handler window. (I may be wrong in assuming so)

anyway i have saved my data now. What should I do now.? (Thanks once again)

On 2011-02-16 15:06, babloo75 wrote:
> I think its 260 one. I have attached the pic below:
> ‘ImageShack® - Online Photo and Video Hosting’
> (
> What should I do now?

Downgrade it.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You need to get rid of that driver version. There is a long, long thread about issues with the configuration that you have, i.e. Nvidia 260, 32bit: NVIDIA 260.19 Issues

In short, you need to downgrade to 256.x.

There are several ways to do it.

I. The so-called hard way.

Instructions for installing the .run file can be found either here: SDB:NVIDIA the hard way - openSUSE
Or here: Nvidia for Newbies part 1

The run file, 32-bit:

But before you do this, I think you need to deinstall the Nvidia 260 driver. Can be done via YaST though.

II. Find older .rpm for 256.xx kernel modules and install via YaST.

A quick search for Nvidia drivers: Search Results
turn up a few things, but I am not 100% sure if that is what you need. For instance:
Index of /repositories/home:/estellnb:/nouveau/openSUSE_11.3_Update_standard


III. Use jdmcdaniel3’s LNVHW

Further info here: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3

jdmcdaniel3’s LNVHW may the best option.

And lest I forget, you may still be able to login to an IceWM session. It should be available at the login screen if you installed from the KDE Live-CD.

Yes I have got Live CD. But I have no knowledge of this “IceWM session”

And the login screen you can select your session type. Either by clicking on “Menu” in the bottom left corner, or with the shortcut Alt-M, and then selecting “Session type”>“IceWM”.

I guess the IceWM is there, for just these cases.

I meant of cource, that you boot your normal openSuSE install on your harddrive. And not boot a live CD. (It is just that an install that was made with a KDE Live CD includes the IceWM. So that if you installed from a live CD you should have IceWM available.)

(Sorry for the new post, the time to edit was up.)