SUSE ate my DVD and won't give it back

Greetings All,

I am experiencing a strange phenomena with SUSE 11.4.

I can put a CD or DVD in the drive, mount it, read it & unmount it. But I cannot take the disk out
of the drive once it has been place in the drive without

  1. Physically holding the CD draw open
  2. Shutting down SUSE.

As soon as the drive starts to eject the disk, the draw is forced closed again. This happens if the
eject button is pressed, or the** sudo eject** command is issued. For some reason, the draw is being instructed to close again almost immediately after it opens. I’ve managed to extract disks by grabbing the draw when it starts to open, but I’m afraid I will damage the drive this way.

I do not think this is a hardware issue, as other OSs run on this system do not seem to have this
problem.

Any ideas on what could be causing this and how to solve it?

Thanx in advance.

Rich

Have you tried any of these threads:
DVD tray won’t re-open
Unable to Eject CD Drive
CD/DVD drive not opening on multi-disk software install

These threads seem to refer to the drive not ejecting at all. It WILL eject, but then it changes it’s mind real quick…

Rich

this reads like a physical driver eject mechanism alignment problem.

What if you gently (very very very gently) tap the side of the drive when it ejects?

No change. This ONLY happens if there is a CD/DVD in the drive, and the drive has been mounted at some time. If the drive is empty, eject works normally.
I’ve already changed the drive when this started thinking that it was a hardware problem.

Rich

Try eject -T

Rich, I can confirm that. Had the same problem on my (now gone) openSUSE 11.3 Desktop with KDE4.6.0.

have you used a paper clip in the tiny hole in the front of the drive ???
it might be partly covered up - mine in on the DELL xps

But the hole is there .

I have also come across where users are using kde but have gnome installed too and some crossover in the config has nautilus mounting the cd/dvd and it’s not obvious.
You can open nautilus in kde and check. If this might apply, check and see if nautilus will eject it.

This might be the answer.
Yes, I have both KDE & GNOME installed. This morning, I started a Nautilus window in KDE, and the problem seems to have resolved itself (at least for now).
Possibly something in GNOME needed to be initialized.

Thanx!

Rich

Try setting nautilus NOT to auto mount anything
If you use kde mostly, this will not be a annoyance