suse and yast repositories version 10.

I am not familiar with suse package management and have a few boxes running suse 10.0. I want to upgrade the machines via internet repos.

I am using suse 10.0 according to /etc/issue. I am then trying to use yast via ncurses interface. I disable the cdrom repo and try and add a http or ftp repo for suse. Every time I try a repo it either does not work as expected or I get an error.

The error is ERROR(InstSrc:E_no_instsrc_on_media)

By not working as expected I mean it saves the repo but then when i go to software management i get an Update Problem – see help message when trying to list rpms.

Here is an example of what I am trying to add for an installation source (quotes are not used just showing my exact string):

protocol: http checkbox checked
server name: “download.opensuse.org
directory on server: “distribution/10.3/repo/oss/”

I have tried with different repos without success.

I have a yast and a yast2 command.

I also tried trying to add version 11 repos as I would prefer to upgrade to that version but I ran into the same problems.

Can anyone assist ?

Can you try with the 11.1 ones. Maybe the 10.3/11.0 were moved or removed.

10.0 is too old. You should download the latest DVD/CD and do fresh installation instead of updating it.

I tried dirs download.opensuse.org

11.0
11.1
1.2-Milestone1
1.2-Milestone2

had the same problems.

I was trying to avoid doing a fresh install. I would prefer to just upgrade using package management system. Is this possible using suse or is a fresh install required to go from say 10.0 to 10.2 or 10.3 or 11.2 etc…

They are right. 10.0 is to old. 10.3 is either at the end of its life, or will be shortly. Your best bet is to go to 11.1. To do this, I would in no way suggest upgrading. Do a format and install.

The repos for 10.3 are still available. For how much longer, I don’t know.

10.3 OSS Index of /distribution/10.3/repo/oss
10.3 NON-OSS Index of /distribution/10.3/repo/non-oss

11.1 OSS Index of /distribution/11.1/repo/oss
11.1 NON-OSS Index of /distribution/11.1/repo/non-oss

After a bit of research 10.3 end of life will be openSUSE 10.3 - October 31st 2009

Reference: SUSE Linux Lifetime - openSUSE

shankos wrote:
> I am not familiar with suse package management and have a few boxes
> running suse 10.0.

CAUTION!

since you say you have a few boxes, i can GUESS that maybe you are
sheparding some servers…maybe those boxes are not running “suse
10.0” but actually running “openSUSE 10.0” or SUSE Linux Enterprise
Desktop (SLED) or SUSE Linux Enterprise Server (SLES) version 10…

if you are running SLED or SLES 10 then:

  • BOTH are supported by Novell and can be fully patched and updated
    through
  • they can be (i think) updated to version 11 (i think, check at novell)
  • but, this is not the place to learn, instead go to forums.novell.com

if you are actually running openSUSE 10.0 you have NOT had any
community provided security updates or patches since November 2007!

see: http://en.opensuse.org/SUSE_Linux_Lifetime and act accordingly!

as others have said, openSUSE 10.3 is currently supported until
November 2009 and you can try, but i’d guess you would be UNhappy with
trying to ‘upgrade’ from 10.0 to anything…(i’ve not seen an ‘old
head’ around here recommend trying)

instead: backup all data, test backup data, do a fresh install and
then restore data from backup…

CAUTION:

-openSUSE 11.x is NOT like what you may be used to (like 9.3 out of
Germany’s SuSE factory was generally stable and ready to roll in a
production environment…some folks say they are using openSUSE
11.x in a production environment…ask’em how long it took to get it
stable…

-if you want stable, long term support you really need to look at
SLED/SLES and purchase it (caveat: i don’t use either, i don’t work
for anyone, and i’m ‘selling’ anything!)

-for max chance at a stable, free, platform install openSUSE from DVD
while connected to the internet (for instant patching and updating
past the DVD image)

-if you need only a server then look closely at
http://en.opensuse.org/INSTALL_Local#Step_5:_Desktop_selection
and select the bottom option “Minimal Server Selection (Text mode)”

-if you need/want a desktop then install Gnome or KDE3.5 (just a
little above the server selection on the green screen)…

CAUTION: my strong recommendation is to avoid KDE4.1 unless you canNOT
live without eye-candy, instability, experimental frustration and
constant updates (which often breaks stuff–take a look at the posts here)

yes, i know that green screen says: "KDE 4.1 is the latest stable
desktop released by the KDE . . . "

which is, in my opinion liar-liar-pants-on-fire, wishful thinking,
unsupportable BS…

welcome to the new openSUSE…have fun.


natural_pilot

This is what I am running.

cat /etc/issue
Welcome to SUSE LINUX 10.0 (i586) - Kernel \r (\l).

According to the life cycle link provided
SUSE Linux Lifetime - openSUSE it looks as though I am running opensuse before it was named opensuse. I have a few boxes at work that i have inherited from someone else to manage.

I still can use the 10.3 repos with suse 10.0 install I have ??
As explained in my first post it does not work.

If i have to reinstall I would probably just use another linux distro I am familiar with rather then opensuse.

I would have preffered to upgrade as it is easier.

So it seems as though to go from version 10.0 to 10.3 I have reinstall.

And to go to version 11 (recommended) I have reinstall.

And now some one is telling me opensuse is not that stable anyway. So maybe I should just reinstall another linux distro if I cannot upgrade.

Mistake above should read.

I still CANT use the 10.3 repos with suse 10.0 install I have ??
As explained in my first post it does not work.

Upgrade is not recommended. You may reinstall (probably not formatting partitions where user data / home directories are kept).
It is up to you what distro you install. I presume that you are talking about servers and people are talking about “stability” issues mostly when they experience problems with GUI. My experience with openSUSE 11.x is that it rocks when used as just servers.

> cat /etc/issue
> Welcome to SUSE LINUX 10.0 (i586) - Kernel \r (\l).

mine says:
Welcome to openSUSE 10.3 (i586) - Kernel \r (\l).

i have NO idea what a SLED or SLES 10 would report…maybe someone
here can definitively say if you have a Novell SUSE Linux Enterprise
Server 10 or what is now named openSUSE 10.0

(or you could join forums.novell.com and ask there!)

i BELIEVE you have SLES 10, which is still supported by Novell if
you purchase the update service on an annual basis…

if you have Novell’s commercial Linux server offering AND their
update service, there is no driving need i’m aware of to ‘upgrade’ to
version 11, as what you have has all the security patches in place,
and is supported for a few years more…

however, if you have not been using the paid for update service, you
might appreciate that it is by design that SLED/S cannot use the repos
for openSUSE…you might imagine that there are differently named and
stocked repos for their commercial [read: money maker] product…

but, if you are running openSUSE 10.0 (unpatched for two+ years) you
certainly need to do something…

i agree with the other poster who says that MOST instability problems
with openSUSE 11.x come from the graphical user interface…

you can find folks using openSUSE 11.x in headless (and no GUI
installed) server service…


.~.
/V
natural_pilot /( )
^^-^^

i will try asking on novell forums for a definate answer as to if i actually have sles or sled.

To have an idea of what version you are using, the boot screen usually gives you:
OpenSuse 2.xxx
or
Suse Linux Enterprise Desktop/Server …

If you have suse you need to have a subscription and you can upgrade via dvd.

if you have OpenSuse, you can get the network install disk and upgrade via a network, but as the guys have said, backup the home directory first and do a fresh install.