Suse and Atheros wireless

I just bought an HP dv6910us laptop and installed Suse 11.0. I cannot get the wireless card to work, it recognizes it but says its not configured. The model of the card is ar242. It wont let me configure it. I am a newbie to linux, please help…:frowning:

have you installed the madwifi drivers ? have you configured it via YaST - network devices - network settings ?


I tried the madwifi drivers last night, and suse just stopped working all together… would not boot up,I had to reinstall.

try the drivers from here Index of /repositories/home:/schmolle1980 some people have reported better success with these drivers


I understand how frustrating this can be. I can try and elaborate on what deltaflyer44 already mentioned, as I installed it only this morning on a fresh 11.0 install with KDE4:

You need the kernel modules package in conjunction with madwifi to get this card working.

Install madwifi from the OSS repository (I installed version just this morning), which, if not already enabled, can be added in Yast in “Software Repositories.”

Note: If not already installed (those installed will be shown in the list), choose the OSS repository from the community repositories, or add the following as a URL:

Index of /distribution/11.0/repo/oss

Once the madwifi package is installed, fetch the “madwifi-kmp” from the build service at this address:

In order to download the correct kmp package (i.e. default, pae, etc) run the following command in the terminal to determine which kernel you are running:

uname -a

I am assuming for the sake of this guide that you’re running the default kernel and that you have already updated it through Yast to the 2.6.25-16 version as I did this morning. My output on a 64-bit machine of ‘uname -a’ looks like this: #1 SMP 2008-08-21 00:34:25 +0200 x86_64 x86_64 x86_64 GNU/Linux

At the build service site, I would choose the matching madwifi-kmp-default package corresponding to my kernel,… I recommend using the “one-click install” feature to the right, as this chooses for you the appropriate package (or at least should). My AR242 used the “trunk+3717…” version from the repository deltaflyer44 listed:

Index of /repositories/home:/schmolle1980

Once you install the kmp package, restart your computer. Open Yast > Network Devices > Network Settings, and configure your wireless card with the information from the network you wish to connect to. Under the hardware tab, be sure to select the “ath_pci” module instead of the “ath5k.” I would actually blacklist the latter by adding it to your /etc/modprobe.d/blacklist file with root permissions and your preferable text editor.
I also prefer to select “Autoconnect” at the end of the network configuration–to see if the settings have actually been applied, though this isn’t absolutely necessary, and may not be your wish. Apply the settings, then:

Restart, and voila!

Hope this helps. This is the one thing I wish worked out of the box :wink:

frosch62 wrote:
> Hope this helps. This is the one thing I wish worked out of the box :wink:

Thanks for the details. There have been a lot of Atheros changes to
the kernel in recent weeks. It will get better soon. In fact, I
suspect that the built-in driver will work with openSUSE 11.1.


I can confirm that my normally troublesome Atheros 5007eg, which required the use of ndiswrapper or a patched madwifi, is fully functional on Opensuse 11.1 Beta 1 and fully supported by the kernel. If you’re still having issues, all seems to be on track for December with that card.

Yay :slight_smile: