SUSE 42.1 - VNC & desktop slider

Hi, I just installed OpenSUSE 42.1 on my PC and have a few questions. I installed x11vnc and the problem is when I try to connect to the PC via VNC without monitor plugged in. I just have black screen and I see only the cursor. How can I fix this if it’s possible ? Can I somehow render the desktop even without monitor attached ? It’s not that I will use that PC without monitor all the time, but I need to work there sometimes without monitor.

The second problem is, when I add desktop icons on my desktop and I add it to the bottom, it creates a desktop slider so it will make my desktop bigger. I want to turn that off. Is that possible ?

Thanks … If you need additional informations, let me know.

Well, you could at least explain which desktop (KDE, Gnome, Xfce, …).

Ooops, sorry. I’m using KDE

Update: managed to solve it by adding parameter “nomodeset” into boot loader options. Well now I have a new problem. I now see the desktop, but the resolution seems to be 640x320. Any possible way to get the resolution like 1024*768 without monitor attached ?

UPDATE 2: If I add the parameter “nomodeset” into boot loader, I can now connect via VNC. The problem comes, when I plug in monitor after the PC is already loaded. The resolution won’t adapt to the screen resolution. How can I change that ?

When I start the PC without monitor plugged in and then connect the monitor after the system is up, it receives no signal and won’t turn on. This is a log:

2016-08-26T14:35:20.408673+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: RRotify_OutputChange
2016-08-26T14:35:20.409304+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Output: 71
2016-08-26T14:35:20.409707+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011CRTC: 0
2016-08-26T14:35:20.410065+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Mode: 0
2016-08-26T14:35:20.410428+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Rotation: “Rotate_0”
2016-08-26T14:35:20.410784+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Connection: “Connected”
2016-08-26T14:35:20.411134+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Subpixel Order: 0
2016-08-26T14:35:20.411542+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: RRScreenChangeNotify
2016-08-26T14:35:20.411890+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Window: 39845892
2016-08-26T14:35:20.412226+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Root: 213
2016-08-26T14:35:20.412560+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Rotation: “Rotate_0”
2016-08-26T14:35:20.415454+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Rotation: “Rotate_0”
2016-08-26T14:35:20.415789+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Connection: “Connected”
2016-08-26T14:35:20.416092+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xcb.helper: #011Subpixel Order: 0
2016-08-26T14:35:20.416390+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: XRandROutput 71 update
2016-08-26T14:35:20.416711+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011m_connected: 1
2016-08-26T14:35:20.417023+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011m_crtc QObject(0x0)
2016-08-26T14:35:20.417334+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011CRTC: 0
2016-08-26T14:35:20.417640+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011MODE: 0
2016-08-26T14:35:20.417946+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011Connection: 0
2016-08-26T14:35:20.418262+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011Primary: false
2016-08-26T14:35:20.418562+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: Output 71 : connected = true , enabled = false
2016-08-26T14:35:20.432964+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: XRandROutput 71 update
2016-08-26T14:35:20.433374+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011m_connected: 0
2016-08-26T14:35:20.433711+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011m_crtc QObject(0x0)
2016-08-26T14:35:20.434023+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011CRTC: 0
2016-08-26T14:35:20.434327+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011MODE: 0
2016-08-26T14:35:20.434627+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011Connection: 0
2016-08-26T14:35:20.434927+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: #011Primary: false
2016-08-26T14:35:20.435249+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: Output 71 : connected = true , enabled = false
2016-08-26T14:35:20.928382+02:00 filialkaxxx org.kde.KScreen[1615]: kscreen.xrandr: Emitting configChanged()

nomodeset uses fall back drivers. You did not say what video card/driver you use

Intel HD integrated graphics. - drivers which downloaded automatically from 42.1 installation.

Is the CPU a i7 (ie Skylake)? If so you need Kernel 4.3+ to properly support it.

No, no … It’s intel g3240

Not an Intel lover so maybe some one else has an idea now that we know the hardware. :’(

And what about the desktop slider ? Any ideas ? When I put an icon to the bottom of the desktop, it creates a slider and expands the desktop… I want to turn that feature off.